Dual Monitor Configuration - with KVM Switch

Screen resolution, 3D Acceleration, nVidia, ATI
Forum rules
Before you post please read this
Crusader
Level 2
Level 2
Posts: 64
Joined: Thu Oct 09, 2014 12:22 pm

Dual Monitor Configuration - with KVM Switch

Postby Crusader » Sun Nov 05, 2017 9:10 pm

Hello,

I have been privileged to get help from this forum before and am requesting help again - for a related issue.

Issue
I recently hooked up my work and personal laptops to a 2-port ATEN KVM (model CS1742) switch. The work laptop is fine, but when I switch to my personal laptop, graphics are all messed up and frozen and I have to restart my personal laptop essentially every time (Display parameters are set as indicated below). I have provided relevant details below and will be happy to share others as needed.

As part of my research, I read manipulating Xorg files used to be the way to go; however, it appears Xorg files don't exist (?) anymore. A few years ago, I had a gentle soul on this forum help me with display issues; this time, a KVM switch has joined the fray.

System Details (not that I understand them)

Code: Select all

System:    Host: a-UL80VT Kernel: 4.8.0-53-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: Cinnamon 3.4.3 (Gtk 3.18.9-1ubuntu3.3) dm: lightdm Distro: Linux Mint 18.2 Sonya
Machine:   Mobo: ASUSTeK model: UL80VT v: 1.0 Bios: American Megatrends v: 214 date: 01/17/2011
CPU:       Dual core Intel U7300 (-MCP-) cache: 3072 KB
           flags: (lm nx sse sse2 sse3 sse4_1 ssse3 vmx) bmips: 6932
           clock speeds: min/max: 800/1300 MHz 1: 800 MHz 2: 1300 MHz
Graphics:  Card-1: Intel Mobile 4 Series Integrated Graphics Controller
           bus-ID: 00:02.0 chip-ID: 8086:2a42
           Card-2: NVIDIA GT218M [GeForce G210M] bus-ID: 01:00.0 chip-ID: 10de:0a74
           Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa) FAILED: nouveau
           Resolution: 1920x1080@60.00hz, 1280x1024@60.02hz
           GLX Renderer: Mesa DRI Mobile Intel GM45 Express
           GLX Version: 2.1 Mesa 12.0.6 Direct Rendering: Yes
Audio:     Card-1 NVIDIA High Definition Audio Controller
           driver: snd_hda_intel bus-ID: 01:00.1 chip-ID: 10de:0be3
           Card-2 Intel 82801I (ICH9 Family) HD Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0 chip-ID: 8086:293e
           Sound: Advanced Linux Sound Architecture v: k4.8.0-53-generic
Network:   Card-1: Qualcomm Atheros AR9285 Wireless Network Adapter (PCI-Express)
           driver: ath9k bus-ID: 03:00.0 chip-ID: 168c:002b
           IF: wlp3s0 state: up mac: <filter>
           Card-2: Qualcomm Atheros AR8131 Gigabit Ethernet
           driver: atl1c v: 1.0.1.1-NAPI port: ec00 bus-ID: 04:00.0 chip-ID: 1969:1063
           IF: enp4s0 state: down mac: <filter>
Drives:    HDD Total Size: 500.1GB (5.6% used)
           ID-1: /dev/sda model: ST500LT012 size: 500.1GB serial: W3P0XRC7
Partition: ID-1: / size: 308G used: 23G (8%) fs: ext4 dev: /dev/sda5
           ID-2: swap-1 size: 4.26GB used: 0.00GB (0%) fs: swap dev: /dev/sda6
RAID:      System: supported: N/A
           No RAID devices: /proc/mdstat, md_mod kernel module present
           Unused Devices: none
Sensors:   System Temperatures: cpu: 60.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Repos:     Active apt sources in file: /etc/apt/sources.list.d/official-package-repositories.list
           deb http: //packages.linuxmint.com sonya main upstream import backport
           deb http: //archive.ubuntu.com/ubuntu xenial main restricted universe multiverse
           deb http: //archive.ubuntu.com/ubuntu xenial-updates main restricted universe multiverse
           deb http: //archive.ubuntu.com/ubuntu xenial-backports main restricted universe multiverse
           deb http: //security.ubuntu.com/ubuntu/ xenial-security main restricted universe multiverse
           deb http: //archive.canonical.com/ubuntu/ xenial partner
Info:      Processes: 185 Uptime: 4:22 Memory: 1352.4/3916.8MB
           Init: systemd v: 229 runlevel: 5 default: 2 Gcc sys: 5.4.0
           Client: Unknown python2.7 client inxi: 2.2.35

OS:        Mint (used daily) and Windows (used ocassionally).

Monitors:  ASUS VS238 VGA 1920X1080 67KHz 60Hz set at 1920 x 1080 (16:9)
           HP Compaq LA1951g set at 1280 x 1024 (5:4) - serves as an extension of the ASUS (primary) monitor           

All help will be greatly appreciated.
LO 5.x on Mint 18.2 Cinnamon
In a world without walls, who needs Windows

Return to “Graphic Cards & Monitors”