Can I get this Dell/Intel combo to display higher resolution?

Screen resolution, 3D Acceleration, nVidia, ATI
Forum rules
Before you post please read this
Cliff_G
Level 1
Level 1
Posts: 3
Joined: Wed Nov 08, 2017 7:01 am

Can I get this Dell/Intel combo to display higher resolution?

Postby Cliff_G » Thu Nov 09, 2017 1:48 pm

So far delighted with my Linux Mint re-install. This is on an old Dell D610 (2005 or so) so I went for the oldest currently supported Mint, Qiana with Mate. Have also tried a few other distros - Lubuntu, Xubuntu and Q4OS but they all had problems of one sort or another, but also all shared the same issue with screen resolution:

This screen is capable of some big resolutions, which is why I bought the machine originally, and was running these fine under WinXP (at least 1280*something and possibly up to 1600*1200, I forget) but all the Linux's have been limited to 1024*768 on this machine. Looking around the forum here I am not sure I will do any better with LM, but thought I would ask anyway.

The driver manager says "No proprietary drivers are in use"

$ inxi -Fxz output:

------------------------
System: Host: APTL-03 Kernel: 3.13.0-24-generic i686 (32 bit, gcc: 4.8.2) Desktop: N/A Distro: Linux Mint 17 Qiana
Machine: System: Dell product: Latitude D610
Mobo: Dell model: 0D4571 Bios: Dell version: A03 date: 03/02/2005
CPU: Single core Intel Pentium M (-UP-) cache: 2048 KB flags: (nx sse sse2) bmips: 3192.06 clocked at 1600.00 MHz
Graphics: Card: Intel Mobile 915GM/GMS/910GML Express Graphics Controller bus-ID: 00:02.0
X.Org: 1.15.1 drivers: intel (unloaded: fbdev,vesa) Resolution: 1024x768@60.0hz
GLX Renderer: Mesa DRI Intel 915GM x86/MMX/SSE2 GLX Version: 1.4 Mesa 10.1.0 Direct Rendering: Yes
Audio: Card: Intel 82801FB/FBM/FR/FW/FRW (ICH6 Family) AC'97 Audio Controller driver: snd_intel8x0 ports: ed00 ec40 bus-ID: 00:1e.2
Sound: Advanced Linux Sound Architecture ver: k3.13.0-24-generic
Network: Card-1: Broadcom NetXtreme BCM5751 Gigabit Ethernet PCI Express driver: tg3 ver: 3.134 bus-ID: 02:00.0
IF: eth0 state: down mac: <filter>
Card-2: Intel PRO/Wireless 2200BG [Calexico2] Network Connection driver: ipw2200 ver: 1.2.2kmprq bus-ID: 03:03.0
IF: eth1 state: up mac: <filter>
Drives: HDD Total Size: 80.0GB (6.4% used) 1: id: /dev/sda model: ST980815A size: 80.0GB
Partition: ID: / size: 73G used: 4.8G (7%) fs: ext4 ID: swap-1 size: 1.33GB used: 0.00GB (0%) fs: swap
RAID: No RAID devices detected - /proc/mdstat and md_mod kernel raid module present
Sensors: None detected - is lm-sensors installed and configured?
Info: Processes: 141 Uptime: 28 min Memory: 558.8/1247.3MB Runlevel: 2 Gcc sys: 4.8.4 Client: Shell inxi: 1.8.4
-----------------------
also:
sudo lshw -C video
*-display:0
description: VGA compatible controller
product: Mobile 915GM/GMS/910GML Express Graphics Controller
vendor: Intel Corporation
physical id: 2
bus info: pci@0000:00:02.0
version: 03
width: 32 bits
clock: 33MHz
capabilities: pm vga_controller bus_master cap_list rom
configuration: driver=i915 latency=0
resources: irq:16 memory:dff00000-dff7ffff ioport:ec38(size=8) memory:c0000000-cfffffff memory:dfec0000-dfefffff
*-display:1 UNCLAIMED
description: Display controller
product: Mobile 915GM/GMS/910GML Express Graphics Controller
vendor: Intel Corporation
physical id: 2.1
bus info: pci@0000:00:02.1
version: 03
width: 32 bits
clock: 33MHz
capabilities: pm bus_master cap_list
configuration: latency=0
resources: memory:dff80000-dfffffff
-----------------------------------------------

I'm a fairly newbie Linux user so won't be up to anything to fancy, but not afraid of the odd Terminal session

Hoping & thanks in advance

Return to “Graphic Cards & Monitors”