Brightness Bug Dell XPS 17 3d Nvidia M555

Screen resolution, 3D Acceleration, nVidia, ATI
Forum rules
Before you post please read this
de5n
Level 1
Level 1
Posts: 1
Joined: Thu Nov 23, 2017 7:11 am

Brightness Bug Dell XPS 17 3d Nvidia M555

Postby de5n » Thu Nov 23, 2017 12:48 pm

The brightness of my laptop's screen is not changed at all when using the Fn-Keys. It is shown that brightness level is changed by pressing Fn F-4-f5, but display did not change. I checked if value of brightness is changed in /sys/class/backlight/dell_backlight. And yes, it is changed in files but no display. Also I noticed that after rebooting the system display brightness changes according to what we make before.

dmesg|grep 'ACPI: Video'
[ 1.506893] ACPI: Video Device [PEGP] (multi-head: yes rom: no post: no)

uname -a
Linux Dell-XPS-L702X 4.10.0-40-generic #44~16.04.1-Ubuntu SMP Thu Nov 9 15:37:44 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

I also changed xorg.conf
# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings: version 387.22 (buildd@lgw01-amd64-017) Tue Oct 31 00:34:18 UTC 2017

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
Option "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "type1"
Load "freetype"
Load "glx"
EndSection

Section "InputDevice"
# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "Monitor"
# HorizSync source: edid, VertRefresh source: edid
Identifier "Monitor0"
VendorName "Unknown"
ModelName "LGD"
HorizSync 67.0 - 137.0
VertRefresh 60.0 - 119.0
Option "DPMS"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce GT 555M"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "Stereo" "0"
Option "nvidiaXineramaInfoOrder" "DFP-2"
Option "metamodes" "DP-1: 1920x1080_120 +0+0, DP-2: nvidia-auto-select +1920+0"
Option "SLI" "Off"
Option "MultiGPU" "Off"
Option "BaseMosaic" "off"
Option "RegistryDwords" "EnableBrightnessControl=1"
SubSection "Display"
Depth 24
EndSubSection
EndSection


I also made some manipulates with GRUB but nothing works for me. Any idea hot to fix?

P.S. I performed every point from https://sites.google.com/site/easylinux ... adjustable
but failed.

Return to “Graphic Cards & Monitors”