Nvidia card switching from Intel card problem. Driver?

Screen resolution, 3D Acceleration, nVidia, ATI
Forum rules
Before you post please read this
Post Reply
gipcu
Level 1
Level 1
Posts: 1
Joined: Sun Nov 26, 2017 6:23 pm

Nvidia card switching from Intel card problem. Driver?

Post by gipcu » Sun Nov 26, 2017 6:51 pm

Hello

Linux Mint 18.2 Cinnamon 64-bit
Kernel: 4.11.0-14-generic

inxi -G

Code: Select all

Graphics:  Card-1: Intel 3rd Gen Core processor Graphics Controller
           Card-2: NVIDIA GF117M [GeForce 610M/710M/810M/820M / GT 620M/625M/630M/720M]
           Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa) FAILED: nouveau
           Resolution: 1366x768@60.05hz
           GLX Renderer: Mesa DRI Intel Ivybridge Mobile GLX Version: 3.0 Mesa 17.0.7
lshw -c video

Code: Select all

  *-display               
       description: 3D controller
       product: GF117M [GeForce 610M/710M/810M/820M / GT 620M/625M/630M/720M]
       vendor: NVIDIA Corporation
       physical id: 0
       bus info: pci@0000:01:00.0
       version: a1
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list rom
       configuration: driver=nouveau latency=0
       resources: irq:31 memory:f6000000-f6ffffff memory:e0000000-efffffff memory:f0000000-f1ffffff ioport:e000(size=128) memory:f7000000-f707ffff
  *-display
       description: VGA compatible controller
       product: 3rd Gen Core processor Graphics Controller
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 09
       width: 64 bits
       clock: 33MHz
       capabilities: msi pm vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:28 memory:f7400000-f77fffff memory:d0000000-dfffffff ioport:f000(size=64) memory:c0000-dffff
i have searched google for few hours but none of topics matches perfectly my issue and all rest solutions generally about this issue failed for me.

after kernel update i have problem with Nvidia card. Can't switch to nvidia. After i log in, i can see red square on bottom bar near date, wifi etc. It opens NVIDIA X Server Settings. Under PRIME Profiles Intel card is selected and there is option to select Nvidia card. Selecting Nvidia -> password -> popup that you need to relog -> relogin -> and still red square and Intel card selected. Line nothing happened.

now, i know lshw -c video says that driver for nvidia is nouveau but at the moment of executing lshw -c video command i switched in driver-manager back to nvidia, so i dont know why its still nouveau. ALSO before i tried nouveau, configuration line of nvidia card in lshw -c video command had no driver, looked like this:

Code: Select all

configuration: latency=0
I have tried

Code: Select all

sudo apt-get purge bumblebee*
sudo apt-get purge bbswitch*
sudo apt-get purge nvidia*
sudo apt-get --purge autoremove
and afterwards installing from driver-manager nvidia drivers again, but it still ends with red square and intel card selected.

also disabled Secure Boot Mode (cuz somewhere i read taht it might be also issue)

if i try nvidia-settings from command line, NVIDIA X Server Settings opens but i get:

Code: Select all

** Message: PRIME: Requires offloading
** Message: PRIME: is it supported? yes

ERROR: nvidia-settings could not find the registry key file. This file should have been installed along with this driver at
       /usr/share/nvidia/nvidia-application-profiles-key-documentation. The application profiles will continue to work, but values cannot be prepopulated or validated,
       and will not be listed in the help text. Please see the README for possible values and descriptions.
also had to upgrade shim-signed because had errors during instailng nvidia drivers through drive-manager

sudo prime-supported

Code: Select all

yes
What else output/screenshots would be needed to any of you willing to help me?

Post Reply

Return to “Graphics Cards & Monitors”