Installing AMDGPU-PRO in 18.3 breaks graphics

Screen resolution, 3D Acceleration, nVidia, ATI
Forum rules
Before you post please read this
User avatar
zorbama
Level 1
Level 1
Posts: 48
Joined: Tue Nov 20, 2012 5:20 pm
Contact:

Re: Installing AMDGPU-PRO in 18.3 breaks graphics

Post by zorbama » Fri Jan 05, 2018 11:48 am

andwbc wrote:I have just faced the same problem at Mint 18.3 Mate after installing xserver-xorg-hwe-16.04.
Try this:
sudo rm -r /var/opt/amdgpu-pro/
next and run again
./amdgpu-pro-install
You may need to force correction of errors by
sudo apt-get -f install
Interestingly enough, after reinstalling Mint and not installing the previous version of the driver, I installed xserver-xorg-hwe-16.04 and then installed the latest version, and it worked without a problem. I'm on the latest driver now.
"Inspiring quote" -Inspiring Person

Hachesse
Level 1
Level 1
Posts: 1
Joined: Sun Feb 11, 2018 1:57 pm

Re: Installing AMDGPU-PRO in 18.3 breaks graphics

Post by Hachesse » Sun Feb 11, 2018 2:18 pm

I spent hours on this too, after an 17.3 to 18.3 upgrade. I was desperately looking boot logs with same errors as above, and finally picket the right keywords to google...
The solution is to opt-in to a major change under the hood, the HWE, that is not triggered by the upgrade, for whatever reason. This simple command does it:

Code: Select all

sudo apt install --install-recommends linux-generic-hwe-16.04 xserver-xorg-hwe-16.04
Reboot, et voilà.
See some explanation there: http://www.omgubuntu.co.uk/2017/08/ubun ... s-released

This Mint upgrade really isn't for the faint of the heart for those running AMD graphics... Remember that before reaching this, you'll have downloaded 500Mb of driver, modified the install file ´amdgpu-install' so it mentions ´linuxmint' rather than ´ubuntu' at os-name check, launched it with ´sudo bash amdgpu-install', watched it download another Gb of whatever and recompile the kernel. Then this install. Pfew.

Citizen229
Level 5
Level 5
Posts: 736
Joined: Fri Nov 04, 2016 12:09 pm
Location: NW Ohio

Re: Installing AMDGPU-PRO in 18.3 breaks graphics

Post by Citizen229 » Sun Feb 11, 2018 11:14 pm

Did the OP upgrade kernel to series specified by the driver?
Folding@home Project
Team Linux Mint-76140
PM for info on how you can help. Or visit viewtopic.php?f=58&t=243792
Seeking GPU's, i5/7/9's , Ryzens.

Post Reply

Return to “Graphic Cards & Monitors”