Having trouble activating nvidia driver (fixed)

Screen resolution, 3D Acceleration, nVidia, ATI
Forum rules
Before you post please read this
supergreg
Level 1
Level 1
Posts: 6
Joined: Tue Nov 28, 2017 2:11 pm

Having trouble activating nvidia driver (fixed)

Postby supergreg » Thu Nov 30, 2017 5:05 pm

Hey all, while trying to figure out how to get the dock working with my displays on my Lenovo P50 I seem to have messed something up with my driver. I tried temporarily switching to the open source driver (xserver-xorg-video-nouveau, 1:1.0.12-1build2). It was glitchy so I tried to switch back, but it appears that I cannot. The nvidia Prime app says "Graphics card: Unknown" in the tray now. Although the driver manager says I have switched to the official nvidia driver, I am still seeing the same glitches on the screen as before. I'm not sure how to interpret the output of this command but it seems to me it's still trying to use the nouveau driver and something is not loading right:

Code: Select all

$ inxi -SMCGxI
System:    Host: boxybrown Kernel: 4.10.0-40-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: Cinnamon 3.6.6 (Gtk 2.24.30) Distro: Linux Mint 18.3 Sylvia
Machine:   System: LENOVO (portable) product: 20EN003LUS v: ThinkPad P50
           Mobo: LENOVO model: 20EN003LUS v: SDK0J40697 WIN Bios: LENOVO v: N1EET69W (1.42 ) date: 06/28/2017
CPU:       Quad core Intel Core i7-6820HQ (-HT-MCP-) cache: 8192 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 21696
           clock speeds: max: 3600 MHz 1: 899 MHz 2: 899 MHz 3: 899 MHz 4: 900 MHz 5: 899 MHz 6: 899 MHz
           7: 899 MHz 8: 899 MHz
Graphics:  Card-1: Intel Skylake Integrated Graphics bus-ID: 00:02.0
           Card-2: NVIDIA GM107GLM [Quadro M1000M] bus-ID: 01:00.0
           Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa) FAILED: nouveau
           Resolution: 1920x1080@60.05hz, 1920x1080@60.00hz
           GLX Renderer: Mesa DRI Intel HD Graphics 530 (Skylake GT2)
           GLX Version: 3.0 Mesa 17.0.7 Direct Rendering: Yes
Info:      Processes: 267 Uptime: 20 min Memory: 2015.0/31871.6MB Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35


I followed these steps on getting the latest nvidia driver installed, with no results: https://johners.tech/2017/01/11/install ... x-mint-18/

Is there a way to completely reinstall the nvidia drivers?

Thanks in advance for your help!

Code: Select all

$  uname -a
Linux boxybrown 4.10.0-40-generic #44~16.04.1-Ubuntu SMP Thu Nov 9 15:37:44 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux
Last edited by supergreg on Fri Dec 01, 2017 7:39 pm, edited 2 times in total.

dape5519
Level 1
Level 1
Posts: 2
Joined: Thu Nov 30, 2017 8:43 pm

Re: Having trouble switching nvidia driver

Postby dape5519 » Thu Nov 30, 2017 9:03 pm

I've a similar issue. Guru and wizards please wave your magic wand our way!

You can reinstall and the graphics drivers like so, but that didn't fix it for me.

Code: Select all

sudo apt-get remove --purge nvidia-*
reboot
sudo apt-get install nvidia-384 nvidia-settings nvidia-prime
reboot


I can't switch to my GPU in prime either. I tried turning off my GPU manager(even though I have no reason to believe that was the issue) and it crashed Cinnamon.

Here's some of my info: https://ibb.co/jM3LAG

I'm infuriated by my inability to play TF2 without my GPU.

supergreg
Level 1
Level 1
Posts: 6
Joined: Tue Nov 28, 2017 2:11 pm

Re: Having trouble switching nvidia driver

Postby supergreg » Fri Dec 01, 2017 1:24 pm

Ah, interesting, looks like you have the same "FAILED: nouveau" in the inxi output. I'm sure there just needs to be something deleted or removed somewhere but I'm not sure what. I need TF2 as well :) haha.

supergreg
Level 1
Level 1
Posts: 6
Joined: Tue Nov 28, 2017 2:11 pm

Re: Having trouble switching nvidia driver

Postby supergreg » Fri Dec 01, 2017 1:47 pm

I tried the reinstall but like you said, no effect. :(

supergreg
Level 1
Level 1
Posts: 6
Joined: Tue Nov 28, 2017 2:11 pm

Re: Having trouble activating nvidia driver

Postby supergreg » Fri Dec 01, 2017 7:39 pm

Well, I fixed it with some help from a coworker.

First I added this line to /etc/modprobe.d/blacklist.conf:

Code: Select all

blacklist nouveau


Ran this:

Code: Select all

sudo update-initramfs -u


And deleted /etc/X11/xorg.conf and ~/.config/monitors.xml.

Rebooted and my nvidia driver is working again. The first two steps were what he recommended, and I added deleting the config files so now I'm not sure which part of this actually did the trick.


Return to “Graphic Cards & Monitors”