Cannot enable Nvidia GPU on Nvidia Prime

Screen resolution, 3D Acceleration, nVidia, ATI
Forum rules
Before you post please read this
Post Reply
dape5519
Level 1
Level 1
Posts: 2
Joined: Thu Nov 30, 2017 8:43 pm

Cannot enable Nvidia GPU on Nvidia Prime

Post by dape5519 » Thu Nov 30, 2017 9:18 pm

I've reinstalled drivers, disabled my GPUmanager in grub, tried booting from earlier kernels, and pulled my hair out wanting to play TF2.

Here is a screenshot of some diagnostics I've run for the wizards in here: https://ibb.co/jM3LAG
The diagnostics don't say, but I've a GeForce 940MX

I fear the issue is with Nvidia Prime itself, but really I don't have that great of an idea.
After an unpdate, (to grab firefox quantum) I ran into said GPU troubles. I did this to remove the drivers and I've reinstalled several different driver versions(384, 381, 387).

Code: Select all

sudo apt-get remove --purge nvidia-*
I think it's also worth noting that on shutdown/logoff I see text and noveua comes up with some hex, even though the noveua driver blacklisted in my config file and disabled in driver manager. When everything ran perfectly I still saw text, but It was different, like tcp or tmp.

Thank you for reading!

deepakdeshp
Level 10
Level 10
Posts: 3363
Joined: Sun Aug 09, 2015 10:00 am

Re: Cannot enable Nvidia GPU on Nvidia Prime

Post by deepakdeshp » Fri Dec 01, 2017 2:17 am

If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
I am using Mint 18.3 Cinnamon 64 bit with AMD processor . Memory 8GB

Post Reply

Return to “Graphics Cards & Monitors”