[solved] Nvidia drivers cause waking from suspend to generate error "gpu has fallen off the bus" - requires hard reset

Screen resolution, 3D Acceleration, nVidia, ATI
Forum rules
Before you post please read this
Post Reply
Gebnar
Level 1
Level 1
Posts: 1
Joined: Sun Dec 03, 2017 1:54 am

[solved] Nvidia drivers cause waking from suspend to generate error "gpu has fallen off the bus" - requires hard reset

Post by Gebnar » Sun Dec 03, 2017 2:29 am

After spending a few days fighting with this issue, I've finally cracked it. The fix is easy enough.

My laptop is an Acer Aspire-V3-572g, and apparently this issue affects other distros as well. In fact, I got the fix from https://wiki.archlinux.org/index.php/Laptop/Acer in the first place.

As for the issue: everything about Linux Mint has been perfect on my laptop, with the exception of the suspend feature. Installing proprietary Nvidia drivers caused waking the system from suspend to give an error about "the GPU has fallen off the bus", followed by a complete failure of the display. It seems impossible to get to a terminal from this point, though the system appears to remain operational. Each time I recived this error, I had to hold down the power button and do a hard reset.

The fix is to add the following arguments to the kernel boot parameters:

Code: Select all

rcutree.rcu_idle_gp_delay=1 acpi_osi=! acpi_osi='Windows 2009'
You can test this fix by rebooting, and pressing "e" on your primary boot entry in grub. Add the arguments to the end of the line ending with linux and press CTRL+X to boot. Try suspending and waking the system. If it works, you're golden!

To make the fix permanent you need to edit the \etc\default\grub file. Open a terminal window and paste the following command:

Code: Select all

sudo xed /etc/default/grub
Enter your password. Then, find the line that starts with GRUB_CMDLINE_LINUX_DEFAULT=. Mine looked like this:

Code: Select all

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
Add the arguments to the end of this line, inside the quotes. My entry now looks like this:

Code: Select all

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash rcutree.rcu_idle_gp_delay=1 acpi_osi=! acpi_osi='Windows 2009'"
Enjoy using the Nvidia drivers and still being able to suspend your laptop!

vrizov
Level 1
Level 1
Posts: 30
Joined: Thu Feb 05, 2015 5:12 am

Re: [solved] Nvidia drivers cause waking from suspend to generate error "gpu has fallen off the bus" - requires hard res

Post by vrizov » Thu Feb 01, 2018 3:21 am

Thank you so much! You are the best!!!
I was trying for months to get rid of this suspend problem. I tried setting nvidia-persistence mode - didn't work. I tried with nouveau drivers - didn't work.
Adding this code to grub solved the problem with suspend once and for all. Thank you again and have a nice day! :D :D :D

ack0329
Level 1
Level 1
Posts: 42
Joined: Tue Feb 25, 2014 11:42 pm

Re: [solved] Nvidia drivers cause waking from suspend to generate error "gpu has fallen off the bus" - requires hard res

Post by ack0329 » Wed Jul 18, 2018 12:50 pm

I know this is for Linux Mint but this response/solution is from Ubuntu 18.04 but should work with Mint too! :D

I was also having this problem plague me ... and a fix after many attempts was to re-install Ubuntu 18.04, and now it is working perfectly. I am also using Nvidia's "tested" Driver, as Nvidia was the culprit before.

Perhaps it was the "sudo add-apt-repository ppa:graphics-drivers" ppa which installed "Extra" Stuff from the PPA and/or the 396 driver itself which screwed up my laptop's hibernating ability.

Either way it works flawlessly at this time of writing with the NVidia's 390 tested driver. And just FYI, it was also working with the 396 driver for a long time, but became problematic last week - AGAIN! SO although I don't know the exact cause ...

It is/was definitely related to the NVidia driver as before switching to the Nouveau driver also worked, but I sure did not like that option.

Trying to help, Mark :)

Post Reply

Return to “Graphics Cards & Monitors”