Nvidia G210M driver Mint 18.3 <Solved>

Screen resolution, 3D Acceleration, nVidia, ATI
Forum rules
Before you post please read this
Post Reply
Level 1
Level 1
Posts: 2
Joined: Thu Dec 28, 2017 10:45 am

Nvidia G210M driver Mint 18.3 <Solved>

Post by cichy63 » Thu Dec 28, 2017 10:57 am

Hi All,

I've installed a new release of Linux Mint on my Asus laptop with hybryd Intel-Nvidia graphic card and have problem with the driver. I have a fresh install and when I use driver manager to install Nvidia 340 (recommended) drivers everything works fine until first try to switch to Intel, integrated graphic card. I'm being asked to log off and on to activate the change but when i log off i see only black screen and mint crashes. To fix it i need to restore a timeshift backup or reinstall again. I was using v. 18.1, 18.2 without any issues with this card. I'm quite a new user, any help much appreciated. I add my inxi log. Please let me know what would be helpful to diagnose and sort out this issue.

Code: Select all

System:    Host: cichy-UL80VT Kernel: 4.10.0-38-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: Cinnamon 3.6.6 (Gtk 3.18.9-1ubuntu3.3)
           Distro: Linux Mint 18.3 Sylvia
Machine:   System: ASUSTeK (portable) product: UL80VT v: 1.0
           Mobo: ASUSTeK model: UL80VT v: 1.0
           Bios: American Megatrends v: 208 date: 11/24/2009
CPU:       Dual core Intel U7300 (-MCP-) cache: 3072 KB
           flags: (lm nx sse sse2 sse3 sse4_1 ssse3 vmx) bmips: 6933
           clock speeds: max: 1300 MHz 1: 800 MHz 2: 1300 MHz
Graphics:  Card-1: Intel Mobile 4 Series Integrated Graphics Controller
           bus-ID: 00:02.0
           Card-2: NVIDIA GT218M [GeForce G210M] bus-ID: 01:00.0
           Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa) FAILED: nouveau
           Resolution: 1366x768@60.00hz
           GLX Renderer: Mesa DRI Mobile Intel GM45 Express
           GLX Version: 2.1 Mesa 17.0.7 Direct Rendering: Yes
Audio:     Card-1 NVIDIA High Definition Audio Controller
           driver: snd_hda_intel bus-ID: 01:00.1
           Card-2 Intel 82801I (ICH9 Family) HD Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0
           Sound: Advanced Linux Sound Architecture v: k4.10.0-38-generic
Network:   Card-1: Intel Centrino Wireless-N 1000 [Condor Peak]
           driver: iwlwifi bus-ID: 03:00.0
           IF: wlp3s0 state: up mac: <filter>
           Card-2: Qualcomm Atheros AR8131 Gigabit Ethernet
           driver: atl1c v: port: ec00 bus-ID: 04:00.0
           IF: enp4s0 state: down mac: <filter>
Drives:    HDD Total Size: 500.1GB (4.1% used)
           ID-1: /dev/sda model: ST9500325AS size: 500.1GB
Partition: ID-1: / size: 92G used: 5.8G (7%) fs: ext4 dev: /dev/sda5
           ID-2: swap-1 size: 15.00GB used: 0.00GB (0%) fs: swap dev: /dev/sda7
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 55.0C mobo: N/A gpu: 55.0
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 182 Uptime: 21 min Memory: 1650.7/3915.4MB
           Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35 
Last edited by cichy63 on Sat Jan 13, 2018 3:35 am, edited 1 time in total.

Level 1
Level 1
Posts: 2
Joined: Thu Dec 28, 2017 10:45 am

Re: Nvidia G210M driver Mint 18.3

Post by cichy63 » Sat Jan 13, 2018 3:31 am


I've tried everything and figure it out that it is a hardware issue. Unfortunately my intel chipset got problem and causes the system to crash if i try to switch it on. Topic closed.

Post Reply

Return to “Graphics Cards & Monitors”