ASUS ROG Strix GL503 - graphics, wifi and mouse/touchpad problems

Screen resolution, 3D Acceleration, nVidia, ATI
Forum rules
Before you post please read this
Post Reply
kwronski
Level 1
Level 1
Posts: 1
Joined: Thu Jan 04, 2018 4:32 am

ASUS ROG Strix GL503 - graphics, wifi and mouse/touchpad problems

Post by kwronski » Thu Jan 04, 2018 4:41 am

Hi,

I bought new laptop ASUS ROG Strix GL503:
- Intel Core i5-7300HQ
- 8 GB (SO-DIMM DDR4, 2400MHz)
- NVIDIA GeForce GTX 1050 + Intel HD Graphics 630

I made dual boot: Windows 10 + Mint 18.3 Cinamon.
On Windows everything works perfectly, but on Mint I have several problems:

1. Wifi.
I am connected to my home network, but browsers have problem to load any pages.
When I check connection on some speed test pages the result is that most of time speed is 0, sometimes grow up to ~130kb, sometimes grow up to ~15Mb, and again to 0.
I read many other posts, I tried to disable 11n, switch off power saving etc - but nothing helps.

2. Random freezes.
Every few moments the mouse freeze on ~1s. When I checked "htop" I observed that cpu's random core usage grow up to 100% for ~1s and go down to almost 0%.
It definitely makes work impossible.

3. Graphic cards.
I installed NVIDIA drivers using Driver Manager (with ppa:graphics-drivers/ppa repository).
I can work on Nvidia card, but when I switch to integrated Intel HD Graphics 630 and reboot I get black screen freeze - then I need to reboot with "nomodeset" param and change card back to NVIDIA. This results in short battery life.
I also tried to install last version of NVIDIA driver manually (downloading driver form nvidia web page) - but in this case I cannot also boot - always freeze on boot.

4. Touchpad
I cannot use touchpad because cursor first start to jump on the screen, and after a few seconds cursor freeze at place and touchpad not respond.

Some system information:

Code: Select all

System:    Host: homestead Kernel: 4.13.0-21-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: Cinnamon 3.6.7 (Gtk 3.18.9-1ubuntu3.3) Distro: Linux Mint 18.3 Sylvia
Machine:   Mobo: ASUSTeK model: GL503VD v: 1.0 Bios: American Megatrends v: GL503VD.304 date: 10/03/2017
CPU:       Quad core Intel Core i5-7300HQ (-MCP-) cache: 6144 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 19968
           clock speeds: max: 3500 MHz 1: 2500 MHz 2: 2500 MHz 3: 2500 MHz 4: 2500 MHz
Graphics:  Card-1: Intel Device 591b bus-ID: 00:02.0
           Card-2: NVIDIA GP107M [GeForce GTX 1050 Mobile] bus-ID: 01:00.0
           Display Server: X.Org 1.18.4 driver: nvidia Resolution: 2560x1080@60.00hz
           GLX Renderer: GeForce GTX 1050/PCIe/SSE2 GLX Version: 4.6.0 NVIDIA 387.34 Direct Rendering: Yes
Audio:     Card Intel CM238 HD Audio Controller driver: snd_hda_intel bus-ID: 00:1f.3
           Sound: Advanced Linux Sound Architecture v: k4.13.0-21-generic
Network:   Card-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           driver: r8169 v: 2.3LK-NAPI port: d000 bus-ID: 02:00.0
           IF: enp2s0 state: down mac: <filter>
           Card-2: Intel Wireless 8265 / 8275 driver: iwlwifi bus-ID: 04:00.0
           IF: wlp4s0 state: up mac: <filter>
Drives:    HDD Total Size: 240.1GB (28.0% used) ID-1: /dev/nvme0n1 model: N/A size: 256.1GB
           ID-2: /dev/sda model: GOODRAM_CX100 size: 240.1GB temp: 30C
Partition: ID-1: / size: 227G used: 56G (26%) fs: ext4 dev: /dev/nvme0n1p2
           ID-2: swap-1 size: 8.46GB used: 0.00GB (0%) fs: swap dev: /dev/nvme0n1p3
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 55.5C mobo: N/A gpu: 0.0:44C
           Fan Speeds (in rpm): cpu: 0
Info:      Processes: 250 Uptime: 2 min Memory: 1633.5/7864.6MB Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35
Can anyone help me?
Thanks

Post Reply

Return to “Graphic Cards & Monitors”