Monitor resolution increase not allowed

Screen resolution, 3D Acceleration, nVidia, ATI
Forum rules
Before you post please read this
Post Reply
parchping
Level 1
Level 1
Posts: 12
Joined: Sat Jan 06, 2018 12:26 am

Monitor resolution increase not allowed

Post by parchping » Sat Jan 06, 2018 12:59 am

I have a newly built system:
i5 8600k
16g ram
Linux Mint 18.3

Under Display (System Profiler):
Resolution 1024x768 pixels
OpenGL Renderer llvmpipe (LLVM 5.0 256 bits)

My actual display is a 27" Samsung, S27D850T. It should be capable of up to 2560x1440.
I am using cpu graphics--I do not have a graphics card (I don't game).

This is the output from xrandr:
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 1024 x 768, current 1024 x 768, maximum 1024 x 768
default connected 1024x768+0+0 0mm x 0mm
1024x768 76.00*
2560x1440_60.00 (0x2bd) 312.250MHz -HSync +VSync
h: width 2560 start 2752 end 3024 total 3488 skew 0 clock 89.52KHz
v: height 1440 start 1443 end 1448 total 1493 clock 59.96Hz
2560x1440 (0x2be) 312.250MHz -HSync +VSync
h: width 2560 start 2752 end 3024 total 3488 skew 0 clock 89.52KHz
v: height 1440 start 1443 end 1448 total 1493 clock 59.96Hz

Minimum, current and maximum resolutions are all the same, 1024x768.
I have tried a number of things with xrandr. You can see I've added a couple of resolutions; I am unable to access them.

Any help will be greatly appreciated.

Steve

parchping
Level 1
Level 1
Posts: 12
Joined: Sat Jan 06, 2018 12:26 am

Re: Monitor resolution increase not allowed

Post by parchping » Sat Jan 06, 2018 4:34 pm

I forgot to add that I'm using HDMI. I tried dvi this morning with the same results.

Steve

rene
Level 7
Level 7
Posts: 1904
Joined: Sun Mar 27, 2016 6:58 pm

Re: Monitor resolution increase not allowed

Post by rene » Sat Jan 06, 2018 5:33 pm

You are not using a correct videodriver; probably "vesa" whereas it should be "modesetting" (or "intel" if you insist). The output of inxi -Gx will tell you; inxi -Fxz for a more expansive report.

This is no doubt caused by your hardware being too new for the standard 18.3 kernel; I'd expect things to start working automatically once you update your kernel to the nest series and version thereof available. You can do so through Update Manager, View -> Linux kernels menu. I'd grab the newest 4.13 (which you'll want to do again shortly when the first round of meltdown-patched kernels becomes available).

parchping
Level 1
Level 1
Posts: 12
Joined: Sat Jan 06, 2018 12:26 am

Re: Monitor resolution increase not allowed

Post by parchping » Sat Jan 06, 2018 6:17 pm

My kernel was behind; I updated to 4.13 and then rebooted. Still the same result (minus my attempts at adding resolutions). Here's the xrandr output:

xrandr: Failed to get size of gamma for output default
Screen 0: minimum 1024 x 768, current 1024 x 768, maximum 1024 x 768
default connected primary 1024x768+0+0 0mm x 0mm
1024x768 76.00*

I guess this means I have to wait for my hardware to be supported.

Thanks,
Steve

parchping
Level 1
Level 1
Posts: 12
Joined: Sat Jan 06, 2018 12:26 am

Re: Monitor resolution increase not allowed

Post by parchping » Sat Jan 06, 2018 6:23 pm

Here's the new inxi -Gx output:

Graphics: Card: Intel Device 3e92 bus-ID: 00:02.0
Display Server: X.Org 1.18.4 drivers: fbdev,intel (unloaded: vesa)
Resolution: 1024x768@76.00hz
GLX Renderer: llvmpipe (LLVM 5.0, 256 bits)
GLX Version: 3.0 Mesa 17.2.4 Direct Rendering: Yes

so it looks like it changed from vesa to fbdev or intel, but with the same resolution.

rene
Level 7
Level 7
Posts: 1904
Joined: Sun Mar 27, 2016 6:58 pm

Re: Monitor resolution increase not allowed

Post by rene » Sat Jan 06, 2018 6:32 pm

Was under the impression that things would work out of the box, but it appears you may for now need to boot with a specific kernel parameter. With that 4.13 kernel installed, run

Code: Select all

gksudo xed /etc/default/grub
and change GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" to

Code: Select all

GRUB_CMDLINE_LINUX_DEFAULT="i915.alpha_support=1 quit splash"
Save, run sudo update-grub and reboot. Chances seem to be this is all you need.

parchping
Level 1
Level 1
Posts: 12
Joined: Sat Jan 06, 2018 12:26 am

Re: Monitor resolution increase not allowed

Post by parchping » Sun Jan 07, 2018 12:42 am

The 4.13 kernel has been installed and works fine. The change to GRUB_CMDLINE_LINUX_DEFAULT does not, unfortunately. If I modify it as in your post, ("quit splash") or if I edit it to be ("quiet splash"), either way the system will not boot at all. I've had some other misadventures in reinstalling, which is why this took me so long.

I do now have a small gain in resolution--now it is locked at 1280x1024. Still the wrong aspect ratio and more pixels would be nice. Here's what may have given me 1280x1024 instead of 1024x768:

When I first installed Mint 18.3, I picked Cinnamon. This complained at me that I did not have hardware acceleration for graphics (using cpu graphics). I changed to Mate and the complaint went away. This setup had 1024x768 resolution.

When I reinstalled this afternoon, instead of starting with Cinnamon, I *started* with Mate. When I had a working installation, the resolution was 1280x1024.

That's where I'm at. Would an inexpensive graphics card (like a GT 1030) give me more options on resolution?

rene
Level 7
Level 7
Posts: 1904
Joined: Sun Mar 27, 2016 6:58 pm

Re: Monitor resolution increase not allowed

Post by rene » Sun Jan 07, 2018 12:00 pm

Pardon; "quiet" instead of "quit" indeed. Unexpected that it again doesn't work; it seems to with your CPU on Ubuntu 17.10. Since you managed to test both "quiet" and the typo'd version I will assume that the reinstall wasn't due to the failing boot. If it was, pardon again; could've advised to manually add the parameter in Grub instead; have it be a one-shot thing.

Fiddly to describe, sometimes doesn't work for people and generally not needed, but in that context: if you do ever find yourself in a situation like that try holding down or tapping either Left-Shift or Esc at the point where the boot transitions from BIOS to OS to enter the Grub menu. Choose "e" to edit the command line for your boot entry, add/delete the parameter at issue from/to the "linux" line and boot with F10. Fix up /etc/default/grub and rerun sudo update-grub once booted normally again.

Mint 18.x is based on Ubuntu 16.04.x which certainly is quite a bit older than 17.10 but the kernel is the most important difference wrt. graphics support; 17.10 uses 4.13 so I had good hopes. Depending on the exact nature of "will not boot at all" the Xorg version is the next important difference and I remembered reading about the Xorg HWE, "Hardware Enablement", stack at https://github.com/linuxmint/Roadmap. Unfortunately that seems also at the moment still a TODO item; can't find the mentioned instructions and am in fact under the impression that 18.3 ships with Xorg 1.19 in the first place; that that TODO is likely obsolete.

You can verify your Xorg version from the first line of the output of head /var/log/Xorg.0.log. If it is not 1.19: I am myself still on 17.3 and am not sure I should be attempting to advise you on how to upgrade Xorg; there's likely people experienced on this forum. Do be sure to check your update manager for a new version, having set your upgrade strategy to the "always update everything" choice...

If it is 1.19 I'd likely burn Ubuntu 17.10 to a USB and boot it: you'd need to specify that i915.alpha_support=1 parameter; if you'll be doing this I'll go find out how. Yes, sticking in a discrete videocard should also work but I'd not. Would sooner for now retreat to Ubuntu or a different distribution; the issue is Mint 18 not shipping up to date enough software for your very new hardware. Although with a kernel parameter needed, Ubuntu 17.10 seems to.

Yes, the fact that you were on Cinnamon told you were software rendered is just a result of your on-board video not yet being supported on 18.x. MATE doesn't use 3D-acceleration in the first place so would be semi-fine with that (but note that it also suffers quite a bit with non-supported video; no 2D-acceleration, no video-acceleration, no anything).

Mint is a stability-skewed distribution with any Mint x.y release based on the same Ubuntu LTS version; Ubuntu 16.04 in the case of Mint 18.x. Currently we're on 18.3 which means quite a ways into the corresponding Ubuntu 16.04 cycle. Mint 19 will likely work for you out of the box.

parchping
Level 1
Level 1
Posts: 12
Joined: Sat Jan 06, 2018 12:26 am

Re: Monitor resolution increase not allowed

Post by parchping » Sun Jan 07, 2018 1:11 pm

I haven't said yet, but I really appreciate the help. I've done a fair bit as a Linux user, but my admin understanding is pretty weak.

It's different now. I realized I had left it set up with DVI. Shutdown, switched to HDMI. Now it comes up 2560x1440 (locked to that like it was to the lower resolution, min=max). Maybe your suggestions did work but something needed updating via reboot or change of connection.

I have a new video issue. If I open a window (say something simple like terminal) and drag it around by the title bar, it is very jerky, jumps from place to place pretty severely. Even just the mouse pointer has some jerk/jump when I wave it across the screen. Firefox is deadly slow for typing, scrolling, creating a new tab. I have run the update manager (updated all) and changed the kernel to 4.13.

Thanks,
Steve

User avatar
Spearmint2
Level 15
Level 15
Posts: 5713
Joined: Sat May 04, 2013 1:41 pm
Location: Maryland, USA

Re: Monitor resolution increase not allowed

Post by Spearmint2 » Sun Jan 07, 2018 1:31 pm

Try this.

Open text file. Put the following in it, use copy/paste to be certain it goes in exactly.

Code: Select all

xrandr --newmode "2560x1440_60.00"  312.25  2560 2752 3024 3488  1440 1443 1448 1493 -hsync +vsync
xrandr --addmode default 2560x1440_60.00
Save file as .xprofile into your user's home folder (NOT the main /home folder)

Log out and then log in. See if it's available in Display Settings.

I would have expected to see outputs in xrandr like HDM0-1, DVI-0, and/or VGA-0 instead of just "default".

UPDATE: CORRECTED
Last edited by Spearmint2 on Sun Jan 07, 2018 2:32 pm, edited 1 time in total.
All things go better with Mint. Mint julep, mint jelly, mint gum, candy mints, pillow mints, peppermint, chocolate mints, spearmint,....

rene
Level 7
Level 7
Posts: 1904
Joined: Sun Mar 27, 2016 6:58 pm

Re: Monitor resolution increase not allowed

Post by rene » Sun Jan 07, 2018 1:53 pm

I don't believe that's actually going to be a new issue as such; that you are simply experiencing the result of having no hardware acceleration active at all. It seems that kernel 4.15 is going to have finalized support for your CPU's ("Coffee Lake") graphics. 4.15 isn't yet out, but what I would personally attempt is is installing 4.15-rc6 from http://kernel.ubuntu.com/~kernel-ppa/ma ... v4.15-rc6/. A slight additional advantage is that this will patch you for the current Meltdown hooplala as well...

Installing that kernel would leave your current one in place but be sure you know how to boot into a specific kernel before you try any of this lest you'd find yourself reinstalling again if something goes wrong. I.e., you'd enter the Grub menu as per above and select a specific kernel from the "Advanced Options" entry; please try before doing anything but when confident enough you'd grab both

http://kernel.ubuntu.com/~kernel-ppa/ma ... _amd64.deb
http://kernel.ubuntu.com/~kernel-ppa/ma ... _amd64.deb

and install either deb with sudo dpkg -i <name>.deb and reboot.

There's still the issue of me not being certain that your Xorg is new enough and/or how to make it such if not but you can try...

parchping
Level 1
Level 1
Posts: 12
Joined: Sat Jan 06, 2018 12:26 am

Re: Monitor resolution increase not allowed

Post by parchping » Sun Jan 07, 2018 1:57 pm

It looks like there is a typo:
"256x1440" should probably be "2560x1440"?
I don't know about the 256 following though:
xrandr --newmode "256x1440_60.00" 30.00 256 272 296 336 1440 1443 1453 1493 -hsync +vsync
Does the second 256 (256 272 296) relate to this?


It does seem odd that all I have is default. Note that I am now in 2560x1440. A little lower resolution would be good, however.
The big problem is the jerkiness.

Thanks,
Steve

parchping
Level 1
Level 1
Posts: 12
Joined: Sat Jan 06, 2018 12:26 am

Re: Monitor resolution increase not allowed

Post by parchping » Sun Jan 07, 2018 2:19 pm

Hi Rene,

If I have no hardware acceleration, what I'm seeing makes sense. I couldn't believe the cpu graphics were this bad.

I'm interested in trying the 4.15 kernel, but I need a bit more on the instructions. I agree that I want to be confident of how to switch kernels in GRUB before doing it!
Your first paragraph points me to a page with a variety of .deb files. Below this you provided direct links to two different versions. It looks like I should download either of those and install, is that right?
The kernel name ending in amd64 will still work on an i5?

Thanks,
Steve

User avatar
Spearmint2
Level 15
Level 15
Posts: 5713
Joined: Sat May 04, 2013 1:41 pm
Location: Maryland, USA

Re: Monitor resolution increase not allowed

Post by Spearmint2 » Sun Jan 07, 2018 2:32 pm

parchping wrote:It looks like there is a typo:
"256x1440" should probably be "2560x1440"?
I don't know about the 256 following though:
xrandr --newmode "256x1440_60.00" 30.00 256 272 296 336 1440 1443 1453 1493 -hsync +vsync
Does the second 256 (256 272 296) relate to this?


It does seem odd that all I have is default. Note that I am now in 2560x1440. A little lower resolution would be good, however.
The big problem is the jerkiness.

Thanks,
Steve
Yes, made a mistake. Corrected in above original post. What resolution did you want?
All things go better with Mint. Mint julep, mint jelly, mint gum, candy mints, pillow mints, peppermint, chocolate mints, spearmint,....

parchping
Level 1
Level 1
Posts: 12
Joined: Sat Jan 06, 2018 12:26 am

Re: Monitor resolution increase not allowed

Post by parchping » Sun Jan 07, 2018 2:40 pm

Hi Spearmint2,

1920x1080 would probably be about right. Text is readable, but a little small.
I'm going to try Rene's suggestion of the 4.15 kernel first and see if that gives me what I need.

Thanks,
Steve

rene
Level 7
Level 7
Posts: 1904
Joined: Sun Mar 27, 2016 6:58 pm

Re: Monitor resolution increase not allowed

Post by rene » Sun Jan 07, 2018 3:12 pm

parchping wrote:Below this you provided direct links to two different versions. It looks like I should download either of those and install, is that right?
Both those -- but you in fact also need the "all" headers package as a dependency of the generic header package. That is, you would want to install:

http://kernel.ubuntu.com/~kernel-ppa/ma ... 30_all.deb
http://kernel.ubuntu.com/~kernel-ppa/ma ... _amd64.deb
http://kernel.ubuntu.com/~kernel-ppa/ma ... _amd64.deb

I just checked on an 18.3 VirtualBox VM and the new kernel installs and works without issue. If you simply click on the links in order they will offer to open in "GDebi Package Installer" and can be installed simply with "Install Package".
The kernel name ending in amd64 will still work on an i5?
Yes, "amd64" is the generic architecture name for 64-bit x86 processors. The 32-bit x86 architecture name was/is IA32, for "Intel Architecture 32-bit" but while Intel was wasting time on its failed IA64, "Itanium", architecture, AMD expanded IA32 with 64-bit extensions to end up with what we nowadays use as the 64-bit x86 architecture.

On my fully updated 18.3 VM I do see it's still using Xorg 1.18 though, and I'm as such not so sure at this point that 4.15-rc6 is going to be the only thing you need. I can probably work out what to do to upgrade to Xorg 1.19 with the use of this VM but let's first wait and see what happens for you on 4.15-rc6 alone: that bit I can of course not test, lacking the hardware.

Indeed you should before doing anything make sure you know how to boot into specific kernels. On my VM it indeed works to hold down left shift while booting to enter the Grub menu (if you don't get it automatically to begin with) from which you can select specific kernels to boot with from the "Advanced Options" submenu.

parchping
Level 1
Level 1
Posts: 12
Joined: Sat Jan 06, 2018 12:26 am

Re: Monitor resolution increase not allowed

Post by parchping » Sun Jan 07, 2018 4:21 pm

I clicked on the three links in order and used the Install button. Then I rebooted and got into GRUB. Here's what happened:
-----------------------------------------------------
Booted Linux Mint 18.3 MATE 64-bit, with Linux 4.15.0-041500rc6-generic
handful of sparse colored dots, upper left corner of display
before the colored dots, it looks like I have the same errors listed below, but they go past pretty quickly

Booted Linux Mint 18.3 MATE 64-bit, with Linux 4.15.0-041500rc6-generic (upstart)
Did get a Mint logo in the middle of the screen, then it went away and got these errors (boot stops at this point):

[ 0.036737] ACPI Error: [_SB_.PCIO.RP05.PXSX] Namespace lookup failure, AE_NOT_FOUND (20170831/dswload2-191)
[ 0.036746] ACPI Exception: AE_NOT_FOUND, During name lookup/catalog (20170831/psobject-252)
[ 0.036748] ACPI Error: Method parse/execution failed \_SP.PCIO.RP04.PXSX, AE_NOT_FOUND (20170831/psparse-550)
[ 0.037090] ACPI Error: [_SB_.PCIO.RP09.PXSX] Namespace lookup failure, AE_NOT_FOUND (20170831/dswload2-191)
[ 0.037094] ACPI Exception: AE_NOT_FOUND, During name lookup/catalog (20170831/psobject-252)
[ 0.037097] ACPI Error: Method parse/execution failed _SB.PCIO.RP08.PXSX, AE_NOT_FOUND (20170931/psparse-5500)

Booted Linux Mint 18.3 MATE 64-bit, with Linux 4.15.0-041500rc6-generic (recovery mode)
This does boot. Mouse cursor movement, moving window around, using Firefox all look much better, look very normal.
In the Control Center, Displays, the monitor is still unknown, but now I have a set of resolutions to choose from, 2560x1440 on down. Major progress.

inxi -Gx
Graphics: Card: Intel Device 3e92 bus-ID: 00:02.0
Display Server: X.Org 1.18.4 drivers: vesa,intel (unloaded: fbdev)
Resolution: 2560x1440@0.00hz
GLX Renderer: llvmpipe (LLVM 5.0, 256 bits)
GLX Version: 3.0 Mesa 17.2.4 Direct Rendering: Yes


Steve

rene
Level 7
Level 7
Posts: 1904
Joined: Sun Mar 27, 2016 6:58 pm

Re: Monitor resolution increase not allowed

Post by rene » Sun Jan 07, 2018 5:01 pm

The ACPI error messages are in fact likely not much of an issue; they point to different expectations between your BIOS' ACPI tables and the kernel's parser of such, and this is hardly rare nor generally all that problematic, and definitely not normally fatal. The "quiet" kernel parameter that your system is booting with specifically tells the kernel to keep quiet unless actual errors occur; with the ACPI errors the only actually occurring errors they're all that's printed -- and if you then get stuck pre-graphics due to a failure of X.org to start give the impression of being the actual problem, even though they have little to do with things.

I wouldn't find the "recovery" result to be great progress; your inxi report shows that that you're then still stuck on "vesa" (previously "fbdev") and that means you're still unaccelerated even though apparently "fbdev" unicorns-up for you even worse. Perhaps you'd like to try X.org 1.19 -- although you should only if you don't mind that the recommended way back is going to be a full reinstall of 18.3. The below has just now been verified on a new 18.3 VirtualBox VM: I ...

1. installed Mint 18.3 Cinnamon 64-bit
2. fully updated it having set the update policy to "always update everything"
3. rebooted
4. upgraded the kernel to 4.15-rc6 by installing the above 3 packages
5. rebooted and verified to be running 4.15 from the output of uname -r.
6. upgraded to X.org 1.19 with sudo apt-get install --install-recommends xserver-xorg-hwe-16.04
7. rebooted and verified to be running X.org 1.19.5 from the output of inxi -Gx

You'd start at 6 now. If still not I guess I'm out of suggestions but am left wondering why I'm not finding this issue online; Coffee Lake is new but then again not so new that I'd not expect a few reports of not being able to get it working at all. I'd in any case at that point for now give up on Mint on your hardware and look to see if Ubuntu or another distribution works.

If things do work for you on X.org 1.19: note for any possible onlookers; the 4.15-rc6 step although a good idea could probably be replaced by the first tried "i915.alpha_support=1" parameter when running 4.13 or 4.14.

parchping
Level 1
Level 1
Posts: 12
Joined: Sat Jan 06, 2018 12:26 am

Re: Monitor resolution increase not allowed

Post by parchping » Sun Jan 07, 2018 5:17 pm

Brilliant Rene, thanks ever so much. It all works fine now.

uname -r
4.15.0-041500rc6-generic

inxi -Gx
Graphics: Card: Intel Device 3e92 bus-ID: 00:02.0
Display Server: X.Org 1.19.5 drivers: (unloaded: fbdev,vesa)
Resolution: 2560x1440@59.95hz
GLX Renderer: Mesa DRI Intel HD Graphics (Coffeelake 3x8 GT2)
GLX Version: 3.0 Mesa 17.2.4 Direct Rendering: Yes

Steve

rene
Level 7
Level 7
Posts: 1904
Joined: Sun Mar 27, 2016 6:58 pm

Re: Monitor resolution increase not allowed

Post by rene » Sun Jan 07, 2018 5:25 pm

Great, and good to know for subsequent Coffee Lake users.

Note also that you're running a kernel with the Meltdown fix at this point: that is, there will in a few days time be a large influx of new kernels together with sternly formulated upgrade recommendations, but you get to ignore those; may feel free to wait for an official 4.15 or later kernel to be offered to you through update manager.

Post Reply

Return to “Graphics Cards & Monitors”