Blender3D crash and KDE Bugs after "Mesa" update

Screen resolution, 3D Acceleration, nVidia, ATI
Forum rules
Before you post please read this
Post Reply
Mintoine
Level 1
Level 1
Posts: 4
Joined: Sun Jan 07, 2018 1:17 pm

Blender3D crash and KDE Bugs after "Mesa" update

Post by Mintoine » Sun Jan 07, 2018 8:29 pm

Resume:
  • Blender crash, on takeoff, after I've updating the "Mesa" package (with the Mint tray and GUI utility).
    Blender was working fine, just before this update.
    Now, Blender is only working when I boot in "nomodeset" (Grub recovery menu).

    I've boot Mint-KDE in nomodeset kernel mode to write this post.
I've this problem with, Kubuntu, MintXFCE and MintKDE (not tryed on MintCinnamon).
I've KDE desktop problems too (any panels, icons, menus) on Mint-KDE only (not kubuntu).
Booting in nomodeset resolve the Blender & KDE problems. (sucefuly tested on Mint KDE & XFCE).

Notes:
I've 3 LinuxMint (XFCE, Cynamon, KDE + 1 windows) installed.
Installed in december with about 18.3 ISO.
Kubuntu is now erased.
Videocard : ATI RADEON X1200, (RS960,R400 family), (integrate on ASUS motherboard) .


More explanations:
1) Kubuntu :
The first problem (Blender absolutely no run) come with Kubuntu in december perhasp. I tryed differente way to re-install and purge Blender (PPA repositorys, stand alone version)...
I decide to erase Kubuntu and to install the 3 Mint editions (in 3 littles partitions) to resolve this.

2) 3 Mint installs:
The 3 Mind editions was working good and Blender too: Blender work with the 3 desktops, just have to selected "OpenGL select" option to use the Manipulators widgets, in Blender "Preferences", in Kubuntu to).

I've use, daily, Mint-KDE, with upgrade (Mint tray/utility, but without check when problem come).
And this, perhaps, for one month after installaling.

3) Problem come back.. first with Mint-KDE and Mint-XFCE after..
Mint-KDE:
For some days, Blender doesn't work (it din't takeoff).
KDE dont' show any icons, menus or panels. It only show appli windows (I can use Firefox, Konsol, Kate... with internet connection) and KRunner (Alt+F2/space) (Alt+tab work fine).
The only way to get KDE and Blender fine working is to boot in "nomodeset" (Grub recovery menu).

Mint-XFCE:
Today:
Blender was working normaly.
First, I've update other packages without problem for Blender:
https://lut.im/89Yhbf8T85/YrAht3WKKiWu4Cz5.png
And...
I've update the "Mesa" pakage (Mint GUI), and, after, Blender refuse to take of. Just began to draw OS windows and quit, (like with Mint-KDE).
This lib was required by the "mesa" update : libllvm5.0
She was not installed before...

I'have tryed to repport bug, but i don't handerstand any thing...
https://bugs.freedesktop.org/enter_bug.cgi?product=Mesa

Some one can help me?

LOGs:

The update log after what, Blender doesn't work:

Code: Select all

Start-Date: 2018-01-07  17:54:10

Commandline: /usr/sbin/synaptic --hide-main-window --non-interactive --parent-window-id 31457303 -o Synaptic::closeZvt=true --set-selections-file /tmp/tmp3q6rltye

Requested-By: xftawn (1000)

Install:
 libllvm5.0:amd64 (1:5.0-3~16.04.1, automatic)

Upgrade:
 libgles2-mesa:amd64 (17.0.7-0ubuntu0.16.04.2, 17.2.4-0ubuntu1~16.04.2),
 libgles1-mesa:amd64 (17.0.7-0ubuntu0.16.04.2, 17.2.4-0ubuntu1~16.04.2),
 libglapi-mesa:amd64 (17.0.7-0ubuntu0.16.04.2, 17.2.4-0ubuntu1~16.04.2),
 libxatracker2:amd64 (17.0.7-0ubuntu0.16.04.2, 17.2.4-0ubuntu1~16.04.2),
 libegl1-mesa:amd64 (17.0.7-0ubuntu0.16.04.2, 17.2.4-0ubuntu1~16.04.2),
 libgbm1:amd64 (17.0.7-0ubuntu0.16.04.2, 17.2.4-0ubuntu1~16.04.2),
 libwayland-egl1-mesa:amd64 (17.0.7-0ubuntu0.16.04.2, 17.2.4-0ubuntu1~16.04.2),
 libgl1-mesa-dri:amd64 (17.0.7-0ubuntu0.16.04.2, 17.2.4-0ubuntu1~16.04.2),
 libgl1-mesa-glx:amd64 (17.0.7-0ubuntu0.16.04.2, 17.2.4-0ubuntu1~16.04.2)
End-Date: 2018-01-07  17:54:36
Videocard lspci output:

Code: Select all

01:05.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] RS690 [Radeon X1200]
grep "drivers" /var/log/Xorg.0.log (In nomodeset boot mode)

Code: Select all

[    39.015] (II) Loading /usr/lib/xorg/modules/drivers/ati_drv.so
[    39.016] (II) Loading /usr/lib/xorg/modules/drivers/radeon_drv.so
[    39.049] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
[    39.050] (II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
[    39.051] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so

Code: Select all

System:    Host: EDEN Kernel: 4.10.0-42-generic x86_64 (64 bit gcc: 5.4.0) Desktop: KDE Plasma 5.8.8 (Qt 5.6.1)
           Distro: Linux Mint 18.3 Sylvia
Graphics:  Card: Advanced Micro Devices [AMD/ATI] RS690 [Radeon X1200] bus-ID: 01:05.0
           Display Server: X.Org 1.18.4 drivers: ati,vesa (unloaded: fbdev,radeon) Resolution: 1280x1024@0.00hz
           GLX Renderer: llvmpipe (LLVM 5.0, 128 bits) GLX Version: 3.0 Mesa 17.2.4 Direct Rendering: Yes

Mintoine
Level 1
Level 1
Posts: 4
Joined: Sun Jan 07, 2018 1:17 pm

Re: Blender3D crash and KDE Bugs after "Mesa" update

Post by Mintoine » Fri Jan 12, 2018 6:35 pm

I've tryed the "mesa" package update on Mint Cinnamon and it is the same things like Mint KDE and XFCE:

Cinnamon come in Rescue mode, Blender crash on "take-off".

This bugs are not if login in "Software render" mode when user login.

I've use Timeshift before. So, I've restore my Mint and black-listed the mesa package update in the Mint update utility.

Post Reply

Return to “Graphics Cards & Monitors”