[SOLVED] Intel UHD 630 "Coffee Lake" support

Screen resolution, 3D Acceleration, nVidia, ATI
Forum rules
Before you post please read this
Post Reply
stelek
Level 1
Level 1
Posts: 1
Joined: Wed Jan 10, 2018 5:38 pm

[SOLVED] Intel UHD 630 "Coffee Lake" support

Post by stelek » Wed Jan 10, 2018 5:47 pm

My beloved desktop PC died and I was forced to upgrade. I'm a huge fan of low-end CPUs so my choice was Gigabyte Z370 MB and Intel i3-8100 with integrated UHD 630 graphics. Unfortunately it does not work. There's no video acceleration at all and my Mint 18 is unusable.

Following this article: https://www.phoronix.com/scan.php?page= ... hics&num=1 I've added the i915.alpha_support=1 option to my Kernel. Unfortunately the X-server does not come up when it is enabled. Dmesg gives the following:

Code: Select all

[    0.000000] Command line: BOOT_IMAGE=/boot/vmlinuz-4.13.0-26-generic root=UUID=141c9360-a30e-4cfd-b97d-29b7b085fbe5 ro vt.handoff=7 i915.alpha_support=1
[    0.000000] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-4.13.0-26-generic root=UUID=141c9360-a30e-4cfd-b97d-29b7b085fbe5 ro vt.handoff=7 i915.alpha_support=1
[    4.767295] WARNING: CPU: 2 PID: 165 at /build/linux-hwe-UY0ygs/linux-hwe-4.13.0/drivers/gpu/drm/i915/i915_drv.c:230 i915_driver_load+0x104b/0x14c0 [i915]
[    4.767296] Modules linked in: usbhid i915(+) i2c_algo_bit drm_kms_helper e1000e syscopyarea sysfillrect sysimgblt ptp fb_sys_fops ahci pps_core drm libahci wmi video i2c_hid hid
[    4.767324] RIP: 0010:i915_driver_load+0x104b/0x14c0 [i915]
[    4.767352]  i915_pci_probe+0x4e/0x70 [i915]
[    4.767392]  i915_init+0x57/0x5a [i915]
[    4.782224] i915 0000:00:02.0: Direct firmware load for i915/kbl_dmc_ver1_01.bin failed with error -2
[    4.782226] i915 0000:00:02.0: Failed to load DMC firmware [https://01.org/linuxgraphics/downloads/firmware], disabling runtime power management.
[    4.782650] i915 0000:00:02.0: vgaarb: changed VGA decodes: olddecodes=io+mem,decodes=io+mem:owns=io+mem
[    5.054373] [drm] Initialized i915 1.6.0 20170619 for 0000:00:02.0 on minor 0
[    5.156961] i915 0000:00:02.0: fb0: inteldrmfb frame buffer device
[   15.512347] snd_hda_intel 0000:00:1f.3: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915])
I tried the latest 4.4, 4.13 and even 4.15-rc5 kernels. They all fail on Mint 18.

So I'm typing this on Ubuntu 17.10. Here everything works and the dmesg produces:

Code: Select all

[    0.000000] Command line: BOOT_IMAGE=/boot/vmlinuz-4.13.0-16-generic root=UUID=2697846e-3165-4684-8cb3-d09508bfb93a ro quiet splash vt.handoff=7 i915.alpha_support=1
[    0.000000] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-4.13.0-16-generic root=UUID=2697846e-3165-4684-8cb3-d09508bfb93a ro quiet splash vt.handoff=7 i915.alpha_support=1
[    4.835693] WARNING: CPU: 0 PID: 175 at /build/linux-XO_uEE/linux-4.13.0/drivers/gpu/drm/i915/i915_drv.c:230 i915_driver_load+0x11d4/0x14b0 [i915]
[    4.835693] Modules linked in: usbhid i915(+) e1000e ptp pps_core i2c_algo_bit drm_kms_helper syscopyarea sysfillrect sysimgblt fb_sys_fops ahci drm libahci wmi video i2c_hid hid
[    4.835718] RIP: 0010:i915_driver_load+0x11d4/0x14b0 [i915]
[    4.835744]  i915_pci_probe+0x42/0x70 [i915]
[    4.835780]  i915_init+0x57/0x5a [i915]
[    4.849665] [drm] Finished loading DMC firmware i915/kbl_dmc_ver1_01.bin (v1.1)
[    4.850165] i915 0000:00:02.0: vgaarb: changed VGA decodes: olddecodes=io+mem,decodes=io+mem:owns=io+mem
[    5.122392] [drm] Initialized i915 1.6.0 20170619 for 0000:00:02.0 on minor 0
[    5.225358] i915 0000:00:02.0: fb0: inteldrmfb frame buffer device
[    5.884384] snd_hda_intel 0000:00:1f.3: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915])
I hate Ubuntu's user interface. I'd love to go back to my beloved Mint. Please help!
Last edited by Moem on Wed Sep 26, 2018 9:40 am, edited 1 time in total.
Reason: Marked this as [SOLVED] for you; please note that you can and should do this for your own topics. Thanks!

gbgustafson
Level 1
Level 1
Posts: 2
Joined: Sun Mar 13, 2016 8:26 pm

Re: Intel UHD 630 "Coffee Lake" support

Post by gbgustafson » Wed Feb 07, 2018 9:20 pm

In debugging Linux Mint 17.3 and Linux Mint 18.3 on a new Z370 board, video seems to be the issue.

Previous hardware of Z270 MSI worked. Same for Z170 ASROCK hardware. There were issues for MSI, like a hang of 15 seconds on grub2 boot from HDD. I would classify the complaints as minor, even if unsolvable. These examples had proper video, solid boot and stable operation, plus the unexpected bonus of suspend/resume working with no setup labor required.

The situation with ASROCK Z370 hardware is completely different. The trouble seems to be Intel UHD630 video.

For example, all attempts to get suspend/resume or hibernate/resume to work have failed on this hardware using CoffeeLake cpu/intel630 graphics mix.

Other indicators of video issues emerged from video board games like Klondike, which has run under Wine 1.1 and 1.6 without issues for 10 years. On the ASROCK Z370 board klondike has failures, the first ever witnessed for this low-level graphics app. It took an install of Wine 2.1 using Playonlinux to make the old Windows board game work normally.

Video.
There are unsolved problems with Intel 630 graphics and older apps. Equally troubling is suspend/resume, which basically functions, but video issues deliver a black screen with no known effective solutions from the past. This includes all know quirks and kernel parameter fixes that used to work in the past. For instance, the July 2017
suggestion for kernel parameter "i915.alpha_support=1" makes no impact on kernel 4.8.7-040807-generic
[Feb 2018] for either Mint 17.3 or 18.3.

Currently, Linux Mint support for Z370 depends on the Linux kernel version and Intel video driver support, plus evolving Mint Team efforts towards Z370 support. I will wait for the Mint Team to apply the Z370/UHD630 fixes that worked for Archlinux and Ubuntu.

aki-y
Level 1
Level 1
Posts: 1
Joined: Mon Feb 12, 2018 12:18 am

Re: Intel UHD 630 "Coffee Lake" support

Post by aki-y » Mon Feb 12, 2018 12:29 am

I dno't know why but select recovery mode on boot later 4.15.1 kernel works fine for me. I currently using 4.15.2 upgraded by ukuu. Please try it.

PierreVH
Level 1
Level 1
Posts: 1
Joined: Sun Mar 04, 2018 3:06 am

Re: Intel UHD 630 "Coffee Lake" support

Post by PierreVH » Sun Mar 04, 2018 3:40 am

This is how I managed to get my Coffee Lake UHD 630 working with linux mint 18.3 (64 bit):

1. Upgrade to kernel 4.13.0 with update manager

2. In a terminal run:
sudo apt install xserver-xorg-hwe-16.04 xserver-xorg-input-all-hwe-16.04

3. Add the following boot-parameter when booting:
i915.alpha_support=1

This can be done dynamically (temporary) by editing a boot menu-line from the grub menu at boot-time
Or permanently by editing /etc/default/grub and running sudo update-grub

Hope it helps .

Pierre

User avatar
amethyst_igor
Level 3
Level 3
Posts: 143
Joined: Thu Feb 25, 2016 9:15 pm
Location: State of Euphoria
Contact:

Re: Intel UHD 630 "Coffee Lake" support

Post by amethyst_igor » Fri Mar 09, 2018 10:37 pm

PierreVH wrote:
Sun Mar 04, 2018 3:40 am
This is how I managed to get my Coffee Lake UHD 630 working with linux mint 18.3 (64 bit):

1. Upgrade to kernel 4.13.0 with update manager

2. In a terminal run:
sudo apt install xserver-xorg-hwe-16.04 xserver-xorg-input-all-hwe-16.04

3. Add the following boot-parameter when booting:
i915.alpha_support=1

This can be done dynamically (temporary) by editing a boot menu-line from the grub menu at boot-time
Or permanently by editing /etc/default/grub and running sudo update-grub

Hope it helps .

Pierre
This is correct, and also works with kernel 4.15.8, installed using the convenient, time-saving graphical user interface of ukuu, a popular ubuntu kernel installer.
I was having a lot of problems with a brand new MSI Z370M Mortar with an i3-8100 cpu. No kernels above 4.13.x work, unless booting in recovery mode, which does work, although the font tends to get tiny.
Pierre's workaround is the best to date and the one I am staying with until Linux Mint's Update Manager introduces a 4.15 kernel.
I believe that the boot parameter he refers to, the i915 bit, must be inserted into the line with the quote marks that has the words "quiet splash".
I run both Windows 10 and Linux Mint 18 in dual boot with two SSDs and have other rigs running various versions of Linux. My blog.

ea234
Level 1
Level 1
Posts: 3
Joined: Sun Mar 11, 2018 5:55 am
Location: Germany, Hamburg

Re: Intel UHD 630 "Coffee Lake" support

Post by ea234 » Sun Mar 11, 2018 6:12 am

PC MSI Z370 + I7 8700
Screen Resolution was 1074 x 756

1. I reinstalled Linux Mint 18.3 (as German Version)
2. I startet the Update Manager and selected the Kernel 4.13.0xxxx
(all other Updates were installed too)
3. I startet: sudo apt install xserver-xorg-hwe-16.04 xserver-xorg-input-all-hwe-16.04
4. I added the Command Line Parameter:

Command: gksudo xed /etc/default/grub

changed the Line: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
to GRUB_CMDLINE_LINUX_DEFAULT="i915.alpha_support=1 quit splash"

saved the File.

5. update Grub: Command sudo update-grub

That worked.

spaceman_spiff
Level 1
Level 1
Posts: 1
Joined: Fri Mar 23, 2018 6:34 am

Re: Intel UHD 630 "Coffee Lake" support

Post by spaceman_spiff » Fri Mar 23, 2018 7:13 am

Thank you so much! You ended 3 days of computer chaos!
The other posts I found recommended the

Code: Select all

i915.alpha_support=1
all over the internet but without

Code: Select all

sudo apt install xserver-xorg-hwe-16.04 xserver-xorg-input-all-hwe-16.04
it gets stuck on boot with a black screen! :-(

Thank you for posting this @PierreVH !

elihaidv
Level 1
Level 1
Posts: 3
Joined: Tue Apr 17, 2018 4:28 pm

Re: Intel UHD 630 "Coffee Lake" support

Post by elihaidv » Mon Apr 23, 2018 3:07 pm

ea234 wrote:
Sun Mar 11, 2018 6:12 am
PC MSI Z370 + I7 8700
Screen Resolution was 1074 x 756

1. I reinstalled Linux Mint 18.3 (as German Version)
2. I startet the Update Manager and selected the Kernel 4.13.0xxxx
(all other Updates were installed too)
3. I startet: sudo apt install xserver-xorg-hwe-16.04 xserver-xorg-input-all-hwe-16.04
4. I added the Command Line Parameter:

Command: gksudo xed /etc/default/grub

changed the Line: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
to GRUB_CMDLINE_LINUX_DEFAULT="i915.alpha_support=1 quit splash"

saved the File.

5. update Grub: Command sudo update-grub

That worked.
Thank you vary much!
I spent about that issue above a week!
You'r the best! :D :D

User avatar
Grizzly Adam
Level 1
Level 1
Posts: 6
Joined: Fri Jul 20, 2018 6:07 pm

Re: Intel UHD 630 "Coffee Lake" support

Post by Grizzly Adam » Sat Jul 21, 2018 6:46 pm

ea234 wrote:
Sun Mar 11, 2018 6:12 am
1. I reinstalled Linux Mint 18.3 (as German Version)
2. I startet the Update Manager and selected the Kernel 4.13.0xxxx
(all other Updates were installed too)
3. I startet: sudo apt install xserver-xorg-hwe-16.04 xserver-xorg-input-all-hwe-16.04
4. I added the Command Line Parameter:

Command: gksudo xed /etc/default/grub

changed the Line: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
to GRUB_CMDLINE_LINUX_DEFAULT="i915.alpha_support=1 quit splash"

saved the File.

5. update Grub: Command sudo update-grub
This method worked for my intel UHD 605 on Mint 18.3. However, I had to use 4.11.0-14 as any later kernels would not boot. The only downside is now I have a big black blob of a cursor, it looks like there is a shading and shadow issue. Any idea how I could resolve this?

User avatar
smurphos
Level 7
Level 7
Posts: 1600
Joined: Fri Sep 05, 2014 12:18 am
Location: Britisher...

Re: Intel UHD 630 "Coffee Lake" support

Post by smurphos » Sun Jul 22, 2018 1:12 am

Grizzly Adam wrote:
Sat Jul 21, 2018 6:46 pm
Any idea how I could resolve this?
Try Mint 19 - I think this hardware should now be supported out of the box with no tweaks required.
Mint 18.x - try the 4.15.0-x (avoiding -24) kernel series from the update manager reverting to the standard grub 'quiet splash'

User avatar
Grizzly Adam
Level 1
Level 1
Posts: 6
Joined: Fri Jul 20, 2018 6:07 pm

Re: Intel UHD 630 "Coffee Lake" support

Post by Grizzly Adam » Sun Jul 22, 2018 10:27 am

smurphos wrote:
Sun Jul 22, 2018 1:12 am
Try Mint 19 - I think this hardware should now be supported out of the box with no tweaks required.
Mint 18.x - try the 4.15.0-x (avoiding -24) kernel series from the update manager reverting to the standard grub 'quiet splash'
19 does work right out of the box, but i need 18 until the issues with the newer version of kdenlive are fixed.I will give this a try.

Mattyboy
Level 6
Level 6
Posts: 1196
Joined: Thu Mar 26, 2015 2:17 pm

Re: Intel UHD 630 "Coffee Lake" support

Post by Mattyboy » Sun Jul 22, 2018 10:40 am

Grizzly Adam wrote:
Sun Jul 22, 2018 10:27 am
18 until the issues with the newer version of kdenlive are fixed.I will give this a try.
fyi, kdenlive ( latest version 18.04.2 ) now works in 19 just fine. I had been using the app image for ubuntu 18.04 ( also working fine ) downloaded from their site as the flatpack install wouldn't work properly. Funny enough, today, after a bunch of updates I successfully installed it via flatpack and works great.

Code: Select all

Host: admin1-To-be-filled-by-O-E-M Kernel: 4.15.0-29-generic x86_64
           bits: 64 gcc: 7.3.0
           Desktop: Cinnamon 3.8.8 (Gtk 3.22.30-1ubuntu1)
           Distro: Linux Mint 19 Tara

User avatar
Grizzly Adam
Level 1
Level 1
Posts: 6
Joined: Fri Jul 20, 2018 6:07 pm

Re: Intel UHD 630 "Coffee Lake" support

Post by Grizzly Adam » Sun Jul 22, 2018 11:05 am

Mattyboy wrote:
Sun Jul 22, 2018 10:40 am
fyi, kdenlive ( latest version 18.04.2 ) now works in 19 just fine. I had been using the app image for ubuntu 18.04 ( also working fine ) downloaded from their site as the flatpack install wouldn't work properly. Funny enough, today, after a bunch of updates I successfully installed it via flatpack and works great.

Code: Select all

Host: admin1-To-be-filled-by-O-E-M Kernel: 4.15.0-29-generic x86_64
           bits: 64 gcc: 7.3.0
           Desktop: Cinnamon 3.8.8 (Gtk 3.22.30-1ubuntu1)
           Distro: Linux Mint 19 Tara
It works fine unless you are encoding a long video, then the audio falls out of sync. I use it to encode movies every week four our outdoor movie nights and any version of kdenlive older than 16 has sync problems. Could be due to the versions of ffmpeg or mlt it uses.

User avatar
Grizzly Adam
Level 1
Level 1
Posts: 6
Joined: Fri Jul 20, 2018 6:07 pm

Re: Intel UHD 630 "Coffee Lake" support

Post by Grizzly Adam » Sun Jul 22, 2018 11:45 am

Kernel 4.150.23 has me all sorted out, thanks. For the record, .29 did not work.

tricolery
Level 1
Level 1
Posts: 5
Joined: Fri Jun 01, 2018 3:27 pm

Re: Intel UHD 630 "Coffee Lake" support

Post by tricolery » Tue Sep 25, 2018 4:36 pm

Hello, sorry to revive an old topic, but I'm facing the same problems described on this thread.
Sometimes when I use a web browser (tested with google chrome and firefox) the image gets frozen, the computer receive the commands, but the image gets static for 3 seconds or so, then it returns to normal. I also facing the same problem when I play games, such as snes9x emulator or the pcsxr emulator. The same problem as the web browser, the image freezes, I can still hear the sound of the game playing, I can still use the controller, but the image stays static. Sometimes I'm on desktop just using the libreOffice and organizing my files and I see the same symptoms.
I've never had this problem when I was on mint 18.2, this started to happen on mint 19.

Info I can provide to you: (tell me if you need anything more):

I have this computer:
https://www.msi.com/Desktop/Cubi.html

This is my kernel: 4.15.0-34-generic

Everything is up to date.

This is the relevant output of inxi:

CPU: Dual core Intel Pentium 3825U (-MT-MCP-)
arch: Broadwell rev.4 cache: 2048 KB
flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 7582
clock speeds: max: 1900 MHz 1: 812 MHz 2: 1492 MHz 3: 1341 MHz
4: 1435 MHz
Graphics: Card: Intel HD Graphics bus-ID: 00:02.0
Display Server: x11 (X.Org 1.19.6 )
drivers: modesetting (unloaded: fbdev,vesa)
Resolution: 1920x1080@60.00hz
OpenGL: renderer: Mesa DRI Intel Broadwell GT1
version: 4.5 Mesa 18.0.5 Direct Render: Yes

What I tried so far:

-Installed the package: i965-va-driver ( didn't help anything)
-Removed the package xorg-xserver-video-intel (reinstalled it after when I saw I had not fixed the issue.)
-Created that famous 20-intel.conf (sna, dri true) file on my X11 folder. (Didn't help and both my vnc and my teamviewer went nuts. Everything that had a transparency didn't stop blinking)
-I also tried the steps described on this thread. The xserver-xorg-hwe-16.04 xserver-xorg-input-all-hwe-16.04 and edit the grub file.

If you need anymore info I'm gladly collect it for you.

I also see an issue, don't know if it happens to everyone, when a tool tip is going to appear (i.e. I hover the mouse over the "show desktop" button and its tool tip appears) it quickly blinks on the top left edge of my screen, then it appears under the mouse. The exact same thing happens when I move a icon, the icon I'm moving quickly appears on top left edge of the screen then it appears under the mouse.
Don't know if these 2 issues are connected (the second issue does not even bother me), but I thought it would be a good idea to mention it.

What do you people think that is happening?
I know this computer is not common, but for my needs its perfect. It also makes a big energy economy on the end of the month. I casually turn my gaming rig on now. And I love the new mint 19, don't want to return to 18 series.

English is not my main language, so sorry if I said anything strange.

User avatar
smurphos
Level 7
Level 7
Posts: 1600
Joined: Fri Sep 05, 2014 12:18 am
Location: Britisher...

Re: Intel UHD 630 "Coffee Lake" support

Post by smurphos » Wed Sep 26, 2018 4:51 am

This probably deserves it's own topic- although the symptoms may be similar the root cause will probably be different - your processor is not so new (it's Broadwell - gen 5) that kernel driver support should be an issue. Please also post the full output of inxi -Fxz

tricolery
Level 1
Level 1
Posts: 5
Joined: Fri Jun 01, 2018 3:27 pm

Re: Intel UHD 630 "Coffee Lake" support

Post by tricolery » Wed Sep 26, 2018 9:26 am

Thanks :)

I created a new thread.

viewtopic.php?f=59&t=278416

User avatar
Moem
Level 16
Level 16
Posts: 6751
Joined: Tue Nov 17, 2015 9:14 am
Location: The Netherlands
Contact:

Re: Intel UHD 630 "Coffee Lake" support

Post by Moem » Wed Sep 26, 2018 9:39 am

tricolery wrote:
Wed Sep 26, 2018 9:26 am
I created a new thread.
Mod note:
Thanks, it's appreciated!
Image

If your issue is solved, kindly indicate that by editing the first post in the topic, and adding [SOLVED] to the title. Thanks!

Post Reply

Return to “Graphics Cards & Monitors”