Cinnamon "running in software rendering mode"

Screen resolution, 3D Acceleration, nVidia, ATI
Forum rules
Before you post please read this
Post Reply
martinwag
Level 1
Level 1
Posts: 6
Joined: Mon Apr 30, 2012 9:02 am

Cinnamon "running in software rendering mode"

Post by martinwag » Fri Jan 12, 2018 5:31 am

Hi @all,

After boot I get the message "running in software rendering mode ...". I know this has been asked many times, but every answer is either very specific or boils down to "install proprietary driver".

Normally, I'm using auto-logon. The error is gone when I log out and then log in again (witout rebooting). It's also gone when enabling manual log in. So it seems to me that this is a timing problem, meaning it's fixed by adding something like "sleep 1" in a config file.
How can I debug this? Where does Cinnamon write its log files? I can't find anything in the syslog.

Thanks for your help!

regards,
Martin

- Mint 18.3, freshly updated from 17.3. Everyting else works (as far as I have checked :-) ).
- system infos

Code: Select all

martin@mint-rot:~$ inxi -Fxz
System:    Host: mint-rot Kernel: 4.13.0-26-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: Cinnamon 3.6.7 (Gtk 2.24.30) Distro: Linux Mint 18.3 Sylvia
Machine:   Mobo: MSI model: 970A-G43 PLUS (MS-7974) v: 1.0 Bios: American Megatrends v: V1.0 date: 12/17/2015
CPU:       Octa core AMD FX-8320E Eight-Core (-MCP-) cache: 16384 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm) bmips: 51200
           clock speeds: max: 3200 MHz 1: 1400 MHz 2: 1400 MHz 3: 1400 MHz 4: 1800 MHz 5: 1400 MHz 6: 1400 MHz
           7: 1800 MHz 8: 1400 MHz
Graphics:  Card: Advanced Micro Devices [AMD/ATI] Barts PRO [Radeon HD 6850] bus-ID: 01:00.0
           Display Server: X.Org 1.18.4 drivers: ati,radeon (unloaded: fbdev,vesa) Resolution: 1280x1024@60.02hz
           GLX Renderer: AMD BARTS (DRM 2.50.0 / 4.13.0-26-generic, LLVM 5.0.0)
           GLX Version: 3.0 Mesa 17.2.4 Direct Rendering: Yes
Audio:     Card-1 Advanced Micro Devices [AMD/ATI] Barts HDMI Audio [Radeon HD 6800 Series]
           driver: snd_hda_intel bus-ID: 01:00.1
           Card-2 Advanced Micro Devices [AMD/ATI] SBx00 Azalia (Intel HDA) driver: snd_hda_intel bus-ID: 00:14.2
           Sound: Advanced Linux Sound Architecture v: k4.13.0-26-generic
Network:   Card-1: Techsan B2C2 FlexCopII DVB chip / Technisat SkyStar2 DVB card
           driver: b2c2_flexcop_pci port: d000 bus-ID: 03:06.0
           IF: N/A state: N/A speed: N/A duplex: N/A mac: N/A
           Card-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           driver: r8169 v: 2.3LK-NAPI port: c000 bus-ID: 04:00.0
           IF: eth1 state: up speed: 1000 Mbps duplex: full mac: <filter>
           Card-3: Qualcomm Atheros AR9485 Wireless Network Adapter driver: ath9k bus-ID: 06:00.0
           IF: wlan0 state: down mac: <filter>
Drives:    HDD Total Size: 400.1GB (33.5% used) ID-1: /dev/sda model: WDC_WD1600AAJS size: 160.0GB
           ID-2: /dev/sdb model: ADATA_SP550 size: 240.1GB
Partition: ID-1: / size: 29G used: 17G (59%) fs: ext4 dev: /dev/sdb5
           ID-2: /home size: 144G used: 109G (81%) fs: ext4 dev: /dev/sdb6
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 45.0C mobo: 29.0C gpu: 46.0
           Fan Speeds (in rpm): cpu: 701 fan-2: 0 fan-3: 602
Info:      Processes: 235 Uptime: 7 min Memory: 1133.6/16051.3MB Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35

martin@mint-rot:~$ glxinfo | grep render
direct rendering: Yes
    GLX_MESA_multithread_makecurrent, GLX_MESA_query_renderer, 
    GLX_MESA_multithread_makecurrent, GLX_MESA_query_renderer, 
Extended renderer info (GLX_MESA_query_renderer):
OpenGL renderer string: AMD BARTS (DRM 2.50.0 / 4.13.0-26-generic, LLVM 5.0.0)
    GL_ARB_conditional_render_inverted, GL_ARB_conservative_depth, 
    GL_NV_conditional_render, GL_NV_depth_clamp, GL_NV_packed_depth_stencil, 
    GL_ARB_conditional_render_inverted, GL_ARB_conservative_depth, 
    GL_NV_blend_square, GL_NV_conditional_render, GL_NV_depth_clamp, 
    GL_OES_element_index_uint, GL_OES_fbo_render_mipmap,

orschiro
Level 4
Level 4
Posts: 230
Joined: Mon Dec 04, 2017 2:56 am
Contact:

Re: Cinnamon "running in software rendering mode"

Post by orschiro » Sat Jan 13, 2018 3:44 am

Normally, I'm using auto-logon. The error is gone when I log out and then log in again (witout rebooting). It's also gone when enabling manual log in
I think you have found a good workaround. Does it work for you to switch to manual login permanently?

Mintoine
Level 1
Level 1
Posts: 4
Joined: Sun Jan 07, 2018 1:17 pm

Re: Cinnamon "running in software rendering mode"

Post by Mintoine » Mon Jan 15, 2018 8:02 pm

Can you install and try to run Blender 3D just for test?

I've similar problems as you, with 2 desktop (KDE, Cinnamon) and Blender 3D.

Problems comes after updaping mesa packages from 17.0.7 to 17.2.4 version.

(I've a old ATI videao-card : Radeon X1200.)

martinwag
Level 1
Level 1
Posts: 6
Joined: Mon Apr 30, 2012 9:02 am

Re: Cinnamon "running in software rendering mode"

Post by martinwag » Tue Jan 16, 2018 1:38 pm

Increasing boot time by 10s is not really a solution to me. It seems this also works only sometimes...

Blender starts and is able to render the cube that is there at first start. I have no idea whatsoever how to do anything more with Blender.
Otherwise, I'm able to run 3d games in steam (which actually surprises me :-) )

User avatar
Joe2Shoe
Level 3
Level 3
Posts: 161
Joined: Wed Oct 18, 2017 8:12 pm
Location: Ozone

Re: Cinnamon "running in software rendering mode"

Post by Joe2Shoe » Tue Jan 16, 2018 1:50 pm

I have a 10 year old laptop with the AMD/ATI Radeon video chip. I had the "Software-mode rendering" upon boot up, and/or the multiple vertical colored lines at boot and the laptop starts-up with vertical colored lines & will not successfully boot into LM.
The following works for me. Good luck.

1. Boot the laptop.
2. Press the "Shift" key immediately after the BIOS screen finishes.
3. Select "Recovery Mode".
4. Laptop boots to "Recovery Mode".
5. Edit Grub in Terminal: sudo gedit /etc/default/grub
6. Enable the following line (or add if not listed):
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash noacpi"
7. Disable all other "GRUB_CMDLINE_LINUX_DEFAULT="xxxxxx" lines by adding "# " before the lines.
8. Click "Save".
9. Update Grub in Terminal: sudo update-grub
10. In Terminal: reboot
11. If Grub menu appears, select "normal boot".
"Tolerance is the refuge of men without conviction."
"Common sense is not so common" - Voltaire

martinwag
Level 1
Level 1
Posts: 6
Joined: Mon Apr 30, 2012 9:02 am

Re: Cinnamon "running in software rendering mode"

Post by martinwag » Tue Jan 30, 2018 12:50 pm

@Joe2Shoe
doesn't work for me.

martinwag
Level 1
Level 1
Posts: 6
Joined: Mon Apr 30, 2012 9:02 am

Re: Cinnamon "running in software rendering mode"

Post by martinwag » Mon Feb 05, 2018 3:23 pm

Finally found a workaround for this...

showing file ~/.xsession-errors while still being logged in into the software session gives me this:
...
libGL error: failed to open drm device: Permission denied
libGL error: failed to load driver: r600
...

which brings me here: https://bugs.launchpad.net/compiz/+bug/1302270
It's possible to work around the bug by using "chown -R user /dev/dri".
so adding

Code: Select all

chown -R martin /dev/dri/*
to /etc/rc.local fixes this for me. Note that this will work only for one user.


The "correct" solution for this seems to be to add the user to video group. However, I was not successful with that on my first attempt, so I didn't dig deeper into that.

Post Reply

Return to “Graphic Cards & Monitors”