Mint 18.3 - Wrong Nvidia drivers for the GeForce Go 6800(?)

Screen resolution, 3D Acceleration, nVidia, ATI
Forum rules
Before you post please read this
Post Reply
eightone
Level 1
Level 1
Posts: 3
Joined: Mon Jan 15, 2018 1:41 pm
Location: Poland

Mint 18.3 - Wrong Nvidia drivers for the GeForce Go 6800(?)

Post by eightone » Mon Jan 15, 2018 2:10 pm

Hi there

I apologize for any language mistakes, English is not my native language.

As for Linux, I never tried it before.

Quick specs:
Fujitsu-Siemens Amilo M3438G laptop
915 chipset
Pentium M 770
GeForce Go 6800
2GB RAM
17" 1440x900 display

Linux Mint 18.3 XFCE 32bit

Yes, it's quite old laptop, but it's OK for office work, watching FHD movies and playing ~15 years old games. I'm searching for the best suitable Linux distribution. Nine distros testes so far, only two of them are working :| that is: Linux Lite 3.6 and Linux Mint 18.3.
As for Mint, I liked it from the beginning, it runs quite well, there is only one problem.

The default nouveau graphics driver works fine, but I wanted to install official Nvidia driver. So I did it through the drivers panel, which showed me: "304.135-0ubuntu0.16.04.1 Nvidia legacy binary driver v 304.135". I chose it, the installation went well, but after reboot, my screen resolution is 1024x768, and I can only change it to lower (800x600 and 640x480). It should be 1440x900. Another weird thing is Nvidia panel, which is almost empty, there are only two tabs: apps profiles and nvidia settings.

Before that, I tested Linux Lite 3.6, I installed the same Nvidia driver v304.135, through the drivers panel. And after reboot, everything works well! My screen resolution was 1440x900, the Nvidia panel was complete (colours change, resolution change, 3D settings, thermal diode and many more).

inxi -Fxz :

Code: Select all

mm@mm-Amilo-M3438-Series ~ $ inxi -Fxz
System:    Host: mm-Amilo-M3438-Series Kernel: 4.13.0-26-generic i686 (32 bit gcc: 5.4.0)
           Desktop: Xfce 4.12.3 (Gtk 2.24.28) Distro: Linux Mint 18.3 Sylvia
Machine:   System: FUJITSU SIEMENS (portable) product: Amilo M3438 Series
           Mobo: N/A model: P71EN0
           Bios: American Megatrends v: 1.10C date: 10/05/2005
CPU:       Single core Intel Pentium M (-UP-) cache: 2048 KB
           flags: (nx pae sse sse2) bmips: 4266 speed: 2128 MHz (max)
Graphics:  Card: NVIDIA NV41M [GeForce Go 6800] bus-ID: 03:00.0
           Display Server: X.Org 1.18.4 drivers: vesa (unloaded: fbdev) FAILED: nvidia,nouveau
           Resolution: 1024x768@61.00hz
           GLX Renderer: N/A GLX Version: N/A Direct Rendering: N/A
Audio:     Card Intel 82801FB/FBM/FR/FW/FRW (ICH6 Family) High Definition Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0
           Sound: Advanced Linux Sound Architecture v: k4.13.0-26-generic
Network:   Card-1: Intel PRO/Wireless 2200BG [Calexico2] Network Connection
           driver: ipw2200 v: 1.2.2kmprq bus-ID: 01:03.0
           IF: wlp1s3 state: up mac: <filter>
           Card-2: Realtek RTL8169 PCI Gigabit Ethernet Controller
           driver: r8169 v: 2.3LK-NAPI port: c800 bus-ID: 01:05.0
           IF: enp1s5 state: down mac: <filter>
Drives:    HDD Total Size: 120.0GB (15.1% used)
           ID-1: /dev/sda model: FUJITSU_MHT2060B size: 60.0GB
           ID-2: /dev/sdb model: FUJITSU_MHT2060B size: 60.0GB
Partition: ID-1: / size: 53G used: 15G (30%) fs: ext4 dev: /dev/sda1
           ID-2: swap-1 size: 2.14GB used: 0.00GB (0%) fs: swap dev: /dev/dm-0
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 22.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 163 Uptime: 2 min Memory: 429.6/2012.4MB
           Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35 
mm@mm-Amilo-M3438-Series ~ $ 
I will be grateful for your help.
Regards.
Mariusz

Gurnsy
Level 1
Level 1
Posts: 4
Joined: Mon Apr 10, 2017 4:12 pm

Re: Mint 18.3 - Wrong Nvidia drivers for the GeForce Go 6800(?)

Post by Gurnsy » Mon Jan 15, 2018 5:33 pm

Hello

I'm running the x64 version of LM18.3 MATE and have had a similar issue since the security based 4.13.0-26 kernel update that was made available last week. The effected laptop has a NV6150 Go so like yourself the only Nvidia driver version I can use is the 304.135 version.

I have been searching for any news of an update pending for the 304.135 drivers for LM18.3 and have found no indication that they are going to be updated. When searching the nvidia site the list of available proprietary drivers, the list of supported video cards by the 304.137 has had the 6xxx Go series entries removed for some time now. http://www.nvidia.com/download/driverRe ... 3709/en-us

I'd refer anyone experiencing this issue to watch the official LM blog for updates. https://blog.linuxmint.com/?p=3496

In the mean time. I was able to get the 304.135 driver to work by rolling back to the 4.4.0-109 kernel and re-installing the nvidia driver. The security blog indicates that 4.4.0-108 kernel has had the security update(s) applied. I'm hoping this will provide a secure environment until a fix becomes available.

Cheers

eightone
Level 1
Level 1
Posts: 3
Joined: Mon Jan 15, 2018 1:41 pm
Location: Poland

Re: Mint 18.3 - Wrong Nvidia drivers for the GeForce Go 6800(?)

Post by eightone » Tue Jan 16, 2018 3:43 pm

I see. So I guess when I tested, the Linux Lite 3.6 has had older kernel version, compared to Linux Mint 18.3.

Thank you, I did as you wrote, for now, everything works fine. I'll be testing it.

Gurnsy
Level 1
Level 1
Posts: 4
Joined: Mon Apr 10, 2017 4:12 pm

Re: Mint 18.3 - Wrong Nvidia drivers for the GeForce Go 6800(?)

Post by Gurnsy » Thu Jan 18, 2018 7:59 pm

An update to the 304.135 driver became available today.

I was able to install the 4.13.0-26 kernel and reinstall the updated 304.135 driver successfully.

I'm very impressed that the 304.135 driver was updated so quickly. What an amazing community!

Cheers

eightone
Level 1
Level 1
Posts: 3
Joined: Mon Jan 15, 2018 1:41 pm
Location: Poland

Re: Mint 18.3 - Wrong Nvidia drivers for the GeForce Go 6800(?)

Post by eightone » Sun Jan 21, 2018 2:50 pm

Unfortunately, it doesn't work for me :(
With 4.4.0-109 kernel, everything works fine, I get the updated driver and all went fine, no problems whatsoever.
But when I removed nvidia drivers, installed 4.13.0-26 kernel and then installed updated 304.135 driver, everything was broken again, no native resolution, nvidia panel is empty etc.
So I guess I'm stuck with older kernel.


Edit
Damn. Kernel updated to 4.4.0.112 and... nvidia 304.135 driver is broken too.
I'm stick with 4.4.0-109.

Post Reply

Return to “Graphic Cards & Monitors”