Nvidia Drivers in Driver Manager are ALL incompatible with 18.3

Screen resolution, 3D Acceleration, nVidia, ATI
Forum rules
Before you post please read this
Post Reply
ultiweb
Level 1
Level 1
Posts: 1
Joined: Thu Jan 18, 2018 7:28 am

Nvidia Drivers in Driver Manager are ALL incompatible with 18.3

Post by ultiweb » Thu Jan 18, 2018 7:51 am

Hello,

Listing the drivers using apt search shows every Nvidia driver I install from Driver Manager as having broken dependencies. I dug into it a little to see which dependencies are out of whack and I found that not one of the Nvidia drivers is compatible with a completely up to date Mint 18.3. These are very important dependencies like glibc and libc6, that you don't just start changing willy nilly. I'm only showing versions 384.111, 387.34 and 390.12, which is beta. 384 is the closest to not being broken. On my 6-month-old Dell XPS 15 9560 with GT 1050 chipset I can only use Intel. Stupidly I updated to 384.111 from an earlier 384.something and can no longer use that version, which was working fine. It's a bad idea to be showing only drivers that are not compatible with the OS. I thought it was odd that not one of the drivers is shown as recommended. The drivers that are shown need to be rolled back or the OS needs to be updated. Otherwise, this breaks systems.

In the end, it's on me, I should have checked every single dependency before installing. However, I trusted the OS not to show me broken drivers. Unless I want to spend all my time chasing my tail, I won't do that again. I'll end my rant here. :)

384.111 is supposed to help fix Spectre and Meltdown.

Randy

Hoser Rob
Level 12
Level 12
Posts: 4192
Joined: Sat Dec 15, 2012 8:57 am

Re: Nvidia Drivers in Driver Manager are ALL incompatible with 18.3

Post by Hoser Rob » Thu Jan 18, 2018 10:49 am

They may all be incompatible with your present system config, of which there are few details. Copy/paste this to the terminal and copy/paste the text output here:

Code: Select all

inxi -Fxz

Citizen229
Level 5
Level 5
Posts: 819
Joined: Fri Nov 04, 2016 12:09 pm
Location: NW Ohio

Re: Nvidia Drivers in Driver Manager are ALL incompatible with 18.3

Post by Citizen229 » Fri Jan 19, 2018 6:23 am

Here is a copy paste answer i did on a very similar post:

For the most drivers available in the driver manager....
Fresh install Mint 17.3

For rock steady stability in the OS for a base line.....
Make sure its XFCE

From there you can work your way outward. 18.X for some reason lost about 5 or 6 driver options when I upgraded, with the same card. I am using the same gtx 1060. The drivers may still be there, just the flagging for availability may have been dropped.

Once you find which drivers work, you may be able to find a PPA and manually install that driver in 18.X. I would have to guess the 370 drivers are the target.

Is the xps a laptop? I believe the do different things for lappy versus desktop.
Folding@home Project
Team Linux Mint-76140
PM for info on how you can help. Or visit viewtopic.php?f=58&t=243792
Seeking GPU's, i5/7/9's , Ryzens.

Post Reply

Return to “Graphics Cards & Monitors”