Nvidia GPU not working for laptop with hybrid Intel/Nvidia GPUs

Screen resolution, 3D Acceleration, nVidia, ATI
Forum rules
Before you post please read this
Post Reply
Dreykodoon
Level 1
Level 1
Posts: 1
Joined: Sun Jan 28, 2018 10:05 am

Nvidia GPU not working for laptop with hybrid Intel/Nvidia GPUs

Post by Dreykodoon » Sun Jan 28, 2018 10:22 am

Hello,

After a recent update, I can no longer use my Nvidia GPU, just the Intel one. After running inxi -Fxz and removing unnecessary information, I have the following output:

Code: Select all

System:    Kernel: 4.4.0-109-generic x86_64 (64 bit gcc: 4.8.4)
           Desktop: Cinnamon 2.8.8 (Gtk 3.10.8~8+qiana) Distro: Linux Mint 17.3 Rosa
Machine:   Mobo: ASUSTeK model: X550LB v: 1.0 Bios: American Megatrends v: X550LB.303 date: 09/30/2013
Graphics:  Card-1: Intel Haswell-ULT Integrated Graphics Controller bus-ID: 00:02.0
           Card-2: NVIDIA GK208M [GeForce GT 740M] bus-ID: 04:00.0
           Display Server: X.Org 1.17.1 drivers: intel (unloaded: fbdev,vesa) FAILED: nouveau
           Resolution: 1366x768@60.1hz
           GLX Renderer: Mesa DRI Intel Haswell Mobile GLX Version: 3.0 Mesa 10.5.9 Direct Rendering: Yes
I also tried using both the nvidia-340 and nvidia-384 drivers, but none helped. Currently, the older ones are activated.

Could anyone please help me find a solution?

deepakdeshp
Level 10
Level 10
Posts: 3486
Joined: Sun Aug 09, 2015 10:00 am

Re: Nvidia GPU not working for laptop with hybrid Intel/Nvidia GPUs

Post by deepakdeshp » Tue Jan 30, 2018 1:24 pm

If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
I am using Mint 19 Cinnamon 64 bit with AMD A8/7410 processor . Memory 8GB

Post Reply

Return to “Graphics Cards & Monitors”