cannot boot after selecting intel in nvidia prime settings

Screen resolution, 3D Acceleration, nVidia, ATI
Forum rules
Before you post please read this
Post Reply
Level 1
Level 1
Posts: 1
Joined: Sat Feb 10, 2018 11:33 am

cannot boot after selecting intel in nvidia prime settings

Post by core36 » Sat Feb 10, 2018 1:59 pm

i'm new to linux.

my system:
Schenker XMG Laptop
Intel i7 6820HK
Nvidia GeForce GTX 1060
16 GB ram

this is what i did:
i made a bootable usb drive using rufus and linux mint 18.3 cinnamon 64bit
i set the graphics option in the uefi bios from MShybrid to Discrete
i ran the installer and installed mint
after reboot, i installed the nvidia driver (nvidia-384) from the driver update gui.
and i added "GRUB_GFXPAYLOAD_LINUX=1920*1080" to the "/etc/default/grub" file and then ran "update-grub"
now i was able to boot with MShybrid enabled and the nvidia driver shows prime support and the nvidia card is selected.
i changed it to intel and it told me to log out and back in.
i logged out and it crashed. black screen and nothing worked. only way to shut it down was to hold the power key.
i had to boot in Discrete mode and purge nvidia and install nvidia again to get MShybrid working again.

now i am back on windows an write this.

i need the laptop for work and it involves using blender 3d. i want to use linux because windows 10 forces me to install updates and keeps breaking drivers so that i get bluescreens.
i want a stable system where i am in control again, but for that i need to get nvidia prime to work.

can someone help me? what did i miss?

Post Reply

Return to “Graphics Cards & Monitors”