[SOLVED] Mint 18.3 - Can't get native nvidia driver to be used.

Screen resolution, 3D Acceleration, nVidia, ATI
Forum rules
Before you post please read this
Post Reply
albrnick
Level 1
Level 1
Posts: 2
Joined: Mon Feb 26, 2018 3:13 pm

[SOLVED] Mint 18.3 - Can't get native nvidia driver to be used.

Post by albrnick » Mon Feb 26, 2018 3:23 pm

Hello!

I recently did a fresh install of Mint 18.3, but can't for the life of me get the native nvidia drivers used. I see them as installed, but it always fails to use the nouveau driver, and I'm stuck with cinnamon using software rendering.. I've tried several solutions listed here, but with no luck. :( Any insights you may be able to provide would be most appreciated! Here is the output of some commands:

Code: Select all

$  inxi -SMCGx
System:    Host: sol-2015-18 Kernel: 4.10.0-38-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: Cinnamon 3.6.6 (Gtk 3.18.9-1ubuntu3.3) Distro: Linux Mint 18.3 Sylvia
Machine:   System: ASUS product: All Series
           Mobo: ASUSTeK model: H97-PLUS v: Rev X.0x Bios: American Megatrends v: 2306 date: 10/09/2014
CPU:       Quad core Intel Core i5-4590 (-MCP-) cache: 6144 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 26339
           clock speeds: max: 3700 MHz 1: 3208 MHz 2: 2927 MHz 3: 2131 MHz 4: 3300 MHz
Graphics:  Card: NVIDIA Device 1c81 bus-ID: 01:00.0
           Display Server: X.Org 1.18.4 drivers: fbdev (unloaded: vesa) FAILED: nouveau
           Resolution: 1024x768@76.00hz
           GLX Renderer: Gallium 0.4 on llvmpipe (LLVM 4.0, 256 bits)
           GLX Version: 3.0 Mesa 17.0.7 Direct Rendering: Yes

Code: Select all

$  lspci -nnk |egrep -A3 -i "3D|VGA"
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation Device [10de:1c81] (rev a1)
	Subsystem: Gigabyte Technology Co., Ltd Device [1458:3765]
	Kernel modules: nvidiafb, nouveau, nvidia_390, nvidia_390_drm
01:00.1 Audio device [0403]: NVIDIA Corporation Device [10de:0fb9] (rev a1)

Code: Select all

$ ls /etc/modprobe.d
alsa-base.conf          blacklist-firewire.conf     blacklist-oss.conf           dkms.conf             mlx4.conf
blacklist-ath_pci.conf  blacklist-framebuffer.conf  blacklist-rare-network.conf  fbdev-blacklist.conf  nvidia-390_hybrid.conf
blacklist.conf          blacklist-modem.conf        blacklist-watchdog.conf      iwlwifi.conf          vmwgfx-fbdev.conf

Code: Select all

$ more /etc/modprobe.d/nvidia-390_hybrid.conf 
# This file was installed by nvidia-390
# Do not edit this file manually

blacklist nouveau
blacklist lbm-nouveau
alias nouveau off
alias lbm-nouveau off
I even tried adding nvidia-graphics-drivers.conf file with the 2 lines suggested, with no luck. (Though, I did have that, and the file above as well)

Thoughts? Thanks for your time! :)
Nick
Last edited by albrnick on Wed Feb 28, 2018 10:20 am, edited 1 time in total.

albrnick
Level 1
Level 1
Posts: 2
Joined: Mon Feb 26, 2018 3:13 pm

Re: Mint 18.3 - Can't get native nvidia driver to be used.

Post by albrnick » Wed Feb 28, 2018 10:20 am

I turned off "Secure Boot" on my PC and everything went to working! :)

Post Reply

Return to “Graphics Cards & Monitors”