[SOLVED] Intel coffee lake system running in Software Rendering Mode

Screen resolution, 3D Acceleration, nVidia, ATI
Forum rules
Before you post please read this
Post Reply
tmg
Level 1
Level 1
Posts: 16
Joined: Sat Feb 24, 2018 7:05 pm

[SOLVED] Intel coffee lake system running in Software Rendering Mode

Post by tmg » Wed Feb 28, 2018 6:18 pm

Just installed Mint (first time user) as the Main OS on a new CoffeeLake Intel desktop.

It seems to have installed okay and I have run an update on everything so I am on the latest kernel/firmware etc but when I am using it, it says it's running in Software Rendering mode. I have installed the Intel drivers but that doesn't seem to have fixed anything.

Anyone know how to fix this? It's really slow and stuttering running on an i5-8400 with 16GB RAM
Last edited by tmg on Fri Mar 02, 2018 1:52 am, edited 3 times in total.

deepakdeshp
Level 10
Level 10
Posts: 3362
Joined: Sun Aug 09, 2015 10:00 am

Re: Fresh Install on new system running in Software Rendering Mode

Post by deepakdeshp » Thu Mar 01, 2018 1:13 am

Please paste output of command

Code: Select all

inxi -Fxz
in code tags. Your confideration will be known from this.
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
I am using Mint 18.3 Cinnamon 64 bit with AMD processor . Memory 8GB

tmg
Level 1
Level 1
Posts: 16
Joined: Sat Feb 24, 2018 7:05 pm

Re: Fresh Install on new system running in Software Rendering Mode

Post by tmg » Thu Mar 01, 2018 3:35 am

Output is below

Code: Select all

System:    Host: cantona Kernel: 4.13.0-36-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: Cinnamon 3.6.7 (Gtk 3.18.9-1ubuntu3.3) Distro: Linux Mint 18.3 Sylvia
Machine:   Mobo: Micro-Star model: Z370M GAMING PRO AC (MS-7B44) v: 1.0
           Bios: American Megatrends v: 1.10 date: 10/30/2017
CPU:       Hexa core Intel Core i5-8400 (-MCP-) cache: 9216 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 33696
           clock speeds: max: 4000 MHz 1: 2800 MHz 2: 2800 MHz 3: 2800 MHz 4: 2800 MHz 5: 2800 MHz 6: 2800 MHz
Graphics:  Card: Intel Device 3e92 bus-ID: 00:02.0
           Display Server: X.Org 1.18.4 drivers: vesa,intel (unloaded: fbdev) Resolution: 1920x1080@0.00hz
           GLX Renderer: llvmpipe (LLVM 5.0, 256 bits) GLX Version: 3.0 Mesa 17.2.8 Direct Rendering: Yes
Audio:     Card Intel Device a2f0 driver: snd_hda_intel bus-ID: 00:1f.3 Sound: ALSA v: k4.13.0-36-generic
Network:   Card-1: Intel Ethernet Connection (2) I219-V driver: e1000e v: 3.2.6-k bus-ID: 00:1f.6
           IF: enp0s31f6 state: down mac: <filter>
           Card-2: Intel Device 24fd driver: iwlwifi bus-ID: 02:00.0
           IF: wlp2s0 state: up speed: N/A duplex: N/A mac: <filter>
Drives:    HDD Total Size: 16.0GB (Used Error!) ID-1: /dev/nvme0n1 model: N/A size: 250.1GB
           ID-2: USB /dev/sda model: Extreme size: 16.0GB
Partition: ID-1: / size: 213G used: 6.7G (4%) fs: ext4 dev: /dev/dm-0
           ID-2: /boot size: 472M used: 193M (43%) fs: ext2 dev: /dev/nvme0n1p1
           ID-3: swap-1 size: 17.08GB used: 0.00GB (0%) fs: swap dev: /dev/dm-1
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 29.8C mobo: 27.8C
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 227 Uptime: 5 min Memory: 1014.3/15951.1MB Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35

tmg
Level 1
Level 1
Posts: 16
Joined: Sat Feb 24, 2018 7:05 pm

Re: Fresh Install on new system running in Software Rendering Mode

Post by tmg » Thu Mar 01, 2018 3:51 am

I seem to have fixed it using the solution here:

https://ubuntuforums.org/showthread.php?t=2377324

although I think it might just be this that is needed:

http://joshuakanz.com/ubuntu/Coffee-Lak ... a-Support/

although now when I open the terminal its just an outline with nothing inside :(

tmg
Level 1
Level 1
Posts: 16
Joined: Sat Feb 24, 2018 7:05 pm

Re: Fresh Install on new system running in Software Rendering Mode

Post by tmg » Thu Mar 01, 2018 4:58 am

Yeah so now when I boot into Mint it doesn't say it's using Software rendering but when I open any kind of window (except the default welcome window) it's just a box outline with nothing inside it.

Hoser Rob
Level 11
Level 11
Posts: 3842
Joined: Sat Dec 15, 2012 8:57 am

Re: Fresh Install on new system running in Software Rendering Mode

Post by Hoser Rob » Thu Mar 01, 2018 10:30 am

There are actually a bunch of solutions in those links. Which ones did you actually do?

User avatar
thx-1138
Level 5
Level 5
Posts: 734
Joined: Fri Mar 10, 2017 12:15 pm
Location: Athens, Greece

Re: Fresh Install on new system running in Software Rendering Mode

Post by thx-1138 » Thu Mar 01, 2018 11:58 am

tmg, since firmware is updated, and "i915.alpha_support=1" is set...try sudo apt-get purge xserver-xorg-video-intel, then reboot, see if that fixes it...

If still nada...you could try:
1) Enabling oibaf's ppa, as described in the Ubuntu forum's link above...
2) Install the latest 4.15 mainline...

tmg
Level 1
Level 1
Posts: 16
Joined: Sat Feb 24, 2018 7:05 pm

Re: Fresh Install on new system running in Software Rendering Mode

Post by tmg » Thu Mar 01, 2018 12:38 pm

Hoser Rob wrote:
Thu Mar 01, 2018 10:30 am
There are actually a bunch of solutions in those links. Which ones did you actually do?
I did this >

https://ubuntuforums.org/showthread.php ... st13710326

so now it doesn't give the software render error but whenever I open an application such as the terminal I get a transparent outline of the app window with nothing in it. It happens when I click the shutdown option from the menu too.

tmg
Level 1
Level 1
Posts: 16
Joined: Sat Feb 24, 2018 7:05 pm

Re: Fresh Install on new system running in Software Rendering Mode

Post by tmg » Thu Mar 01, 2018 5:18 pm

Managed to fix this.

Putting my solution in case it helps anyone else.

I ended up re-installing Linux Mint again. Once it loaded it still said it was using the software rendering.

I edited the line in the Grub file as per this link > http://joshuakanz.com/ubuntu/Coffee-Lak ... a-Support/
Step 1 - Copy & Paste the following: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash i915.alpha_support=1"
Step 2 - Open Terminal - Ctrl + Alt + T
Step 3 - Edit your Grub file! - sudo gedit /etc/defaults/grub
Step 4 - Find GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" AND REPLACE with what you Copied from Step 1.
Step 5 - Save the grub file
Step 6 - Update Grub! - sudo update-grub
Step 7 - Reboot & Enjoy Graphics!
Once that was done I reloaded and it still didn't work.

So then I updated everything including the Kernel and after I rebooted it it was fine.

Just to test I took out the edit from the grub file and the problem returned.

Looking at the output of the inxi -Fxz command shows that the GLX entries have changed. So it seems it's a combination of editing the Grub and the new update that came yesterday it seems.

Code: Select all

Graphics:  Card: Intel Device 3e92 bus-ID: 00:02.0
           Display Server: X.Org 1.18.4 drivers: fbdev,intel (unloaded: vesa) Resolution: 1920x1080@77.00hz
           GLX Renderer: Gallium 0.4 on llvmpipe (LLVM 4.0, 256 bits)
           GLX Version: 3.0 Mesa 17.0.7 Direct Rendering: Yes

Code: Select all

Graphics:  Card: Intel Device 3e92 bus-ID: 00:02.0
           Display Server: X.Org 1.18.4 drivers: (unloaded: fbdev,vesa) Resolution: 1920x1080@60.00hz
           GLX Renderer: Mesa DRI Intel HD Graphics (Coffeelake 3x8 GT2)
           GLX Version: 3.0 Mesa 17.2.8 Direct Rendering: Yes

Post Reply

Return to “Graphics Cards & Monitors”