(Solved) 1080p over HDMI not working

Screen resolution, 3D Acceleration, nVidia, ATI
Forum rules
Before you post please read this
Post Reply
Level 1
Level 1
Posts: 29
Joined: Thu Nov 16, 2017 11:23 pm

(Solved) 1080p over HDMI not working

Post by Cinammon32 » Tue Mar 06, 2018 5:39 pm

I'm trying to hook a new computer up to a large screen tv (1080p) over HDMI and am only partially successful.

Code: Select all

asus@asus-LR ~ $ inxi -F
System:    Host: asus-LR Kernel: 4.10.0-38-generic x86_64 (64 bit) Desktop: KDE Plasma 5.8.8
           Distro: Linux Mint 18.3 Sylvia
Machine:   Mobo: ASUSTeK model: ROG MAXIMUS X HERO (WI-FI AC) v: Rev 1.xx
           Bios: American Megatrends v: 1003 date: 12/21/2017
CPU:       Hexa core Intel Core i7-8700K (-HT-MCP-) cache: 12288 KB 
           clock speeds: max: 5000 MHz 1: 799 MHz 2: 927 MHz 3: 915 MHz 4: 4985 MHz 5: 936 MHz 6: 4995 MHz
           7: 1644 MHz 8: 819 MHz 9: 799 MHz 10: 799 MHz 11: 4783 MHz 12: 4879 MHz
Graphics:  Card: NVIDIA Device 1c81
           Display Server: X.Org 1.18.4 drivers: nvidia (unloaded: fbdev,vesa,nouveau)
           Resolution: 1280x1024@60.02hz
           GLX Renderer: GeForce GTX 1050/PCIe/SSE2 GLX Version: 4.5.0 NVIDIA 384.111
Audio:     Card-1 Intel Device a2f0 driver: snd_hda_intel Sound: ALSA v: k4.10.0-38-generic
           Card-2 NVIDIA Device 0fb9 driver: snd_hda_intel
Network:   Card-1: Intel Ethernet Connection (2) I219-V driver: e1000e
           IF: enp0s31f6 state: down mac: 18:31:bf:2b:9d:a0
           Card-2: Realtek Device b822 driver: rtl8822be
           IF: wlp4s0 state: up speed: N/A duplex: N/A mac: e8:2a:44:b6:38:cf
Drives:    HDD Total Size: 6001.2GB (0.4% used) ID-1: /dev/nvme0n1 model: N/A size: 256.1GB
           ID-2: /dev/sda model: ST3000DM008 size: 3000.6GB ID-3: /dev/sdb model: ST3000DM008 size: 3000.6GB
Partition: ID-1: / size: 219G used: 8.5G (5%) fs: ext4 dev: /dev/nvme0n1p1
           ID-2: swap-1 size: 17.10GB used: 0.00GB (0%) fs: swap dev: /dev/nvme0n1p5
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 26.0C mobo: N/A gpu: 23C
           Fan Speeds (in rpm): cpu: 0
Info:      Processes: 270 Uptime: 18:29 Memory: 923.9/15973.7MB Client: Shell (bash) inxi: 2.2.35 
The TV has inputs for VGA (which works wonderfully from another computer) and HDMI.
This graphics card (Nvidia 1050) has a DMI-D output, the Asus motherboard an HDMI.
When starting with HDMI hooked in (and the other monitor disconnected), the Bios screen comes up fine, Mint KDE 18.3 with all updates loads to the logon screen. After entering the user password it continues to load but stops before completion with the following error . . .

"Plasma is unable to start as it could not correctly use OpenGL2. Please check that your graphics drivers are set up correctly."

I've tried both nouveau and the proprietary Nvidia drivers with no success.
I can break out of the freeze with a Ctl-Alt-F2 to the command line and can at least cleanly exit. Any suggestions at this point would be appreciated.
Last edited by Cinammon32 on Wed Mar 07, 2018 6:05 pm, edited 1 time in total.

Level 1
Level 1
Posts: 29
Joined: Thu Nov 16, 2017 11:23 pm

Re: 1080p over HDMI not working

Post by Cinammon32 » Wed Mar 07, 2018 6:05 pm

Solved after a fashion.
https://www.reddit.com/r/Dell/comments/ ... ntu_linux/

Starting a live sesion in Compatability mode and editing the boot parameters by adding 'acpi_rev_overide=1' allows me to install and run Mint HDMI to HDMI. Unfortunately screen refresh is super-slow. Going to have rethink this whole large-screen thing.

Post Reply

Return to “Graphics Cards & Monitors”