2x Nvidia GPU's, 3x Monitors, how hard can it be?

Screen resolution, 3D Acceleration, nVidia, ATI
Forum rules
Before you post please read this
Post Reply
fridgefreezer
Level 1
Level 1
Posts: 5
Joined: Mon Jul 10, 2017 3:29 pm

2x Nvidia GPU's, 3x Monitors, how hard can it be?

Post by fridgefreezer » Wed Mar 14, 2018 12:05 pm

Morning all,
I'm having issues getting my triple-monitor setup to work - I've struggled to get the desktop to span all 3 monitors and even now, Cinnamon crashes at startup and runs in fallback/failsafe mode. I'm hoping you wonderful people might be able to explain a few things and (most likely) point out the glaring error I feel I must have made somewhere in the config.

My system is:
Mint 17.3 64-bit
Kernel 3.19.0-32-generic
CPU is i7-8700k 8th gen @ 3.7GHz / 6-core
48Gb RAM
Graphics cards are both Nvidia Quadro K620 / GM107GL
PSU is a healthy 750W unit
Motherboard is Gigabyte Z370 AORUS Ultra

NVIDIA X Server Settings GUI reports:
Nvidia driver version 384.111
Server Version: 11.0
Server Vendor Version 1.17.1
NV-Control version: 1.29

My xorg.conf looks like this:

Code: Select all

/etc/X11/xorg.conf
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 384.111  (buildmeister@swio-display-x86-rhel47-01)  Wed Dec 20 00:05:28 PST 2017

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 331.20  (buildd@roseapple)  Mon Feb  3 15:07:22 UTC 2014

Section "ServerLayout"

# Removed Option "Xinerama" "0"
# Removed Option "Xinerama" "1"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"

    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Idek Iiyama PL2283H"
    HorizSync       30.0 - 83.0
    VertRefresh     55.0 - 76.0
    Option         "DPMS"
EndSection

Section "Monitor"

    # HorizSync source: unknown, VertRefresh source: unknown
    Identifier     "Monitor1"
    VendorName     "Unknown"
    ModelName      "Idek Iiyama PL2283H"
    HorizSync       30.0 - 83.0
    VertRefresh     55.0 - 76.0
    Option         "DPMS"
EndSection

Section "Monitor"

    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor2"
    VendorName     "Unknown"
    ModelName      "Idek Iiyama PLE2283H"
    HorizSync       30.0 - 83.0
    VertRefresh     55.0 - 76.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "Quadro K620"
    BusID          "PCI:1:0:0"
EndSection

Section "Device"
    Identifier     "Device1"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "Quadro K620"
    BusID          "PCI:2:0:0"
EndSection

Section "Device"
    Identifier     "Device2"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "Quadro K620"
    BusID          "PCI:1:0:0"
    Screen          1
EndSection

Section "Screen"

# Removed Option "metamodes" "DVI-I-1: nvidia-auto-select +0+0"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "DFP-0"
    Option         "metamodes" "DVI-I-1: nvidia-auto-select +0+0, DP-0: nvidia-auto-select +1920+0"
    Option         "MultiGPU" "Off"
    Option         "BaseMosaic" "off"
    Option         "SLI" "Mosaic"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Section "Screen"
    Identifier     "Screen1"
    Device         "Device1"
    Monitor        "Monitor1"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "metamodes" "nvidia-auto-select +0+0"
    Option         "SLI" "Off"
    Option         "MultiGPU" "Off"
    Option         "BaseMosaic" "off"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Section "Screen"
    Identifier     "Screen2"
    Device         "Device2"
    Monitor        "Monitor2"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "DFP-1"
    Option         "metamodes" "DP-0: nvidia-auto-select +0+0"
    Option         "SLI" "Off"
    Option         "MultiGPU" "Off"
    Option         "BaseMosaic" "off"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Section "Extensions"
    Option         "Composite" "Disable"
EndSection
The nvidia command line tools report a few other things which may be of use:

Code: Select all

nvidia-settings -q CurrentMetaMode

  Attribute 'CurrentMetaMode' (PC-XYZABC:0.0): id=50, switchable=yes, source=RandR :: DPY-1: nvidia-auto-select
  @1920x1080 +0+0 {ViewPortIn=1920x1080, ViewPortOut=1920x1080+0+0}, DPY-2: nvidia-auto-select @1920x1080 +1920+0
  {ViewPortIn=1920x1080, ViewPortOut=1920x1080+0+0}, DPY-5: nvidia-auto-select @1920x1080 +3840+0
  {ViewPortIn=1920x1080, ViewPortOut=1920x1080+0+0}
The cinnamon error, according to dmesg, is this:

Code: Select all

[   20.666870] cinnamon[2642]: segfault at 0 ip           (null) sp 00007ffdcf5928b8 error 14
My current situation is:
Nvidia X-Server Settings GUI recognises both GPU's and all 3 monitors. Cinnamon crashes at startup, Ctrl+F2 drops it into fail-safe mode. I then have a single X Screen spanning across all 3 monitors, which is what I want and took a lot of fiddling to arrive at.

Can anyone point me in the right direction?
Yes*
*No

fridgefreezer
Level 1
Level 1
Posts: 5
Joined: Mon Jul 10, 2017 3:29 pm

Re: 2x Nvidia GPU's, 3x Monitors, how hard can it be?

Post by fridgefreezer » Mon Mar 19, 2018 1:04 pm

Well having spent DAYS screwing around with this, via almost completely breaking the entire system, I'm now at least back to 2 monitors on one GPU (using nouveau) but no sign of the 2nd working at all :cry:

What's most frustrating is that booting 18.3 from a Live USB stick it comes up perfectly across all 3 monitors but I can't see what on earth is different.

I'm now backing everything up and will attempt to upgrade to 18.x in the vain hope that might erase whatever configuration has been messed up by nvidia/xorg etc. and get me working... although the way things have been going it's as likely to break the whole PC :roll:
Yes*
*No

fridgefreezer
Level 1
Level 1
Posts: 5
Joined: Mon Jul 10, 2017 3:29 pm

Re: 2x Nvidia GPU's, 3x Monitors, how hard can it be?

Post by fridgefreezer » Tue Mar 20, 2018 7:50 am

Well 18.3 appears to "just work" using Nouveau, although I've no idea if I'm losing performance as I'm not doing GFX intensive stuff.
Yes*
*No

Post Reply

Return to “Graphics Cards & Monitors”