Stuck in software rendering mode after installing new graphics card

Screen resolution, 3D Acceleration, nVidia, ATI
Forum rules
Before you post please read this
Post Reply
Tidal_0x5D
Level 1
Level 1
Posts: 5
Joined: Sat Feb 03, 2018 2:21 pm
Location: Russia

Stuck in software rendering mode after installing new graphics card

Post by Tidal_0x5D » Fri Apr 06, 2018 2:35 pm

I've switched my graphics card from GTX 760 to GTX 1060 and now Cinnamon is constantly running in software rendering mode. (and it lags like hell)
I was using nvidia driver v390.48 before, so I tried to switch to nouveau, but nothing changed.
After that, I tried to completely uninstall nvidia packages , reboot and then install them again (via driver manager), but it didn't help either. (or maybe I was doing something wrong?)

Here is some info (from what people usually post in similar threads):

Code: Select all

$ inxi -SGx
System:    Host: mint01 Kernel: 4.16.0-041600-generic x86_64 (64 bit gcc: 7.2.0)
           Desktop: Cinnamon 3.6.6 (Gtk 3.18.9-1ubuntu3.3)
           Distro: Linux Mint 18.3 Sylvia
Graphics:  Card: NVIDIA Device 1c03 bus-ID: 21:00.0
           Display Server: X.Org 1.18.4 drivers: fbdev (unloaded: vesa) FAILED: nouveau
           Resolution: 1600x900@77.00hz
           GLX Renderer: Gallium 0.4 on llvmpipe (LLVM 4.0, 128 bits)
           GLX Version: 3.0 Mesa 17.0.7 Direct Rendering: Yes

Code: Select all

$ sudo lshw -C video
  *-display               
       description: VGA compatible controller
       product: NVIDIA Corporation
       vendor: NVIDIA Corporation
       physical id: 0
       bus info: pci@0000:21:00.0
       version: a1
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress vga_controller bus_master cap_list rom
       configuration: driver=nvidia latency=0
       resources: irq:25 memory:fc000000-fcffffff memory:e0000000-efffffff memory:f0000000-f1ffffff ioport:d000(size=128) memory:c0000-dffff

Code: Select all

 $ apt search nvidia|grep ^i
i   nvidia-390                      - NVIDIA binary driver - version 390.48     
i   nvidia-opencl-icd-390           - NVIDIA OpenCL ICD                         
i   nvidia-prime                    - Tools to enable NVIDIA's Prime            
i   nvidia-settings                 - Tool for configuring the NVIDIA graphics d

Code: Select all

$ grep nouveau /etc/modprobe.d/*
/etc/modprobe.d/nvidia-390_hybrid.conf:blacklist nouveau
/etc/modprobe.d/nvidia-390_hybrid.conf:blacklist lbm-nouveau
/etc/modprobe.d/nvidia-390_hybrid.conf:alias nouveau off
/etc/modprobe.d/nvidia-390_hybrid.conf:alias lbm-nouveau off

Code: Select all

$ find /etc/X11/ -iname '*.conf'

Last edited by Tidal_0x5D on Sat Apr 07, 2018 2:52 am, edited 1 time in total.

Tidal_0x5D
Level 1
Level 1
Posts: 5
Joined: Sat Feb 03, 2018 2:21 pm
Location: Russia

Re: Stuck in software rendering mode after installing new graphics card

Post by Tidal_0x5D » Fri Apr 06, 2018 4:46 pm

Sooooo I just logged out, selected Cinnamon without "(Software rendering mode)" from the list of available desktops and then logged in again.
Looks like now GUI is running in a hardware rendering mode, even after reboot. :D
Didn't know I could do that, really. Most of what I found on google didn't mention it, but after quick search on a forum I found this post. Thanks to xjcl, I guess. )
Thou it's interesting why hardware change has caused desktop to permanently switch to software rendering mode.

Post Reply

Return to “Graphics Cards & Monitors”