Amd RX 550 no audio

Screen resolution, 3D Acceleration, nVidia, ATI
Forum rules
Before you post please read this
Post Reply
User avatar
mrmajik45
Level 4
Level 4
Posts: 419
Joined: Tue Aug 29, 2017 9:51 pm
Location: USA, indiana
Contact:

Amd RX 550 no audio

Post by mrmajik45 » Fri Apr 06, 2018 9:32 pm

My previous graphics card died so I got a Amd RX 550 and I won't get any audio from linux. Test volume is quiet. Just PURE silence. How do I know if the drivers installed or not?

DMESG amdgpu ERROR:

Code: Select all

amdgpu 0000:03:00.0: Invalid PCI ROM header signature: expecting 0xaa55, got 0xffff
ReactOS Donator ~ $5.00 | Linux Mint Donator ~ $1.00 in BTC

Mattyboy
Level 6
Level 6
Posts: 1196
Joined: Thu Mar 26, 2015 2:17 pm

Re: Amd RX 550 no audio

Post by Mattyboy » Fri Apr 06, 2018 10:25 pm

Provide more information abut your system

Code: Select all

inxi -Fxz

User avatar
mrmajik45
Level 4
Level 4
Posts: 419
Joined: Tue Aug 29, 2017 9:51 pm
Location: USA, indiana
Contact:

Re: Amd RX 550 no audio

Post by mrmajik45 » Fri Apr 06, 2018 10:32 pm

Code: Select all

System:    Host: Dell-Inspirion-Mint Kernel: 4.13.0-38-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: Cinnamon 3.6.7 (Gtk 3.18.9-1ubuntu3.3)
           Distro: Linux Mint 18.3 Sylvia
Machine:   System: Dell product: Inspiron 3656 v: 2.2.0
           Mobo: Dell model: 0R1PCR Bios: Dell v: 2.2.0 date: 06/13/2016
CPU:       Quad core AMD A10-8700P Radeon R6 10 Compute Cores 4C+6G (-MCP-) cache: 4096 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm) bmips: 14373
           clock speeds: max: 1800 MHz 1: 1298 MHz 2: 1297 MHz 3: 1326 MHz
           4: 1367 MHz
Graphics:  Card: Advanced Micro Devices [AMD/ATI] Device 699f bus-ID: 03:00.0
           Display Server: X.Org 1.18.4 drivers: ati (unloaded: fbdev,vesa,radeon,amdgpu)
           Resolution: 1920x1080@60.00hz
           GLX Renderer: Radeon RX 550 Series (AMD POLARIS12 / DRM 3.18.0 / 4.13.0-38-generic, LLVM 5.0.0)
           GLX Version: 3.0 Mesa 17.2.8 Direct Rendering: Yes
Audio:     Card-1 Advanced Micro Devices [AMD] Device 157a
           driver: snd_hda_intel bus-ID: 00:09.2
           Card-2 Advanced Micro Devices [AMD/ATI] Device aae0
           driver: snd_hda_intel bus-ID: 03:00.1
           Sound: Advanced Linux Sound Architecture v: k4.13.0-38-generic
Network:   Card-1: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter
           driver: ath9k bus-ID: 01:00.0
           IF: wlp1s0 state: down mac: <filter>
           Card-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           driver: r8169 v: 2.3LK-NAPI port: e000 bus-ID: 02:00.0
           IF: enp2s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
           Card-3: Atheros usb-ID: 002-004
           IF: null-if-id state: N/A speed: N/A duplex: N/A mac: N/A
Drives:    HDD Total Size: 1000.2GB (2.1% used)
           ID-1: /dev/sda model: ST1000DM010 size: 1000.2GB
Partition: ID-1: / size: 906G used: 8.7G (2%) fs: ext4 dev: /dev/sda1
           ID-2: swap-1 size: 12.82GB used: 0.00GB (0%) fs: swap dev: /dev/sda5
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 32.2C mobo: N/A gpu: 25.0
           Fan Speeds (in rpm): cpu: 2410 fan-2: 776
Info:      Processes: 207 Uptime: 1:07 Memory: 832.3/11946.2MB
           Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35 
ReactOS Donator ~ $5.00 | Linux Mint Donator ~ $1.00 in BTC

Mattyboy
Level 6
Level 6
Posts: 1196
Joined: Thu Mar 26, 2015 2:17 pm

Re: Amd RX 550 no audio

Post by Mattyboy » Sat Apr 07, 2018 8:48 am

Can't be sure but it may have something to do with new Radeon cards not being supported on Mint 18 under Kernel 4.13.

As a test do a live boot of Ubuntu 18.04 beta with the 4.15 Kernel and see if that works.??

Post Reply

Return to “Graphics Cards & Monitors”