[Solved] DisplayLink 1st HDMI works 2nd VGA does not

Screen resolution, 3D Acceleration, nVidia, ATI
Forum rules
Before you post please read this
Post Reply
jenga201
Level 1
Level 1
Posts: 2
Joined: Thu Apr 12, 2018 12:29 pm

[Solved] DisplayLink 1st HDMI works 2nd VGA does not

Post by jenga201 » Thu Apr 12, 2018 12:55 pm

I'm trying to enable a 3 monitor setup through a Dell dock (laptop monitor included).

I can only get the laptop and HDMI monitor to work.
The 2nd monitor is connected through VGA. I've also tried DVI->DisplayPort with the same result.

I've installed the ubuntu DisplayLink drivers.
Everything else seems to work.

GeForce 940MX - Nvidia driver 384.111

Dell WD15 dock
http://www.dell.com/en-us/shop/dell-bus ... ccessories

Code: Select all

~ $ inxi -Fxz
System:    Host: rob Kernel: 4.13.0-38-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: Cinnamon 3.6.7 (Gtk 3.18.9-1ubuntu3.3)
           Distro: Linux Mint 18.3 Sylvia
Machine:   System: Dell (portable) product: Latitude 5580
           Mobo: Dell model: 0FH6CJ v: A00
           Bios: Dell v: 1.8.2 date: 01/30/2018
CPU:       Quad core Intel Core i7-7820HQ (-HT-MCP-) cache: 8192 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 23232
           clock speeds: max: 3900 MHz 1: 900 MHz 2: 900 MHz 3: 962 MHz
           4: 960 MHz 5: 995 MHz 6: 944 MHz 7: 973 MHz 8: 961 MHz
Graphics:  Card-1: Intel Device 591b bus-ID: 00:02.0
           Card-2: NVIDIA Device 179c bus-ID: 01:00.0
           Display Server: X.Org 1.18.4 driver: nvidia
           Resolution: 1920x1080@60.00hz, 1920x1080@60.00hz
           GLX Renderer: GeForce 940MX/PCIe/SSE2
           GLX Version: 4.5.0 NVIDIA 384.111 Direct Rendering: Yes
Audio:     Card-1 Intel Device a171 driver: snd_hda_intel bus-ID: 00:1f.3
           Card-2 Realtek driver: USB Audio usb-ID: 003-004
           Card-3 Plantronics driver: USB Audio usb-ID: 003-003
           Sound: Advanced Linux Sound Architecture v: k4.13.0-38-generic
Network:   Card-1: Intel Ethernet Connection (5) I219-LM
           driver: e1000e v: 3.2.6-k bus-ID: 00:1f.6
           IF: enp0s31f6 state: down mac: <filter>
           Card-2: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter
           driver: ath10k_pci bus-ID: 02:00.0
           IF: wlp2s0 state: up mac: <filter>
           Card-3: Atheros usb-ID: 001-002
           IF: null-if-id state: N/A speed: N/A duplex: N/A mac: N/A
Drives:    HDD Total Size: 762.2GB (55.0% used)
           ID-1: /dev/sda model: INTEL_SSDSCKKF51 size: 512.1GB
           ID-2: USB /dev/sdb model: 00SSD1 size: 250.1GB
Partition: ID-1: / size: 454G used: 218G (51%) fs: ext4 dev: /dev/sda2
           ID-2: swap-1 size: 17.06GB used: 0.00GB (0%) fs: swap dev: /dev/sda3
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 47.0C mobo: N/A gpu: 0.0:43C
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 257 Uptime: 27 min Memory: 2486.6/15922.1MB
           Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35 
Thanks in advance!

jenga201
Level 1
Level 1
Posts: 2
Joined: Thu Apr 12, 2018 12:29 pm

Re: [Solved] DisplayLink 1st HDMI works 2nd VGA does not

Post by jenga201 » Wed Apr 18, 2018 8:52 am

LVDS cable was bad. Dell replaced and everything is working.

Post Reply

Return to “Graphics Cards & Monitors”