Freezing System after Boot. Only Software-Rendering

Screen resolution, 3D Acceleration, nVidia, ATI
Forum rules
Before you post please read this
Post Reply
pd68
Level 1
Level 1
Posts: 4
Joined: Fri May 04, 2018 3:48 pm

Freezing System after Boot. Only Software-Rendering

Post by pd68 » Fri May 04, 2018 4:07 pm

Hello,

i have joined the forums because i haven't been able to solve the following problem for a few days now.
Please excuse my english as it's not my native language.

I'm using a Laptop with NVIDIA GeForce GTX 1060 | 6 GB GDDR5 which is a dual-Graphics-Card.
It's supposed to work with the NVIDIA Drivers (according to NVIDIA Website) and it worked well for ~ 1 Year with one downside: I couldn't use the intel-part of the Graphics-Card, so my battery didn't last long.
A few days ago I updated my NVIDIA Driver (and i haven't wrote down the old version :/) and after that my system froze on login-screen or shortly after loging in.

When i start with recovery mode i can start my system (and get a message, that i'm running on software-rendering mode).
I tried to install the newest Version (390.25) directly from the NVIDIA Homepage, now my system gets a black screen after grub loader and doesn't boot at all.
Recovery Mode still working.

I tried to select the different Versions of the driver but none lets me start my OS.
Image

I'm using Mint 18.2 64bit with Cinnamon.

inxi -Fxz (in Recovery-mode)

Code: Select all

System:    Host: akuma-r4c Kernel: 4.13.0-39-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: Cinnamon 3.4.6 (Gtk 2.24.30) Distro: Linux Mint 18.2 Sonya
Machine:   System: Notebook (portable) product: P65_67HSHP
           Mobo: Notebook model: P65_67HSHP
           Bios: American Megatrends v: 1.05.07 06/26/2017 date: 06/26/2017
CPU:       Quad core Intel Core i7-7700HQ (-HT-MCP-) cache: 6144 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 22464
           clock speeds: max: 3800 MHz 1: 806 MHz 2: 807 MHz 3: 850 MHz
           4: 835 MHz 5: 820 MHz 6: 865 MHz 7: 847 MHz 8: 873 MHz
Graphics:  Card-1: Intel Device 591b bus-ID: 00:02.0
           Card-2: NVIDIA Device 1c60 bus-ID: 01:00.0
           Display Server: X.Org 1.18.4 drivers: vesa (unloaded: fbdev) FAILED: intel,nouveau
           Resolution: 1920x1080@0.00hz
           GLX Renderer: llvmpipe (LLVM 5.0, 256 bits)
           GLX Version: 3.0 Mesa 17.2.8 Direct Rendering: Yes
Audio:     Card Intel Device a171 driver: snd_hda_intel bus-ID: 00:1f.3
           Sound: Advanced Linux Sound Architecture v: k4.13.0-39-generic
Network:   Card-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           driver: r8169 v: 2.3LK-NAPI port: d000 bus-ID: 6d:00.1
           IF: enp109s0f1 state: down mac: <filter>
           Card-2: Intel Device 24fd driver: iwlwifi bus-ID: 6e:00.0
           IF: wlp110s0 state: up speed: N/A duplex: N/A mac: <filter>
Drives:    HDD Total Size: 1025.2GB (23.9% used)
           ID-1: /dev/sda model: Crucial_CT525MX3 size: 525.1GB
           ID-2: /dev/sdb model: ST500LM000 size: 500.1GB
Partition: ID-1: / size: 466G used: 214G (49%) fs: ext4 dev: /dev/sda1
           ID-2: swap-1 size: 17.05GB used: 0.00GB (0%) fs: swap dev: /dev/dm-0
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 41.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 303 Uptime: 4:24 Memory: 6539.8/15917.2MB
           Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (zsh 5.1.1) inxi: 2.2.35 

User avatar
trytip
Level 8
Level 8
Posts: 2364
Joined: Tue Jul 05, 2016 1:20 pm

Re: Freezing System after Boot. Only Software-Rendering

Post by trytip » Fri May 04, 2018 4:28 pm

first remove your nvidia and reboot sudo apt-get remove --purge nvidia-* but if you tried to install from nvidia site you'll probably need to also sudo nvidia-uninstall if that does anything ... reboot
after purge and reboot what do you gets for dkms status
Image

pd68
Level 1
Level 1
Posts: 4
Joined: Fri May 04, 2018 3:48 pm

Re: Freezing System after Boot. Only Software-Rendering

Post by pd68 » Fri May 04, 2018 5:34 pm

Hi,

thank you very much for your answer!
purge worked - my system is starting again.

dkms status

Code: Select all

ndiswrapper, 1.60, 4.13.0-39-generic, x86_64: installed
ndiswrapper, 1.60, 4.8.0-53-generic, x86_64: installed

User avatar
trytip
Level 8
Level 8
Posts: 2364
Joined: Tue Jul 05, 2016 1:20 pm

Re: Freezing System after Boot. Only Software-Rendering

Post by trytip » Fri May 04, 2018 6:28 pm

you should now be using the open source drivers and you can try installing from driver manager again but i'm not familiar with new nvidia drivers or which driver is best for the system with your card. choosing a driver from mint driver manager is more compatible since building it from nvidia require advanced which i also have no experience

after installing drivers always reboot immediately then test with dkms status if nvidia installed it will say and never install a driver without removing the old one first.
Image

pd68
Level 1
Level 1
Posts: 4
Joined: Fri May 04, 2018 3:48 pm

Re: Freezing System after Boot. Only Software-Rendering

Post by pd68 » Sun May 06, 2018 6:17 am

System is freezing again on boot, even i didn't change anything...

guess i will just break down the whole thing and reinstall it completely. But thank you very much for your help!

User avatar
trytip
Level 8
Level 8
Posts: 2364
Joined: Tue Jul 05, 2016 1:20 pm

Re: Freezing System after Boot. Only Software-Rendering

Post by trytip » Sun May 06, 2018 10:20 pm

sometimes the nouveau driver get blacklisted from nvidia driver. With purge command it should UN-blacklisted. If you want to be sure that nouveau will be loaded at boot, you can force-load it by add it to /etc/modules
echo 'nouveau' | sudo tee -a /etc/modules
search for the xorg.conf file and remove it as well sudo rm /etc/X11/xorg.conf
Image

Post Reply

Return to “Graphics Cards & Monitors”