Works on live USB, but not on HDD ( 945GM)

Screen resolution, 3D Acceleration, nVidia, ATI
Forum rules
Before you post please read this
Post Reply
mikerr
Level 1
Level 1
Posts: 7
Joined: Sun May 13, 2018 6:16 am

Works on live USB, but not on HDD ( 945GM)

Post by mikerr » Sun May 13, 2018 8:47 am

I have 18.3 working fine on a live USB stick on an old Samsung q35 laptop

Working:

Code: Select all

$ inxi -G
Graphics:  Card: Intel Mobile 945GM/GMS 943/940GML Express Integrated Graphics Controller
           Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa)
           Resolution: 1280x800@59.99.hz
           GLX Renderer: Mesa DRI Intel 945GM
           GLX Version: 1.4 Mesa 17.0.7
once installed to hard drive I get a mouse cursor but black screen (and corruption at top of screen).
Adding nomodeset to the boot gets me into a desktop, but obviously without accerated gfx.

Here's output of non-accelerated hdd install:

Not working:

Code: Select all

$ inxi -G
Graphics:  Card: Intel Mobile 945GM/GMS 943/940GML Express Integrated Graphics Controller
           Display Server: X.Org 1.18.4 drivers: vesa,intel (unloaded: fbdev)
           Resolution: 1280x800@0.00hz
           GLX Renderer: llvmpipe (LLVM 5.0, 128 bits)
           GLX Version: 3.0 Mesa 17.2.8
So I just need to replicate the drivers used in the first somehow ?

deepakdeshp
Level 10
Level 10
Posts: 3363
Joined: Sun Aug 09, 2015 10:00 am

Re: Works on live USB, but not on HDD ( 945GM)

Post by deepakdeshp » Mon May 14, 2018 3:01 am

Try making the kernel version same from USB boot and HDD.

Code: Select all

 uname -r
gives the kernel version.
In update manager--view, you can install kernels.
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
I am using Mint 18.3 Cinnamon 64 bit with AMD processor . Memory 8GB

User avatar
catweazel
Level 14
Level 14
Posts: 5457
Joined: Fri Oct 12, 2012 9:44 pm
Location: Australian Antarctic Territory

Re: Works on live USB, but not on HDD ( 945GM)

Post by catweazel » Mon May 14, 2018 3:49 am

deepakdeshp wrote:
Mon May 14, 2018 3:01 am
Try making the kernel version same from USB boot and HDD.[
Surely they're the same? Wouldn't the OP be better off to install a 4.15 kernel?
A new scientific truth does not triumph by convincing its opponents and making them see the light, but rather because its opponents eventually die, and a new generation grows up that is familiar with it. - Max Planck

mikerr
Level 1
Level 1
Posts: 7
Joined: Sun May 13, 2018 6:16 am

Re: Works on live USB, but not on HDD ( 945GM)

Post by mikerr » Mon May 14, 2018 5:36 am

Ah, they were different kernels. USB was 4.10.0-38 ... non working HDD was 4.13.0-41

Grub gave me the option of reverting:
Image

Selecting 4.10 fixed it.

Now I'll test others
[edit] 4.15.0.13 works fine too, so I'll leave it on that.

Post Reply

Return to “Graphics Cards & Monitors”