(SOLVED) Need GPU driver advice for LM 18.3 AMD/ATI

Screen resolution, 3D Acceleration, nVidia, ATI
Forum rules
Before you post please read this
Post Reply
nevl
Level 1
Level 1
Posts: 21
Joined: Mon Mar 06, 2017 12:44 am

(SOLVED) Need GPU driver advice for LM 18.3 AMD/ATI

Post by nevl »

Hi my machine n GPU driver info is:

Machine: Mobo: MSI model: X370 SLI PLUS (MS-7A33) v: 2.0 serial: H416260744
Bios: American Megatrends v: 3.B0 date: 03/10/2018
CPU: Quad core AMD Ryzen 5 2400G with Radeon Vega Graphics (-HT-MCP-) cache: 2048 KB
flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm) bmips: 28799
clock speeds: max: 2862 MHz 1: 2738 MHz 2: 2862 MHz 3: 2477 MHz 4: 1673 MHz 5: 2480 MHz 6: 1500 MHz
7: 1560 MHz 8: 2491 MHz
Graphics: Card: Advanced Micro Devices [AMD/ATI] Device 15dd bus-ID: 38:00.0
Display Server: X.org 1.18.4 drivers: fbdev,ati (unloaded: vesa,radeon)
tty size: 125x42 Advanced Data: N/A for root

I got resolution only on 1024 x 768 pixel, can I get more resolution from any drivers ?

Many thanks...
nevl_
Last edited by nevl on Tue Jun 12, 2018 1:21 am, edited 1 time in total.
NevL
User avatar
thx-1138
Level 8
Level 8
Posts: 2114
Joined: Fri Mar 10, 2017 12:15 pm
Location: Athens, Greece

Re: Need GPU driver advice for LM 18.3 AMD/ATI

Post by thx-1138 »

...it would certainly be helpful if people around also knew what your kernel version is as well.
Also, run sudo update-pciids first, in case it gives us more info in regards to the mysterious Device 15dd card...
(most likely Raven Ridge i assume?)...then run inxi -Fxz & post the results.

...first thoughts... to be on the safe side, make sure you first back-up your personal data, use Timeshift, and:
1) Update linux-firmware if you haven't done so already...sudo apt-get install linux-firmware
2) Update the kernel to 4.15 if you haven't done so already...
3) Update Xorg as well... sudo apt-get install xserver-xorg-hwe-16.04 xserver-xorg-video-all-hwe-16.04 xserver-xorg-input-all-hwe-16.04
4) Update the thread's title to also include 'Ryzen' in it's title, so that people with Ryzen will notice it easier & might pop-up to further help...
nevl
Level 1
Level 1
Posts: 21
Joined: Mon Mar 06, 2017 12:44 am

Re: Need GPU driver advice for LM 18.3 AMD/ATI

Post by nevl »

Hi thx-1138 thanks for your reply,..

FYI
System: Host: NEVL-MSIMINT Kernel: 4.13.0-45-generic x86_64 (64 bit gcc: 5.4.0)
Desktop: KDE Plasma 5.8.9 (Qt 5.6.1) dm: sddm,sddm Distro: Linux Mint 18.3 Sylvia
Machine: Mobo: MSI model: X370 SLI PLUS (MS-7A33) v: 2.0 Bios: American Megatrends v: 3.B0 date: 03/10/2018
CPU: Quad core AMD Ryzen 5 2400G with Radeon Vega Graphics (-HT-MCP-) cache: 2048 KB
flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm) bmips: 28799
clock speeds: max: 2783 MHz 1: 1360 MHz 2: 1471 MHz 3: 1475 MHz 4: 1584 MHz 5: 1542 MHz 6: 2783 MHz
7: 2219 MHz 8: 1852 MHz
Graphics: Card: Advanced Micro Devices [AMD/ATI] Raven Ridge [Radeon Vega Series / Radeon Vega Mobile Series]
bus-ID: 38:00.0 chip-ID: 1002:15dd
Display Server: X.org 1.18.4 drivers: fbdev,ati (unloaded: vesa,radeon)
tty size: 125x42 Advanced Data: N/A for root
Audio: Card-1 Advanced Micro Devices [AMD] Device 15e3
driver: snd_hda_intel bus-ID: 38:00.6 chip-ID: 1022:15e3
Card-2 Advanced Micro Devices [AMD/ATI] Device 15de
driver: snd_hda_intel bus-ID: 38:00.1 chip-ID: 1002:15de
Sound: Advanced Linux Sound Architecture v: k4.13.0-45-generic
Network: Card: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
driver: r8169 v: 2.3LK-NAPI port: f000 bus-ID: 21:00.0 chip-ID: 10ec:8168
IF: enp33s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
WAN IP: <filter> IF: enp33s0 ip-v4: <filter> ip-v6: <filter>
Drives: HDD Total Size: 1000.2GB (21.9% used)
ID-1: /dev/sda model: ST3500312CS size: 500.1GB serial: 9VVBFTES temp: 29C
ID-2: /dev/sdb model: WDC_WD5000AAKX size: 500.1GB serial: WD-WMAYUT880075 temp: 32C
Partition: ID-1: / size: 427G used: 143G (36%) fs: ext4 dev: /dev/md0
ID-2: swap-1 size: 34.36GB used: 0.00GB (0%) fs: swap dev: /dev/sdb2
ID-3: swap-2 size: 34.36GB used: 0.00GB (0%) fs: swap dev: /dev/sda2
RAID: System: supported: raid1 linear multipath raid0 raid6 raid5 raid4 raid10
Device-1: /dev/md0 - active components: online: sda3[0] sdb3[1]
Info: raid: 1 report: 2/2 UU blocks: 454175744 chunk size: N/A bitmap: true super blocks: 1.2
Unused Devices: none
Sensors: None detected - is lm-sensors installed and configured?
Info: Processes: 212 Uptime: 3:19 Memory: 1658.8/15791.0MB
Init: systemd v: 229 runlevel: 5 default: 2 Gcc sys: 5.4.0
Client: Shell (bash 4.3.481 running in bash) inxi: 2.2.35
NevL
User avatar
thx-1138
Level 8
Level 8
Posts: 2114
Joined: Fri Mar 10, 2017 12:15 pm
Location: Athens, Greece

Re: Need GPU driver advice for LM 18.3 AMD/ATI

Post by thx-1138 »

...it's a very new (and shiny!) system, and Raven Ridge as i suspected...
4.15 kernel is a minimum requirement...and luckily, linux-firmware 1.157.18 & above provides support, judging from it's changelog ...
Try the steps above after backing up your data just in case...

Also read here to get an idea (it's current support is still a work-in-progress....):
https://askubuntu.com/questions/1007350 ... en-5-2400g
...and from what i further read online, it's probably 4.17 that will contain a more proper support for such.

Ie. this might require quite a bit of extra effort to get it running 'perfectly' in current Mint 18's underlying stack.
As for maximum performance out of it, you'd still also need newer Mesa / xorg libraries etc. - as i don't know how far Canonical will provide official backports for such on 16.04 / Mint 18...ie. in the longer term, you will certainly be better served with Mint 19 which will be based on 18.04 base...
nevl
Level 1
Level 1
Posts: 21
Joined: Mon Mar 06, 2017 12:44 am

Re: Need GPU driver advice for LM 18.3 AMD/ATI

Post by nevl »

Hi thx-1138 ,...
this output after follow your instruction,..
I got max 1920 x 1080

System: Host: NEVL-MSIMINT Kernel: 4.15.0-23-generic x86_64 (64 bit gcc: 5.4.0)
Desktop: KDE Plasma 5.8.9 (Qt 5.6.1)
Distro: Linux Mint 18.3 Sylvia
Machine: Mobo: MSI model: X370 SLI PLUS (MS-7A33) v: 2.0
Bios: American Megatrends v: 3.B0 date: 03/10/2018
CPU: Quad core AMD Ryzen 5 2400G with Radeon Vega Graphics (-HT-MCP-) cache: 2048 KB
flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm) bmips: 28799
clock speeds: max: 3399 MHz 1: 3156 MHz 2: 3142 MHz 3: 2974 MHz
4: 3107 MHz 5: 3399 MHz 6: 3100 MHz 7: 3040 MHz 8: 3112 MHz
Graphics: Card: Advanced Micro Devices [AMD/ATI] Raven Ridge [Radeon Vega Series / Radeon Vega Mobile Series]
bus-ID: 38:00.0
Display Server: X.org 1.19.5 drivers: ati,amdgpu (unloaded: fbdev,vesa,radeon)
tty size: 77x28 Advanced Data: N/A for root
Audio: Card-1 Advanced Micro Devices [AMD] Device 15e3
driver: snd_hda_intel bus-ID: 38:00.6
Card-2 Advanced Micro Devices [AMD/ATI] Device 15de
driver: snd_hda_intel bus-ID: 38:00.1
Sound: Advanced Linux Sound Architecture v: k4.15.0-23-generic
Network: Card: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
driver: r8169 v: 2.3LK-NAPI port: f000 bus-ID: 21:00.0
IF: enp33s0 state: up speed: 1000 Mbps duplex: full
mac: <filter>
Drives: HDD Total Size: 1000.2GB (21.9% used)
ID-1: /dev/sda model: ST3500312CS size: 500.1GB temp: 30C
ID-2: /dev/sdb model: WDC_WD5000AAKX size: 500.1GB temp: 33C
Partition: ID-1: / size: 427G used: 144G (36%) fs: ext4 dev: /dev/md0
ID-2: swap-1 size: 34.36GB used: 0.00GB (0%) fs: swap dev: /dev/sdb2
ID-3: swap-2 size: 34.36GB used: 0.00GB (0%) fs: swap dev: /dev/sda2
RAID: Device-1: /dev/md0 - active components: online: sda3[0] sdb3[1]
Info: raid: 1 report: 2/2 blocks: 454175744 chunk size: N/A bitmap: true
Sensors: System Temperatures: cpu: No active sensors found. Have you configured your sensors yet? mobo: N/A gpu: 0.0
Info: Processes: 234 Uptime: 5 min Memory: 4593.0/15790.7MB
Init: systemd runlevel: 5 Gcc sys: 5.4.0
Client: Shell (bash 4.3.481) inxi: 2.2.35
NevL
User avatar
thx-1138
Level 8
Level 8
Posts: 2114
Joined: Fri Mar 10, 2017 12:15 pm
Location: Athens, Greece

Re: Need GPU driver advice for LM 18.3 AMD/ATI

Post by thx-1138 »

...excellent - glad to have been of help :)
nevl
Level 1
Level 1
Posts: 21
Joined: Mon Mar 06, 2017 12:44 am

Re: Need GPU driver advice for LM 18.3 AMD/ATI

Post by nevl »

many thanks thx-1138 for the help,...
can you tell me something, I already have a choice of the pixel range, but i still have a little problem here.. that the font like dancing (the black colour is not proper)...
:D
NevL
User avatar
thx-1138
Level 8
Level 8
Posts: 2114
Joined: Fri Mar 10, 2017 12:15 pm
Location: Athens, Greece

Re: Need GPU driver advice for LM 18.3 AMD/ATI

Post by thx-1138 »

...that i wouldn't know i'm afraid... :-/
Is it "video tearing" what you mean, like trembling lines? I'm totally unfamiliar with how KDE handles such...
nevl
Level 1
Level 1
Posts: 21
Joined: Mon Mar 06, 2017 12:44 am

Re: Need GPU driver advice for LM 18.3 AMD/ATI

Post by nevl »

hahaha thanks you so much, i'll mark this tread as solved.
NevL
nevl
Level 1
Level 1
Posts: 21
Joined: Mon Mar 06, 2017 12:44 am

Re: Need GPU driver advice for LM 18.3 AMD/ATI

Post by nevl »

thx-1138 wrote:
Tue Jun 12, 2018 1:14 am
...that i wouldn't know i'm afraid... :-/
Is it "video tearing" what you mean, like trembling lines? I'm totally unfamiliar with how KDE handles such...
Hi thx-1138,
can you help me again? :D ... my lm18.3 stuck blank after changing profile picture,.. :cry:
NevL
User avatar
thx-1138
Level 8
Level 8
Posts: 2114
Joined: Fri Mar 10, 2017 12:15 pm
Location: Athens, Greece

Re: (SOLVED) Need GPU driver advice for LM 18.3 AMD/ATI

Post by thx-1138 »

Hi nevl, i'm not familiar with KDE & it's components, ie. SDDM - the ArchWiki appears to say though:
https://wiki.archlinux.org/index.php/SD ... fter_login
Try removing ~/.Xauthority
Ie. that's what i'd try, Ctrl+Alt+F1 to switch to tty1, login, rm ~/.Xauthority,
then switch back to tty7 via Ctrl+Alt+F7 (or completely reboot afterwards, ie. systemctl reboot).
Be careful with the rm command obviously...
Or instead of removing .Xauthority, maybe you could simply try restarting it:
sudo systemctl restart sddm
nevl
Level 1
Level 1
Posts: 21
Joined: Mon Mar 06, 2017 12:44 am

Re: (SOLVED) Need GPU driver advice for LM 18.3 AMD/ATI

Post by nevl »

sorry for not tell you the complete problem. I mean after I changed the profile picture is fine. while I shutdown the desktop and booting again with blank screen.
NevL
nevl
Level 1
Level 1
Posts: 21
Joined: Mon Mar 06, 2017 12:44 am

Re: (SOLVED) Need GPU driver advice for LM 18.3 AMD/ATI

Post by nevl »

nevl wrote:
Wed Jun 13, 2018 2:14 am
sorry for not tell you the complete problem. I mean after I changed the profile picture is fine. while I shutdown the desktop and booting again with blank screen.
for more information, i can login to the desktop while I push and click shift button again n again, but this method does not always work for this problem.

sorry for my bad english.
NevL
User avatar
thx-1138
Level 8
Level 8
Posts: 2114
Joined: Fri Mar 10, 2017 12:15 pm
Location: Athens, Greece

Re: (SOLVED) Need GPU driver advice for LM 18.3 AMD/ATI

Post by thx-1138 »

nevl...

Xorg 1.18.4 was released 17 July 2017, kernel 4.13 on 3 September 2017...
Xorg 1.19.5 was released 12 October 2017, kernel 4.15 on January 28 2018...

...and your Ryzen 5 2400G was released in...'the future' -> 12 February 2018. :wink:

The mere fact that not only it boots but works for the basic part is to wonder...
viewtopic.php?f=49&t=264133
Ie. expect lots of bugs & glitches. As already said above, your best bet would be Mint 19.
Even then, you'll still have to wait until kernel 4.17 becomes available, Mesa receives updates etc etc...
nevl
Level 1
Level 1
Posts: 21
Joined: Mon Mar 06, 2017 12:44 am

Re: (SOLVED) Need GPU driver advice for LM 18.3 AMD/ATI

Post by nevl »

thx-1138 wrote:
Wed Jun 13, 2018 3:26 am
nevl...

Xorg 1.18.4 was released 17 July 2017, kernel 4.13 on 3 September 2017...
Xorg 1.19.5 was released 12 October 2017, kernel 4.15 on January 28 2018...

...and your Ryzen 5 2400G was released in...'the future' -> 12 February 2018. :wink:

The mere fact that not only it boots but works for the basic part is to wonder...
viewtopic.php?f=49&t=264133
Ie. expect lots of bugs & glitches. As already said above, your best bet would be Mint 19.
Even then, you'll still have to wait until kernel 4.17 becomes available, Mesa receives updates etc etc...
hahahaha
thanks for your information and analysis.. and thanks you very much for your guide and help...
NevL
Post Reply

Return to “Graphics Cards & Monitors”