Nvidia settings patch and save

Screen resolution, 3D Acceleration, nVidia, ATI
Forum rules
Before you post please read this
Post Reply
neggard
Level 1
Level 1
Posts: 29
Joined: Sat Oct 25, 2008 11:53 am

Nvidia settings patch and save

Post by neggard » Sun Jun 17, 2018 5:37 am

Hello.
I installed Linux Mint 19 Cinnamon beta and the nvidia driver is version 390.48
Where is the right patch to "X configuration file"?
I have change my monitor refreshrate and want to save that so it works all the time.

User avatar
catweazel
Level 17
Level 17
Posts: 7749
Joined: Fri Oct 12, 2012 9:44 pm
Location: Australian Antarctic Territory

Re: Nvidia settings patch and save

Post by catweazel » Sun Jun 17, 2018 5:40 am

neggard wrote:
Sun Jun 17, 2018 5:37 am
Hello.
I installed Linux Mint 19 Cinnamon beta and the nvidia driver is version 390.48
Where is the right patch to "X configuration file"?
I have change my monitor refreshrate and want to save that so it works all the time.
nVidia settings > X Server Display Configuration > Save to X Configuration File

Path and name: /etc/X11/xorg.conf
¡uʍop ǝpısdn sı buıɥʇʎɹǝʌǝ os ɐıןɐɹʇsnɐ ɯoɹɟ ɯ,ı

neggard
Level 1
Level 1
Posts: 29
Joined: Sat Oct 25, 2008 11:53 am

Re: Nvidia settings patch and save

Post by neggard » Sun Jun 17, 2018 6:29 am

Well I have my config in there.
But every time I reboot my refreshrate is 60hz
Why dont Linux Mint read that file?

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings: version 390.42 (buildd@lcy01-amd64-029) Thu Mar 22 17:34:03 UTC 2018


Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
Option "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "type1"
Load "freetype"
Load "glx"
EndSection

Section "InputDevice"

# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "Monitor"

# HorizSync source: edid, VertRefresh source: edid
Identifier "Monitor0"
VendorName "Unknown"
ModelName "BenQ ZOWIE XL LCD"
HorizSync 30.0 - 160.0
VertRefresh 56.0 - 144.0
Option "DPMS"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce GTX 980 Ti"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "Stereo" "0"
Option "nvidiaXineramaInfoOrder" "DFP-0"
Option "metamodes" "1920x1080_144 +0+0"
Option "SLI" "Off"
Option "MultiGPU" "Off"
Option "BaseMosaic" "off"
SubSection "Display"
Depth 24
EndSubSection
EndSection

User avatar
roblm
Level 9
Level 9
Posts: 2765
Joined: Sun Feb 24, 2013 2:41 pm

Re: Nvidia settings patch and save

Post by roblm » Sun Jun 17, 2018 9:55 am

EDITED: Try this method before trying the method below. Open the Nvidia Settings utility and set the refresh rate to 144 Hz. Close the program and go to System Settings > Display. Click the Apply button. Log out and back in. END OF EDITING.


You will need to force Xorg to use the 144 Hz refresh rate. Use this command to open the xorg.conf file for editing but ignore the Warning message:

Code: Select all

xed admin:///etc/X11/xorg.conf
Add this line to Section "Monitor":

Code: Select all

Modeline "1920x1080x143.98"  346.50  1920 1968 2000 2080  1080 1083 1087 1157  +HSync -VSync
Add this line to Section "Screen" after the metamodes line:

Code: Select all

Option "ModeValidation" "NoXserverModes, NoVesaModes, NoEdidModes, AllowNonEdidModes"
Logout and back in but be prepared for trouble.

If there is a problem getting back to the desktop, then press Ctrl+Alt+F1 to enter the virtual console tty1. Login and then type this command to rename the xorg.conf file:

Code: Select all

sudo mv /etc/X11/xorg.conf /etc/X11/xorg.conf.old
Then type: sudo reboot

If you can't enter tty1, then press Ctrl+Alt+Delete to reboot. If that doesn’t work, then press and hold the Alt+PrintScreen keys with your small fingers and then press the keys REISUB. Select Recovery Mode at the GRUB boot menu. If no menu shows, then hold down the Shift key while starting (or keep tapping it). For Mint 19, you may need to press the Esc key.
See this topic: viewtopic.php?f=47&t=270727&p=1478447&h ... b#p1478175

In the menu, select “root - drop to root shell prompt”. When asked for the root password, just type your user password. Then change the file permissions to read and write by typing:

Code: Select all

mount -o remount,rw /

Type this command to rename the xorg.conf file:

Code: Select all

mv /etc/X11/xorg.conf /etc/X11/xorg.conf.old

Then type: reboot

neggard
Level 1
Level 1
Posts: 29
Joined: Sat Oct 25, 2008 11:53 am

Re: Nvidia settings patch and save

Post by neggard » Thu Jun 21, 2018 2:54 pm

Try this method before trying the method below. Open the Nvidia Settings utility and set the refresh rate to 144 Hz. Close the program and go to System Settings > Display. Click the Apply button. Log out and back in.

Wonderful, the easiest solution works.
Thanks for the help. :D :D :D :D

Post Reply

Return to “Graphics Cards & Monitors”