Nvidia Tearing on LM 19

Screen resolution, 3D Acceleration, nVidia, ATI
Forum rules
Before you post please read this
Post Reply
Zenubix
Level 1
Level 1
Posts: 4
Joined: Fri Jul 06, 2018 6:46 am

Nvidia Tearing on LM 19

Post by Zenubix » Fri Jul 06, 2018 6:57 am

Hey guys

I know that there may be a lot of topics on this subject, and I probably read them all and try out most solutions, but still cannot fix this problem.
That being said, I have GTX 1050 Ti running on the latest proprietry driver installed via Driver Manager (390.48) and I've experienced a lot of
tearing on youtube videos, scrolling forums, web pages etc, but not on games.

I've tried to add "tearfree" and "triplebuffer" options on the xorg.config but in both cases I got only black screen after restart, and had to purge drivers and
reinstall them.

Code: Select all

Graphics:  Card: NVIDIA GP107 [GeForce GTX 1050 Ti]
           Display Server: x11 (X.Org 1.19.6 ) drivers: nvidia (unloaded: modesetting,fbdev,vesa,nouveau)
           Resolution: 1920x1080@60.00hz
           OpenGL: renderer: GeForce GTX 1050 Ti/PCIe/SSE2 version: 4.6.0 NVIDIA 390.48
Xorg.config:

Code: Select all

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 390.42  (buildd@lcy01-amd64-029)  Thu Mar 22 17:34:03 UTC 2018

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "Module"
    Load           "dbe"
    Load           "extmod"
    Load           "type1"
    Load           "freetype"
    Load           "glx"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "BenQ GL2440H"
    HorizSync       30.0 - 83.0
    VertRefresh     50.0 - 76.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GTX 1050 Ti"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "DFP-1"
    Option         "metamodes" "nvidia-auto-select +0+0 {ForceCompositionPipeline=On, ForceFullCompositionPipeline=On}"
    Option         "SLI" "Off"
    Option         "MultiGPU" "Off"
    Option         "BaseMosaic" "off"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection
As you can see, even with ForceCompositionPipeline and ForceFullCompositionPipeline enabled, I still get tearing.
I am open to any suggestion.

User avatar
trytip
Level 8
Level 8
Posts: 2151
Joined: Tue Jul 05, 2016 1:20 pm

Re: Nvidia Tearing on LM 19

Post by trytip » Fri Jul 06, 2018 10:05 am

try one or the other not both

Code: Select all

"nvidia-auto-select +0+0 { ForceFullCompositionPipeline = On }"
Image

Zenubix
Level 1
Level 1
Posts: 4
Joined: Fri Jul 06, 2018 6:46 am

Re: Nvidia Tearing on LM 19

Post by Zenubix » Fri Jul 06, 2018 5:55 pm

It's not allowing me to select ForceFullCompositionPipeline = On via GUI of Nvidia settings without selecting the other also.
Tried to manually set them thru xorg.config but now i get black screen regardless what I write as an option. Even when I save
the default xorg.config I still get black screen. Tbh, at this point, I am clueless.

User avatar
trytip
Level 8
Level 8
Posts: 2151
Joined: Tue Jul 05, 2016 1:20 pm

Re: Nvidia Tearing on LM 19

Post by trytip » Fri Jul 06, 2018 6:06 pm

delete xorg.conf and reboot, that should bring you to a desktop, then you can continue to set it with sudo nvidia-xconfig
Image

Zenubix
Level 1
Level 1
Posts: 4
Joined: Fri Jul 06, 2018 6:46 am

Re: Nvidia Tearing on LM 19

Post by Zenubix » Fri Jul 06, 2018 6:34 pm

Okay, I removed xorg.config and tried to set it with

Code: Select all

sudo nvidia-xconfig
and it returned default file in which I added the

Code: Select all

"nvidia-auto-select +0+0 { ForceFullCompositionPipeline = On }"
.

After restart, again I got black screen.

User avatar
catweazel
Level 17
Level 17
Posts: 7566
Joined: Fri Oct 12, 2012 9:44 pm
Location: Australian Antarctic Territory

Re: Nvidia Tearing on LM 19

Post by catweazel » Fri Jul 06, 2018 9:02 pm

Zenubix wrote:
Fri Jul 06, 2018 6:34 pm
Okay, I removed xorg.config and tried to set it with

Code: Select all

sudo nvidia-xconfig
and it returned default file in which I added the

Code: Select all

"nvidia-auto-select +0+0 { ForceFullCompositionPipeline = On }"
After restart, again I got black screen.
Edit the line that reads Option "metamodes" ... like this:

Code: Select all

Option         "metamodes" "DVI-I-1: nvidia-auto-select +0+0 { ForceFullCompositionPipeline = On }"
That's for my machine so don't replace whatever you have with DVI-I-1.
¡uʍop ǝpısdn sı buıɥʇʎɹǝʌǝ os ɐıןɐɹʇsnɐ ɯoɹɟ ɯ,ı

Zenubix
Level 1
Level 1
Posts: 4
Joined: Fri Jul 06, 2018 6:46 am

Re: Nvidia Tearing on LM 19

Post by Zenubix » Sat Jul 07, 2018 3:43 pm

Yes I edited with "Option" included, and no it doesn't fix the problem.

Post Reply

Return to “Graphics Cards & Monitors”