graphics card active unknowed.

Screen resolution, 3D Acceleration, nVidia, ATI
Forum rules
Before you post please read this
Post Reply
getaway
Level 2
Level 2
Posts: 71
Joined: Tue Jul 15, 2014 3:11 am
Location: Bretagne, France

graphics card active unknowed.

Post by getaway » Thu Jul 19, 2018 12:19 pm

I am not sure of what have exactly been done to my laptop.
Things worked well before I tried to upgrade to Tara 19. Then I had problems with bluetooth and audio. Downgrading to a 18.3 snapshot didn't fix the problem. For a few days I did many manipulations around bluez, pulseaudio and alsa during a few days. Things have more or less been fixed for that subject.
But.... At some time, the management of GPU's cards became impossible. (My laptop is equiped with 2 GPU's: one is the intel chipset, the other a Nvidia 384 card.)
On the linuxmint dashboard the green Nvidia applet disappeared, replaced by a red one with an X in the center, telling "active graphic card: unknown".

Following is a inxi listing

Code: Select all

System:    Host: gerard-UX430UNR Kernel: 4.10.0-38-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: Cinnamon 3.6.7 (Gtk 3.18.9-1ubuntu3.3)
           Distro: Linux Mint 18.3 Sylvia
Machine:   System: ASUSTeK (portable) product: UX430UNR v: 1.0
           Mobo: ASUSTeK model: UX430UNR v: 1.0
           Bios: American Megatrends v: UX430UNR.304 date: 03/09/2018
CPU:       Quad core Intel Core i7-8550U (-HT-MCP-) cache: 8192 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 15936
           clock speeds: max: 4000 MHz 1: 719 MHz 2: 785 MHz 3: 777 MHz
           4: 787 MHz 5: 699 MHz 6: 771 MHz 7: 784 MHz 8: 781 MHz
Graphics:  Card-1: Intel Device 5917 bus-ID: 00:02.0
           Card-2: NVIDIA Device 1d10 bus-ID: 01:00.0
           Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa)
           Resolution: 1368x768@60.00hz
           GLX Renderer: Mesa DRI Intel Kabylake GT1.5
           GLX Version: 3.0 Mesa 17.2.8 Direct Rendering: Yes
Audio:     Card Intel Device 9d71 driver: snd_hda_intel bus-ID: 00:1f.3
           Sound: Advanced Linux Sound Architecture v: k4.10.0-38-generic
Network:   Card: Intel Device 24fd driver: iwlwifi bus-ID: 02:00.0
           IF: wlp2s0 state: up speed: N/A duplex: N/A mac: <filter>
Drives:    HDD Total Size: 2605.1GB (56.6% used)
           ID-1: /dev/sda model: SanDisk_SD9SN8W5 size: 512.1GB
           ID-2: USB /dev/sdb model: Elements_25A2 size: 1000.2GB
           ID-3: USB /dev/sdc model: My_Passport_0830 size: 1000.2GB
           ID-4: USB /dev/sdf model: Ultra size: 31.1GB
           ID-5: USB /dev/sde model: Ultra size: 61.5GB
           Optical: No optical drives detected.
Partition: ID-1: / size: 234G used: 58G (26%) fs: ext4 dev: /dev/sda5
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 42.5C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 266 Uptime: 47 min Memory: 1446.1/15905.7MB
           Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35 
Clicking this red applet runs the "Nvidia server settings" which shows the intel chipset as the active GPU.
When I choose the Nvidia GPU, I'm told to close and reopen a session (as it always did...) but after I'v done so, the applet is still red in the dashboard ant the "Nvidia server settings" tool still show the intel chipset as the active GPU...
Following advices from some posts I read on this forum, I tried apt-get purge bumblebee, bbswitch and Nvidia; reinstalled Nvidia 384 driver. I even upgraded kernel from 4.10.0-38 to 4.13.0-45 (not the last but the one proposed by the LinuxMint update tool. None on this made things better... (so, for the kernel I came back to 4.10.0-38)

Has somebody any idea which could help me to fix that?
Linuxmint Cinnamon Tara 19 64 bits
Asus X200MA and UX430U

XP-refugee
Level 1
Level 1
Posts: 28
Joined: Mon Jan 01, 2018 2:41 am

re: Active graphics card: unknown

Post by XP-refugee » Mon Sep 03, 2018 3:13 am

WARNING: This is low quality help.
All I know is that following the instructions on the link below worked for me.
I do not know if the instructions are safe.
Or if they will work for anyone else.

https://unix.stackexchange.com/question ... -18/440089

gm10
Level 13
Level 13
Posts: 4667
Joined: Thu Jun 21, 2018 5:11 pm

Re: graphics card active unknowed.

Post by gm10 » Mon Sep 03, 2018 3:23 am

getaway wrote:
Thu Jul 19, 2018 12:19 pm
But.... At some time, the management of GPU's cards became impossible. (My laptop is equiped with 2 GPU's: one is the intel chipset, the other a Nvidia 384 card.)
On the linuxmint dashboard the green Nvidia applet disappeared, replaced by a red one with an X in the center, telling "active graphic card: unknown".
Run this in a terminal:

Code: Select all

sudo update-pciids
After that inxi should identify your GPU as GP108M [GeForce MX150].

You will have to install the binary nvidia driver via driver manager or that graphics-drivers PPA but I'll let you nvidia experts tell you the details.

User avatar
catweazel
Level 17
Level 17
Posts: 7774
Joined: Fri Oct 12, 2012 9:44 pm
Location: Australian Antarctic Territory

Re: graphics card active unknowed.

Post by catweazel » Mon Sep 03, 2018 3:36 am

getaway wrote:
Thu Jul 19, 2018 12:19 pm
Things worked well before I tried to upgrade to Tara 19.

Code: Select all

Machine:   System: ASUSTeK (portable) product: UX430UNR v: 1.0
Has somebody any idea which could help me to fix that?
https://www.pcsuggest.com/nvidia-optimus-ubuntu/

You're not the only one having trouble with Optimus-based graphics in Asus gear. Try that link, but it's not for the faint-hearted.
¡uʍop ǝpısdn sı buıɥʇʎɹǝʌǝ os ɐıןɐɹʇsnɐ ɯoɹɟ ɯ,ı

Post Reply

Return to “Graphics Cards & Monitors”