[SOLVED] Tearing in LM 19 only when an external monitor is rotated

Screen resolution, 3D Acceleration, nVidia, ATI
Forum rules
Before you post please read this
Post Reply
javigh
Level 1
Level 1
Posts: 2
Joined: Fri Jul 27, 2018 4:59 am

[SOLVED] Tearing in LM 19 only when an external monitor is rotated

Post by javigh » Fri Jul 27, 2018 5:49 am

Hi all,

I recently installed Linux Mint 18.3 that I updated to 19 in a week and I have had this problem with both of them.

I have a laptop Clevo N131WU with an i7-8550U and two Full HD external monitors connected for a total of 3 screens at 1920x1080. When I use the 3 screens in landscape mode everything seems fine, but when I rotate 90 degrees one of them, the tearing appears in all monitors and the wallpaper has random black zones, especially where you have dragged the window over... When you select another window, this usually disappears and the wallpapers is fine but it'll appear again if you move another window. If I have only the wallpaper showing on the rotated monitor (because the other one has a window maximized for example) then the black artifacts concentrate only around the window.

Apart from that, one of the monitors (the one in landscape mode) has "diagonal" tearing while the rotated one has "vertical" tearing... Not sure why... The tearing and black artifacts are related though because or I have both or everything is fine.

I have tried to rotate the monitor with xrandr and the "Display" settings and I have the same problems... Not sure if the "Display" uses xrandr underneath.

This is the information about my system:

Code: Select all

CPU~Quad core Intel Core i7-8550U (-MT-MCP-) speed/max~800/4000 MHz Kernel~4.15.0-29-generic x86_64 Up~1 day Mem~11759.0/15917.3MB HDD~2050.4GB(10.2% used) Procs~334 Client~Shell inxi~2.3.56

Code: Select all

00:02.0 VGA compatible controller: Intel Corporation UHD Graphics 620 (rev 07)
	Subsystem: CLEVO/KAPOK Computer UHD Graphics 620
	Kernel driver in use: i915
	Kernel modules: i915

Code: Select all

Graphics:  Card: Intel UHD Graphics 620
           Display Server: X.Org 1.19.6 driver: modesetting
           Resolution: 1920x1080@60.01hz, 1920x1080@60.00hz, 1920x1080@60.00hz
           OpenGL: renderer: Mesa DRI Intel UHD Graphics 620 (Kabylake GT2) version: 4.5 Mesa 18.0.5

Code: Select all

Screen 0: minimum 320 x 200, current 4920 x 1920, maximum 8192 x 8192
eDP-1 connected 1920x1080+0+680 (normal left inverted right x axis y axis) 293mm x 165mm
   1920x1080     60.01*+  60.01    59.97    59.96    59.93
   HDMI-1 connected 1080x1920+3840+0 left (normal left inverted right x axis y axis) 477mm x 268mm
   1920x1080     60.00*+
   HDMI-2 connected primary 1920x1080+1920+680 (normal left inverted right x axis y axis) 477mm x 268mm
   1920x1080     60.00*+
I've tried to set the option

Code: Select all

Option "TearFree" "true"
in

Code: Select all

/etc/X11/xorg.conf.d/20-intel.conf
and using different acceleration methods, but I haven't been able to fix this.

Should I spend more time trying to fix that or it's a matter of time until a new driver/kernel fixes it?

Thank you!
Attachments
IMG_20180727_102901.jpg
Last edited by javigh on Mon Sep 03, 2018 4:59 am, edited 1 time in total.

javigh
Level 1
Level 1
Posts: 2
Joined: Fri Jul 27, 2018 4:59 am

Re: Tearing in LM 19 only when an external monitor is rotated

Post by javigh » Mon Sep 03, 2018 4:58 am

Just in case someone is interested, I couldn't fix the tearing problem with the "modesetting" driver. Once I installed the intel driver and used it, everything was fixed.

Post Reply

Return to “Graphics Cards & Monitors”