I can't get nVidia optimus running with bumblebee!

Screen resolution, 3D Acceleration, nVidia, ATI
Forum rules
Before you post please read this
Post Reply
Vincintosh
Level 1
Level 1
Posts: 3
Joined: Wed Aug 01, 2018 7:18 pm

I can't get nVidia optimus running with bumblebee!

Post by Vincintosh » Wed Aug 01, 2018 7:27 pm

Good morning everyone, I hope there's someone that can help me solve this very annoying issue. I have a Xiaomi Notebook Pro laptop with nVidia Optimus technology. I was able to get the proprietary drivers running with prime using the integrated Driver Manager software of Linux Mint. But that's not what I want, I need the GPU to be available on the go without rebooting with Bumblebee and Optirun, as I have always been able to achieve with many other distros. So I installed bumblebee, but when I try to optirun something here's what I get

Code: Select all

[  550.983104] [ERROR]Cannot access secondary GPU - error: Could not load GPU driver

[  550.983171] [ERROR]Aborting because fallback start is disabled.
Here's my bumblebee.conf

Code: Select all

# Configuration file for Bumblebee. Values should **not** be put between quotes

## Server options. Any change made in this section will need a server restart
# to take effect.
[bumblebeed]
# The secondary Xorg server DISPLAY number
VirtualDisplay=:8
# Should the unused Xorg server be kept running? Set this to true if waiting
# for X to be ready is too long and don't need power management at all.
KeepUnusedXServer=false
# The name of the Bumbleblee server group name (GID name)
ServerGroup=bumblebee
# Card power state at exit. Set to false if the card shoud be ON when Bumblebee
# server exits.
TurnCardOffAtExit=false
# The default behavior of '-f' option on optirun. If set to "true", '-f' will
# be ignored.
NoEcoModeOverride=false
# The Driver used by Bumblebee server. If this value is not set (or empty),
# auto-detection is performed. The available drivers are nvidia and nouveau
# (See also the driver-specific sections below)
Driver=nvidia
# Directory with a dummy config file to pass as a -configdir to secondary X
XorgConfDir=/etc/bumblebee/xorg.conf.d
# Xorg binary to run
XorgBinary=/usr/lib/xorg/Xorg

## Client options. Will take effect on the next optirun executed.
[optirun]
# Acceleration/ rendering bridge, possible values are auto, virtualgl and
# primus.
Bridge=primus
# The method used for VirtualGL to transport frames between X servers.
# Possible values are proxy, jpeg, rgb, xv and yuv.
VGLTransport=proxy
# List of paths which are searched for the primus libGL.so.1 when using
# the primus bridge
PrimusLibraryPath=/usr/lib/x86_64-linux-gnu/primus:/usr/lib/i386-linux-gnu/primus
# Should the program run under optirun even if Bumblebee server or nvidia card
# is not available?
AllowFallbackToIGC=false


# Driver-specific settings are grouped under [driver-NAME]. The sections are
# parsed if the Driver setting in [bumblebeed] is set to NAME (or if auto-
# detection resolves to NAME).
# PMMethod: method to use for saving power by disabling the nvidia card, valid
# values are: auto - automatically detect which PM method to use
#         bbswitch - new in BB 3, recommended if available
#       switcheroo - vga_switcheroo method, use at your own risk
#             none - disable PM completely
# https://github.com/Bumblebee-Project/Bumblebee/wiki/Comparison-of-PM-methods

## Section with nvidia driver specific options, only parsed if Driver=nvidia
[driver-nvidia]
# Module name to load, defaults to Driver if empty or unset
KernelDriver=nvidia
PMMethod=auto
# colon-separated path to the nvidia libraries
LibraryPath=/usr/lib/nvidia-390:/usr/lib32/nvidia-390
# comma-separated path of the directory containing nvidia_drv.so and the
# default Xorg modules path
XorgModulePath=/usr/lib/nvidia-390/xorg,/usr/lib/xorg/modules
XorgConfFile=/etc/bumblebee/xorg.conf.nvidia

## Section with nouveau driver specific options, only parsed if Driver=nouveau
[driver-nouveau]
KernelDriver=nouveau
PMMethod=auto
XorgConfFile=/etc/bumblebee/xorg.conf.nouveau
It seems correct, I've always configured it like this under other distros. I don't know, maybe I need to uninstall/disable the prime switching method but I don't know how to do that :? I'm new to Mint: I'm using the Cinnamon edition. Any help is really appreciated, thank you for your time

Vincintosh
Level 1
Level 1
Posts: 3
Joined: Wed Aug 01, 2018 7:18 pm

Re: I can't get nVidia optimus running with bumblebee!

Post by Vincintosh » Thu Aug 02, 2018 3:50 pm

nothing? :(

User avatar
roblm
Level 9
Level 9
Posts: 2765
Joined: Sun Feb 24, 2013 2:41 pm

Re: I can't get nVidia optimus running with bumblebee!

Post by roblm » Thu Aug 02, 2018 5:14 pm

What command did you use to install bumblebee?

Use these commands and post the output: inxi -Fxz and dpkg -l |grep -i nvidia

Vincintosh
Level 1
Level 1
Posts: 3
Joined: Wed Aug 01, 2018 7:18 pm

Re: I can't get nVidia optimus running with bumblebee!

Post by Vincintosh » Thu Aug 02, 2018 8:29 pm

roblm wrote:
Thu Aug 02, 2018 5:14 pm
What command did you use to install bumblebee?

Use these commands and post the output: inxi -Fxz and dpkg -l |grep -i nvidia
I installed Bumblebee from apt normally: sudo apt install bumblebee

User avatar
roblm
Level 9
Level 9
Posts: 2765
Joined: Sun Feb 24, 2013 2:41 pm

Re: I can't get nVidia optimus running with bumblebee!

Post by roblm » Fri Aug 03, 2018 6:53 am

Would you post all the info I requested. There was a change in how the /etc/bumblebee/bumblebee.conf file is configured, starting with Mint 19/Ubuntu 18.04.

Besides those other two commands, also post the output of this command: apt-cache policy nvidia-prime bumblebee-nvidia primus

User avatar
roblm
Level 9
Level 9
Posts: 2765
Joined: Sun Feb 24, 2013 2:41 pm

Re: I can't get nVidia optimus running with bumblebee!

Post by roblm » Sat Aug 04, 2018 7:09 am

Before answering your specific question, I had first wanted to gather enough info from you on what bumblebee related packages were installed on your system but you have posted very little info. I am also assuming that you have installed Mint 19.

Prior to Mint 19, after installing a Nvidia driver in Driver Manager, the Nvidia libraries were added to /usr/lib/nvidia-xxx, where xxx was the driver version, such as nvidia-384. The 32 bit libraries were added to /usr/lib32/nvidia-xxx.
The Nvidia driver module (nvidia_drv.so), was added to the subfolder /usr/lib/nvidia-xxx/xorg.

These paths changed for Mint 19. You can open the File Manager and check for those locations and they don’t exist.

So this LibraryPath line in your bumblebee.conf file:

# colon-separated path to the nvidia libraries
LibraryPath=/usr/lib/nvidia-390:/usr/lib32/nvidia-390

Should be changed to this:

LibraryPath=/usr/lib/x86_64-linux-gnu:/usr/lib/i386-linux-gnu


This XorgModulePath line in your file:

# comma-separated path of the directory containing nvidia_drv.so and the
# default Xorg modules path
XorgModulePath=/usr/lib/nvidia-390/xorg,/usr/lib/xorg/modules

Should be changed to this:

XorgModulePath=/usr/lib/x86_64-linux-gnu/nvidia/xorg,/usr/lib/xorg/modules

Reboot.

Making those changes may not be enough to get bumblebee to work correctly.

Post Reply

Return to “Graphics Cards & Monitors”