Vulkan on 19

Screen resolution, 3D Acceleration, nVidia, ATI
Forum rules
Before you post please read this
Post Reply
User avatar
jxr182
Level 1
Level 1
Posts: 5
Joined: Thu Aug 09, 2018 11:15 am
Location: Oklahoma
Contact:

Vulkan on 19

Post by jxr182 » Mon Aug 20, 2018 8:16 pm

I have searched the internet and mint forums but am not finding any clear how-to's. I found one for ubuntu at https://linuxconfig.org/install-and-tes ... n-on-linux but when i went to apt install vulkan and 396 weren't found.

How can I install vulkan? I have vulkaninfo and some dependencies installed but cannot find any guide or howto on how to get vulkan itself installed on my 19 system.

I don't know what info you guys will want. Maybe there's a general guide I'm just not finding. I'm running a 660 TI. I am currently running the 390 driver *I think*.

User avatar
catweazel
Level 16
Level 16
Posts: 6964
Joined: Fri Oct 12, 2012 9:44 pm
Location: Australian Antarctic Territory

Re: Vulkan on 19

Post by catweazel » Tue Aug 21, 2018 12:47 am

jxr182 wrote:
Mon Aug 20, 2018 8:16 pm
I have searched the internet and mint forums but am not finding any clear how-to's. I found one for ubuntu at https://linuxconfig.org/install-and-tes ... n-on-linux but when i went to apt install vulkan and 396 weren't found.
https://launchpad.net/~graphics-drivers ... ubuntu/ppa

Add that ppa and sudo apt update.
Caution: Dancing Wu Li Master and Official curmudgeon-in-chief

User avatar
jxr182
Level 1
Level 1
Posts: 5
Joined: Thu Aug 09, 2018 11:15 am
Location: Oklahoma
Contact:

Re: Vulkan on 19

Post by jxr182 » Tue Aug 21, 2018 6:33 pm

Thank you. Those are the same instructions I had already found on the other site though. I add the ppa, update and upgrade (upgrade may be unnecessary). Then I sudo apt install vulkan nvidia-396 and my system is still not able to find either of those packages.

User avatar
jxr182
Level 1
Level 1
Posts: 5
Joined: Thu Aug 09, 2018 11:15 am
Location: Oklahoma
Contact:

Re: Vulkan on 19

Post by jxr182 » Sun Aug 26, 2018 1:00 pm

I've installed everything vulkan I can find (not including anything actually called "vulkan").
When i run vulkaninfo i get:

/build/vulkan-77a_zE/vulkan-1.1.73+dfsg/demos/vulkaninfo.c:3141: failed with VK_ERROR_INITIALIZATION_FAILED

an internet search on that error found exactly 0 results. Looking at it i'm sure it's due to vulkan itself not being installed.

gm10
Level 9
Level 9
Posts: 2602
Joined: Thu Jun 21, 2018 5:11 pm

Re: Vulkan on 19

Post by gm10 » Sun Aug 26, 2018 1:27 pm

jxr182 wrote:
Sun Aug 26, 2018 1:00 pm
I've installed everything vulkan I can find (not including anything actually called "vulkan").
When i run vulkaninfo i get:

/build/vulkan-77a_zE/vulkan-1.1.73+dfsg/demos/vulkaninfo.c:3141: failed with VK_ERROR_INITIALIZATION_FAILED

an internet search on that error found exactly 0 results. Looking at it i'm sure it's due to vulkan itself not being installed.
Maybe, or you installed too much. All I have is mesa-vulkan-drivers (which installs libvulkan1) and now I added vulkan-utils for the vulkaninfo tool. Seems to run fine, although for my intel chip I get this funny warning message that you shouldn't usually see in release code:

Code: Select all

$ vulkaninfo | head -n5
INTEL-MESA: warning: ../../../src/intel/vulkan/anv_device.c:1034: FINISHME: Implement pop-free point clipping
===========
VULKAN INFO
===========

Vulkan Instance Version: 1.1.73
Someone finish it already. :lol:

This is followed by endless pages of supported modes and formats. but at least I know it runs v1.1:

Code: Select all

Device Properties and Extensions :
==================================
GPU0
VkPhysicalDeviceProperties:
===========================
	apiVersion     = 0x401000  (1.1.0)
	driverVersion  = 75501573 (0x4801005)
	vendorID       = 0x8086
	deviceID       = 0x5a85
	deviceType     = INTEGRATED_GPU
	deviceName     = Intel(R) HD Graphics 500 (Broxton 2x6)
But better ask someone with an nvidia chip for help on what you should be seeing with yours.

Post Reply

Return to “Graphics Cards & Monitors”