Linux Mint 19 nVidia Driver 396

Screen resolution, 3D Acceleration, nVidia, ATI
Forum rules
Before you post please read this
Post Reply
StevenC21
Level 2
Level 2
Posts: 88
Joined: Mon Mar 19, 2018 11:02 pm

Linux Mint 19 nVidia Driver 396

Post by StevenC21 » Wed Aug 22, 2018 12:15 am

Anybody know how to install this one? I was following instructions from here: https://github.com/ValveSoftware/Proton ... PREREQS.md but when I try to run

Code: Select all

sudo apt install nvidia-driver-396
it gives me this:

Code: Select all

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 nvidia-driver-396 : Depends: libnvidia-gl-396 (= 396.51-0ubuntu0~gpu18.04.1) but it is not going to be installed
                     Depends: nvidia-dkms-396 (= 396.51-0ubuntu0~gpu18.04.1) but it is not going to be installed
                     Depends: libnvidia-compute-396 (= 396.51-0ubuntu0~gpu18.04.1) but it is not going to be installed
                     Depends: nvidia-compute-utils-396 (= 396.51-0ubuntu0~gpu18.04.1) but it is not going to be installed
                     Depends: libnvidia-decode-396 (= 396.51-0ubuntu0~gpu18.04.1) but it is not going to be installed
                     Depends: libnvidia-encode-396 (= 396.51-0ubuntu0~gpu18.04.1) but it is not going to be installed
                     Depends: nvidia-utils-396 (= 396.51-0ubuntu0~gpu18.04.1) but it is not going to be installed
                     Depends: libnvidia-ifr1-396 (= 396.51-0ubuntu0~gpu18.04.1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
Running Linux Mint 19 Cinnamon.

Code: Select all

inxi -Fxzb

Code: Select all

System:    Host: steven-GL753VE Kernel: 4.15.0-32-generic x86_64 bits: 64 gcc: 7.3.0
           Desktop: Cinnamon 3.8.8 (Gtk 3.22.30) Distro: Linux Mint 19 Tara
Machine:   Device: laptop System: ASUSTeK product: GL753VE v: 1.0 serial: N/A
           Mobo: ASUSTeK model: GL753VE v: 1.0 serial: N/A
           UEFI: American Megatrends v: GL753VE.306 date: 01/02/2018
Battery    BAT0: charge: 41.2 Wh 96.7% condition: 42.6/48.2 Wh (88%)
           model: Simplo SDI ICR18650 status: N/A
CPU:       Quad core Intel Core i7-7700HQ (-MT-MCP-) arch: Skylake rev.9 cache: 6144 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 22464
           clock speeds: max: 3800 MHz 1: 2048 MHz 2: 2200 MHz 3: 2188 MHz 4: 2200 MHz
           5: 2200 MHz 6: 2193 MHz 7: 2195 MHz 8: 2200 MHz
Graphics:  Card-1: Intel Device 591b bus-ID: 00:02.0
           Card-2: NVIDIA GP107M [GeForce GTX 1050 Ti Mobile] bus-ID: 01:00.0
           Display Server: x11 (X.Org 1.19.6 )
           drivers: modesetting,nvidia (unloaded: fbdev,vesa,nouveau)
           Resolution: 1920x1080@60.02hz
           OpenGL: renderer: GeForce GTX 1050 Ti/PCIe/SSE2
           version: 4.6.0 NVIDIA 390.48 Direct Render: Yes
Audio:     Card Intel CM238 HD Audio Controller driver: snd_hda_intel bus-ID: 00:1f.3
           Sound: Advanced Linux Sound Architecture v: k4.15.0-32-generic
Network:   Card-1: Intel Wireless 7265 driver: iwlwifi bus-ID: 02:00.0
           IF: wlp2s0 state: up mac: <filter>
           Card-2: Realtek RTL8111/8168/8411 PCIE Gigabit Ethernet Controller
           driver: r8169 v: 2.3LK-NAPI port: d000 bus-ID: 03:00.0
           IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives:    HDD Total Size: 1256.6GB (61.1% used)
           ID-1: /dev/sda model: SanDisk_SD8SN8U1 size: 128.0GB
           ID-2: /dev/sdb model: TOSHIBA_MQ01ABD1 size: 1000.2GB
           ID-3: USB /dev/sdc model: Flash_Drive size: 128.3GB
Partition: ID-1: / size: 214G used: 161G (80%) fs: ext4 dev: /dev/sdb2
           ID-2: swap-1 size: 16.10GB used: 0.00GB (0%) fs: swap dev: /dev/sdb3
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 63.5C mobo: N/A gpu: 0.0:53C
           Fan Speeds (in rpm): cpu: 0
Info:      Processes: 306 Uptime: 7:32 Memory: 2922.9/15925.4MB
           Init: systemd runlevel: 5 Gcc sys: 7.3.0 Client: Shell (bash 4.4.191) inxi: 2.3.56 
"A computer is like air conditioning. It becomes useless when you open Windows."
- Linus Torvalds

User avatar
kyphi
Level 8
Level 8
Posts: 2324
Joined: Sat Jul 09, 2011 1:14 am
Location: The Hunter, Australia

Re: Linux Mint 19 nVidia Driver 396

Post by kyphi » Wed Aug 22, 2018 12:33 am

There seems to be a line missing in the instructions (sudo apt-get update).

Code: Select all

sudo add-apt-repository ppa:graphics-drivers/ppa
sudo apt-get update
sudo apt install nvidia-driver-396
Linux Mint 19 Cinnamon - 64bit

StevenC21
Level 2
Level 2
Posts: 88
Joined: Mon Mar 19, 2018 11:02 pm

Re: Linux Mint 19 nVidia Driver 396

Post by StevenC21 » Wed Aug 22, 2018 12:35 am

Thank you very much for this! I don't know how I missed that.
"A computer is like air conditioning. It becomes useless when you open Windows."
- Linus Torvalds

Bawyn
Level 1
Level 1
Posts: 3
Joined: Mon Oct 01, 2018 6:32 pm

Re: Linux Mint 19 nVidia Driver 396

Post by Bawyn » Thu Oct 04, 2018 2:23 pm

I am having the same issue, only I took it one step further, did what was recommended, but got:
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help resolve the situation:

The following packages have unmet dependencies:
nvidia-driver-396 : Depends: libnvidia-gl-396 (= 396.54-0ubuntu0~gpu18.04.1) but it is not going to be installed
Depends: nvidia-dkms-396 (= 396.54-0ubuntu0~gpu18.04.1) but it is not going to be installed
Depends: libnvidia-compute-396 (= 396.54-0ubuntu0~gpu18.04.1) but it is not going to be installed
Depends: nvidia-compute-utils-396 (= 396.54-0ubuntu0~gpu18.04.1) but it is not going to be installed
Depends: libnvidia-decode-396 (= 396.54-0ubuntu0~gpu18.04.1) but it is not going to be installed
Depends: libnvidia-encode-396 (= 396.54-0ubuntu0~gpu18.04.1) but it is not going to be installed
Depends: nvidia-utils-396 (= 396.54-0ubuntu0~gpu18.04.1) but it is not going to be installed
Depends: libnvidia-ifr1-396 (= 396.54-0ubuntu0~gpu18.04.1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
What am I doing wrong?

EDIT: I solved my dilemma. After attempting to install the driver, I rebooted, and noticed my system needed an update. After updating this, it allowed me to install the 396 driver. (Which works great btw). So thanks!
Last edited by Bawyn on Thu Oct 04, 2018 4:41 pm, edited 2 times in total.

ajgringo619
Level 4
Level 4
Posts: 472
Joined: Thu Mar 01, 2018 8:36 pm
Location: San Diego, California

Re: Linux Mint 19 nVidia Driver 396

Post by ajgringo619 » Thu Oct 04, 2018 2:45 pm

When I first upgraded to the 396 series (version 24, using the same PPA), I had to upgrade to the latest 390 version (I think it was 390.87). After that (and a reboot, of course) I was able to install the 396 series. I've been on 396.54 for a while now and it runs great.
[Mint 19 XFCE, AMD FX-8350 Eight-Core w/16 GB RAM, 4.15.0-39-generic, GeForce GTX 960 w/Nvidia 410.73]
Image

Post Reply

Return to “Graphics Cards & Monitors”