Nvidia video tearing

Screen resolution, 3D Acceleration, nVidia, ATI
Forum rules
Before you post please read this
Moosetek13
Level 1
Level 1
Posts: 36
Joined: Sat Jun 27, 2015 10:16 pm

Re: Nvidia video tearing

Post by Moosetek13 » Mon Sep 03, 2018 10:47 pm

I still do not see any tearing. I think that fix worked.

Again, Roblm, Thank You!

Moosetek13
Level 1
Level 1
Posts: 36
Joined: Sat Jun 27, 2015 10:16 pm

Re: Nvidia video tearing

Post by Moosetek13 » Thu Sep 06, 2018 12:00 am

Just a quick update.

2 days later, and the problem has not shown up again.

jamieyeung1991
Level 1
Level 1
Posts: 1
Joined: Sat Sep 08, 2018 1:46 pm

Re: Nvidia video tearing

Post by jamieyeung1991 » Sat Sep 08, 2018 1:49 pm

roblm wrote:
Mon Sep 03, 2018 6:37 pm
For laptops with Nvidia’s Optimus technology, to prevent tearing on the laptop’s screen when the Nvidia GPU is enabled, the kernel parameter nvidia-drm.modeset=1 needs to be used. Use this command to open the grub file:
xed admin:///etc/default/grub

Change this line:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

To this:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nvidia-drm.modeset=1"

Then update grub and reboot: sudo update-grub; reboot

Running glxgears in the Terminal should show the framerate is the same as the monitor's refresh rate.
Thanks man :D

Post Reply

Return to “Graphics Cards & Monitors”