Proprietary Nvidia drivers on Mint 19 turning off screen on TTY/i3

Screen resolution, 3D Acceleration, nVidia, ATI
Forum rules
Before you post please read this
Post Reply
tubtub303
Level 1
Level 1
Posts: 1
Joined: Sun Sep 09, 2018 10:16 pm

Proprietary Nvidia drivers on Mint 19 turning off screen on TTY/i3

Post by tubtub303 » Sun Sep 09, 2018 10:55 pm

I've been scouring the internet over the past two days looking for a solution to this problem and have yet to find anything that worked. The X server starts up just fine and the graphical tty7 runs no problem, but when I switch to any other tty1-6, two of my three screen briefly flash the login prompt before going dark.
Here are some details:
  • Mint 19.0 with Cinnamon 3.8.8, kernel version 4.15.0-20-generic
  • Nvidia GeForce GTX 1060 6 GB, driver version 390.48
  • 1 monitor connected via DisplayPort
  • 1 monitor via DVI
  • 1 TV via HDMI
I've tried:
  • open source nouveau drivers
  • forcing graphics modes with GRUB_GFXMODE and GRUB_GFXPAYLOAD_LINUX
  • GRUB command line parameters for nvidia-drm.modeset, nomodeset, vga, and uvesafb
and nothing has worked so far.

From what I can tell, it's not an X issue because the tty consoles don't use an X server, it's a text-only graphical mode. Despite this, I've tried many Xorg configuration solutions but (surprise) none of them worked.
What's strangest to me about it is that not all of the displays go dark. The DisplayPort and DVI monitors quickly fade to black but are still receiving a signal - they do not go into standby mode, although that has happened a few times when I've broken the X config trying to change things - yet the HDMI-connected TV will show the entire console.
Even weirder, if a program sends color output, the DVI monitor turns back on! It will stay on for a while but occasionally fades to black, I'm not sure what causes this. The TV always stays on and the DP monitor always stays off.

I know plenty of people have had similar issues in the past but all of those seem to be fixed by simply adding the GFX_MODE lines in the grub. Even the more obscure framebuffer fixes haven't helped for me. Oh, and I forgot to mention, I started out using Manjaro, tried fixes on clean installs of Ubuntu and Debian before landing on Mint. From this and from posts on other forums it seems like this problem has more to do with the kernel itself than the specific distribution.

Edit: I also forgot to mention that if I kill the X server and start a new one on a tty for i3, the exact same behavior occurs.

Any help would be greatly appreciated!

Post Reply

Return to “Graphics Cards & Monitors”