nvidia-settings stay at default. (SOLVED)

Screen resolution, 3D Acceleration, nVidia, ATI
Forum rules
Before you post please read this
Post Reply
User avatar
Prsman
Level 4
Level 4
Posts: 222
Joined: Tue Nov 17, 2015 3:15 pm

nvidia-settings stay at default. (SOLVED)

Post by Prsman » Mon Sep 24, 2018 9:33 pm

Can someone please help me to find why when I run nvida-settings and make changes, the settings stay as they were. some info to help.

Code: Select all

starsailor@Surfer ~ $ inxi -G
Graphics:  Card: NVIDIA G96 [GeForce 9400 GT]
           Display Server: X.Org 1.18.4 driver: nvidia
           Resolution: 1280x1024@60.02hz
           GLX Renderer: GeForce 9400 GT/PCIe/SSE2
           GLX Version: 3.3.0 NVIDIA 340.107

Code: Select all

starsailor@Surfer ~ $ sudo nvidia-settings
[sudo] password for starsailor: 
libEGL warning: DRI2: failed to authenticate
libEGL warning: DRI2: failed to authenticate
** Message: PRIME: No offloading required. Abort
** Message: PRIME: is it supported? no

Code: Select all

starsailor@Surfer ~ $ cat /etc/X11/xorg.conf
# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 396.54  (buildd@lcy01-amd64-010)  Tue Aug 21 18:18:03 UTC 2018

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Philips 190S"
    HorizSync       30.0 - 83.0
    VertRefresh     56.0 - 76.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce 9400 GT"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "CRT-1"
    Option         "metamodes" "nvidia-auto-select +0+0"
    Option         "SLI" "Off"
    Option         "MultiGPU" "Off"
    Option         "BaseMosaic" "off"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Code: Select all

#
# /home/starsailor/.nvidia-settings-rc
#
# Configuration file for nvidia-settings - the NVIDIA X Server Settings utility
# Generated on Mon Sep 24 18:14:03 2018
#

# ConfigProperties:

RcFileLocale = C
DisplayStatusBar = Yes
SliderTextEntries = Yes
IncludeDisplayNameInConfigFile = Yes
ShowQuitDialog = Yes
UpdateRulesOnProfileNameChange = Yes
Timer = PowerMizer_Monitor_(GPU_0),Yes,1000
Timer = Thermal_Monitor_(GPU_0),Yes,1000
Timer = Memory_Used_(GPU_0),Yes,3000

# Attributes:

Surfer:0[DPY:VGA-0]/RedBrightness=0.000000
Surfer:0[DPY:VGA-0]/GreenBrightness=0.000000
Surfer:0[DPY:VGA-0]/BlueBrightness=0.000000
Surfer:0[DPY:VGA-0]/RedContrast=0.000000
Surfer:0[DPY:VGA-0]/GreenContrast=0.000000
Surfer:0[DPY:VGA-0]/BlueContrast=0.000000
Surfer:0[DPY:VGA-0]/RedGamma=1.000000
Surfer:0[DPY:VGA-0]/GreenGamma=1.000000
Surfer:0[DPY:VGA-0]/BlueGamma=1.000000
This is how I run nvidia-settings:

Code: Select all

sudo nvidia-settings

After you've configured your settings, click on X Server Display Configuration, then click on the Save to X Configuration File button, enter /etc/X11/xorg.conf in the textbox, make sure Merge with existing file is unchecked, then click the Save button.
My monitor is old, a Phillips 190S. What am I doing wrong? Thanks
Last edited by Prsman on Wed Sep 26, 2018 12:43 pm, edited 1 time in total.

User avatar
richyrich
Level 19
Level 19
Posts: 9027
Joined: Mon May 04, 2009 8:31 pm

Re: nvidia-settings stay at default.

Post by richyrich » Mon Sep 24, 2018 9:55 pm

I see this in the xorg.conf
# nvidia-settings: version 396.54 (buildd@lcy01-amd64-010) Tue Aug 21 18:18:03 UTC 2018
Did you at one time try to install the incorrect drivers ?

User avatar
Prsman
Level 4
Level 4
Posts: 222
Joined: Tue Nov 17, 2015 3:15 pm

Re: nvidia-settings stay at default.

Post by Prsman » Mon Sep 24, 2018 10:12 pm

Hi I did not try to install the incorrect drivers. I used the driver manager. But I had a problem. I had to run these commands after to get the driver installed.

Code: Select all

sudo apt install --reinstall initramfs-tools initramfs-tools-bin initramfs-tools-core
Then the nvidia driver would run, stayed on nouveau before. HTH


(edit) Synaptic says that nvidia-settings version 396 is what I have installed. No other version is listed.

User avatar
richyrich
Level 19
Level 19
Posts: 9027
Joined: Mon May 04, 2009 8:31 pm

Re: nvidia-settings stay at default.

Post by richyrich » Tue Sep 25, 2018 1:25 am

Oh . . I've never seen 396.xx settings with 340.xx drivers before.

Are you sure there isn't a graphical Nvidia Settings in the menu? Reading that last bit states the actions to take when in the Nvidia Settings GUI?
sudo nvidia-settings

After you've configured your settings, click on X Server Display Configuration, then click on the Save to X Configuration File button, enter /etc/X11/xorg.conf in the textbox, make sure Merge with existing file is unchecked, then click the Save button.

User avatar
trytip
Level 8
Level 8
Posts: 2484
Joined: Tue Jul 05, 2016 1:20 pm

Re: nvidia-settings stay at default.

Post by trytip » Tue Sep 25, 2018 2:48 am

dkms status in Terminal will show you what?
Image

User avatar
Prsman
Level 4
Level 4
Posts: 222
Joined: Tue Nov 17, 2015 3:15 pm

Re: nvidia-settings stay at default.

Post by Prsman » Tue Sep 25, 2018 2:19 pm

Hi, so from the replies, I assume that the nvidia-settings should be the same version as the driver. Yes/No? On the website Debian.pkgs.org/9/ I found this package: nvidia-settings-legacy-340xx_340.101-1_amd64.deb

As for:

Code: Select all

starsailor@Surfer ~ $ dkms status
bbswitch, 0.8, 4.4.0-134-generic, x86_64: installed
bbswitch, 0.8, 4.4.0-135-generic, x86_64: installed
ndiswrapper, 1.60, 4.4.0-134-generic, x86_64: installed
ndiswrapper, 1.60, 4.4.0-135-generic, x86_64: installed
nvidia-340, 340.107, 4.4.0-134-generic, x86_64: installed
nvidia-340, 340.107, 4.4.0-135-generic, x86_64: installed
I could purge the nvidia-settings I have and install the 340xx version. I'm feeling brave. :idea:

User avatar
richyrich
Level 19
Level 19
Posts: 9027
Joined: Mon May 04, 2009 8:31 pm

Re: nvidia-settings stay at default.

Post by richyrich » Tue Sep 25, 2018 2:25 pm

You forgot to answer: Do you have the graphical Nvidia Settings program in the Menu ?

User avatar
trytip
Level 8
Level 8
Posts: 2484
Joined: Tue Jul 05, 2016 1:20 pm

Re: nvidia-settings stay at default.

Post by trytip » Tue Sep 25, 2018 3:16 pm

i never understood the need for separate packages with nvidia and nvidia settings. i had to find nvidia-settings_331.20-0ubuntu8_amd64.deb because i needed it for conky nvidia configuration. the nvidia-settings does not have to match the driver version, but can't say what impact the newest settings have on the older drivers
Image

User avatar
Prsman
Level 4
Level 4
Posts: 222
Joined: Tue Nov 17, 2015 3:15 pm

Re: nvidia-settings stay at default. (SOLVED)

Post by Prsman » Wed Sep 26, 2018 12:43 pm

Well this is embarrassing, the problem is "operator error". Got to learn what does what. Thanks to everyone for the help. I'll go now.

Post Reply

Return to “Graphics Cards & Monitors”