Intel Broadwell Graphics Freezing

Screen resolution, 3D Acceleration, nVidia, ATI
Forum rules
Before you post please read this
Post Reply
tricolery
Level 1
Level 1
Posts: 6
Joined: Fri Jun 01, 2018 3:27 pm

Intel Broadwell Graphics Freezing

Post by tricolery » Wed Sep 26, 2018 9:19 am

This post was made on this thread: viewtopic.php?f=59&t=261389 , but user @smurphos suggested me to create a topic for this issue.

_____________________________________________________________________________________________________________________

Hello, I'm facing a strange issue on my linux mint 19 and Intel Broadwell processor/GPU.
Sometimes when I use a web browser (tested with google chrome and firefox) the image gets frozen, the computer receive the commands, but the image gets static for 3 seconds or so, then it returns to normal. I also facing the same problem when I play games, such as snes9x emulator or the pcsxr emulator. The same problem as the web browser, the image freezes, I can still hear the sound of the game playing, I can still use the controller, but the image stays static. Sometimes I'm on desktop just using the libreOffice and organizing my files and I see the same symptoms.
I've never had this problem when I was on mint 18.2, this started to happen on mint 19.

Info I can provide to you: (tell me if you need anything more):

I have this computer:
https://www.msi.com/Desktop/Cubi.html

This is my kernel: 4.15.0-34-generic

Everything is up to date.

This is the full output of inxi:

Code: Select all

System:    Host: suzumecubi Kernel: 4.15.0-34-generic x86_64
           bits: 64 gcc: 7.3.0
           Desktop: MATE 1.20.1 (Gtk 3.22.30) Distro: Linux Mint 19 Tara
Machine:   Device: desktop System: MICRO-STAR product: MS-B09611 serial: N/A
           Mobo: MICRO-STAR model: MS-B0961 v: 1.0 serial: N/A
           UEFI [Legacy]: American Megatrends v: EB096TAO V8.0B2 date: 12/03/2015
CPU:       Dual core Intel Pentium 3825U (-MT-MCP-) 
           arch: Broadwell rev.4 cache: 2048 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 7582
           clock speeds: max: 1900 MHz 1: 1452 MHz 2: 1014 MHz 3: 1271 MHz
           4: 1172 MHz
Graphics:  Card: Intel HD Graphics bus-ID: 00:02.0
           Display Server: x11 (X.Org 1.19.6 )
           drivers: modesetting (unloaded: fbdev,vesa)
           Resolution: 1920x1080@60.00hz
           OpenGL: renderer: Mesa DRI Intel Broadwell GT1
           version: 4.5 Mesa 18.0.5 Direct Render: Yes
Audio:     Card-1 Intel Broadwell-U Audio Controller
           driver: snd_hda_intel bus-ID: 00:03.0
           Card-2 Intel Wildcat Point-LP High Def. Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0
           Sound: Advanced Linux Sound Architecture v: k4.15.0-34-generic
Network:   Card-1: Realtek RTL8111/8168/8411 PCIE Gigabit Ethernet Controller
           driver: r8169 v: 2.3LK-NAPI port: e000 bus-ID: 02:00.0
           IF: enp2s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
           Card-2: Intel Wireless 3160 driver: iwlwifi bus-ID: 03:00.0
           IF: wlp3s0 state: down mac: <filter>
Drives:    HDD Total Size: 1128.2GB (68.6% used)
           ID-1: /dev/sda model: ST1000LM048 size: 1000.2GB
           ID-2: /dev/sdb model: MZMPC128HBFU size: 128.0GB
Partition: ID-1: / size: 111G used: 13G (12%) fs: ext4 dev: /dev/sdb1
           ID-2: /home size: 917G used: 703G (81%) fs: ext4 dev: /dev/sda
           ID-3: swap-1 size: 6.44GB used: 0.73GB (11%)
           fs: swap dev: /dev/sdb2
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 67.5C mobo: 31.0C
           Fan Speeds (in rpm): cpu: 2591 fan-1: 0 fan-4: 0 fan-5: 0
Info:      Processes: 222 Uptime: 2 days Memory: 1106.6/3827.1MB
           Init: systemd runlevel: 5 Gcc sys: 7.3.0
           Client: Shell (bash 4.4.191) inxi: 2.3.56 
What I tried so far:

-Installed the package: i965-va-driver ( didn't help anything)
-Removed the package xorg-xserver-video-intel (reinstalled it after when I saw I had not fixed the issue.)
-Created that famous 20-intel.conf (sna, dri true) file on my X11 folder. (Didn't help and both my vnc and my teamviewer went nuts. Everything that had a transparency didn't stop blinking)
-I also tried the steps described on this thread. The xserver-xorg-hwe-16.04 xserver-xorg-input-all-hwe-16.04 and edit the grub file.
-Monitored the temperature for one some time with (while true; do sensors | grep "Core"; sleep 1; done | awk '{print $3}') No strange temperature was recorded. The board didn't pass 68ºC.
-Stressed the gpu with glmark2 and glxgears. Strangely enough, I could not see the issue happening.
-I opened it and changed the thermal paste and cleaned the heat sink. Did not work either.

If you need anymore info I'm gladly collect it for you.

I also see an issue, don't know if it happens to everyone, when a tool tip is going to appear (i.e. I hover the mouse over the "show desktop" button and its tool tip appears) it quickly blinks on the top left edge of my screen, then it appears under the mouse. The exact same thing happens when I move a icon, the icon I'm moving quickly appears on top left edge of the screen then it appears under the mouse.
Don't know if these 2 issues are connected (the second issue does not even bother me), but I thought it would be a good idea to mention it.

What do you people think that is happening?
I know this computer is not common, but for my needs its perfect. It also makes a big energy economy on the end of the month. I casually turn my gaming rig on now. And I love the new mint 19, don't want to return to 18 series.

Thank you everyone!

English is not my main language, so sorry if I said anything strange.

tricolery
Level 1
Level 1
Posts: 6
Joined: Fri Jun 01, 2018 3:27 pm

Re: Intel Broadwell Graphics Freezing

Post by tricolery » Tue Jan 08, 2019 10:56 pm

Well.. Don't know what changed, but mint 19.1 fixed it...

Post Reply

Return to “Graphics Cards & Monitors”