Having trouble setting a refresh rate to 144Hz <SOLVED>

Screen resolution, 3D Acceleration, nVidia, ATI
Forum rules
Before you post please read this
Post Reply
TOSTERBROD
Level 1
Level 1
Posts: 7
Joined: Sat Sep 29, 2018 1:06 am

Having trouble setting a refresh rate to 144Hz <SOLVED>

Post by TOSTERBROD » Sat Sep 29, 2018 1:28 am

Hello, I'm new to the os and linux in general, my monitor supports 144Hz and in windows I could change it in the display setting, however here I cannot. I also tried changing it through nvidia x server setting but didn't find that option either.

details:
monitor: AOC G2460P
GPU: NVIDIA geforce gtx 980ti
OS: Linux Mint 19 Cinnamon 3.8.9
I know that others have posted similar issues but I didn't really understand the instructions and I would really appreciate If you'd help me.
Last edited by TOSTERBROD on Sun Sep 30, 2018 12:53 am, edited 1 time in total.

Tim09
Level 1
Level 1
Posts: 1
Joined: Sat Sep 29, 2018 5:38 am

Re: Having trouble setting a refresh rate to 144Hz

Post by Tim09 » Sat Sep 29, 2018 5:59 am

Actually NVIDIA X Server Settings worked for me:
Image

The frequency is set up as "Auto" on default, so i selected "144 Hz". Then i pressed the "Apply" Button, saved the changes to the X Configuration File and left NV Settings. If you reboot and notice that the frequency is again 60 Hz, do the same procedure again and then go into the Display settings and just click "Apply". This did the trick for me to save my setup.
Last edited by Moem on Sat Sep 29, 2018 6:12 am, edited 1 time in total.
Reason: Using the [rimg] tags (for remote images) makes your image appear directly inside the post.

TOSTERBROD
Level 1
Level 1
Posts: 7
Joined: Sat Sep 29, 2018 1:06 am

Re: Having trouble setting a refresh rate to 144Hz

Post by TOSTERBROD » Sun Sep 30, 2018 12:52 am

Tim09 wrote:
Sat Sep 29, 2018 5:59 am
Actually NVIDIA X Server Settings worked for me:
Image

The frequency is set up as "Auto" on default, so i selected "144 Hz". Then i pressed the "Apply" Button, saved the changes to the X Configuration File and left NV Settings. If you reboot and notice that the frequency is again 60 Hz, do the same procedure again and then go into the Display settings and just click "Apply". This did the trick for me to save my setup.
Thank you so much for your help!

Post Reply

Return to “Graphics Cards & Monitors”