[SOLVED] Booting when only the driver for the secondary GPU is enabled

Screen resolution, 3D Acceleration, nVidia, ATI
Forum rules
Before you post please read this
Post Reply
Asgatoril
Level 1
Level 1
Posts: 2
Joined: Mon Oct 22, 2018 10:08 am

[SOLVED] Booting when only the driver for the secondary GPU is enabled

Post by Asgatoril » Mon Oct 22, 2018 10:44 am

Hi,

I'm trying to set up GPU Passthrough from my Mint 19 (x64, Cinnamon) Host to my Windows 10 x64 VM.
For this I'm redirecting the calls to the faster graphics card, a small Nvidia card, to a dummy driver and blacklist the nouveau at boot time with a kernel parameter via grub.
The integrated Graphics, Intel 630, stays enabled for my Mint system.
This works fairly well, but the mainboard gives me some trouble.
In the BIOS GPU-Settings I can only select:
IGD, which completely disables the PEG. It won't show up in lshw.
PEG, which completely disables the IGD. It won't show up in lshw.
Auto, which uses PEG as primary and IGD secondary GPU

There is no option to set the IGD as primary GPU and the PEG as secondary.

Now to my problem: If I set the GPU priority to "Auto", which is the only option, which will enable both GPUs, I can use the Monitor on my IGD to manuever through grub and can see the Mint bootscreen, but as soon as the boot is finished and I should get either to the loginmanager or the desktop, the monitor won't get a signal anymore. If I use Ctrl+Alt+Del, the PC reboots and I can see the Mint logo again.
Everything else doesn't seem to do anything. I can't change to other ttys (or at least can't see it). Setting the Loginmanager to autologin also brings no better results.
If I change the primary GPU to IGD Mint boots as usual, albeit only with the Monitor connected to the IGD (which is the outcome I want for Auto, since the other GPU is disabled via grub)
If I change the kernel parameter back to normal and set the primary device to Auto, Mint starts as usual with both monitors.

So, does someone know how to get the GUI to show up, when the driver for the primary GPU is blacklisted but the secondary GPU is available?

Thanks a lot in advance!
Last edited by Asgatoril on Tue Oct 23, 2018 4:09 am, edited 1 time in total.

Asgatoril
Level 1
Level 1
Posts: 2
Joined: Mon Oct 22, 2018 10:08 am

Re: Booting when only the driver for the secondary GPU is enabled

Post by Asgatoril » Tue Oct 23, 2018 4:08 am

Got it to work. Just needed to add video=efifb:off as kernel parameter in my grub config and create a file "10-intel.conf" in /usr/share/X11/xorg.conf.d with this content:

Code: Select all

Section "Device"
        Identifier      "Device0"
        Driver          "intel"
        VendorName      "Intel"
        BusID           "PCI:0:2:0"
EndSection

Post Reply

Return to “Graphics Cards & Monitors”