Mint 19 Nvidia update problem, rendering in software mode (Solved)

Screen resolution, 3D Acceleration, nVidia, ATI
Forum rules
Before you post please read this
Post Reply
stevep3129
Level 2
Level 2
Posts: 88
Joined: Mon Sep 21, 2015 6:10 pm
Location: Oregon

Mint 19 Nvidia update problem, rendering in software mode (Solved)

Post by stevep3129 » Mon Oct 22, 2018 11:12 pm

When I booted up it came up with "Rendering in software mode."
Searching Mint forum I found the following post.
viewtopic.php?f=59&t=279210&p=1536857&h ... e#p1536857
The symptoms on my PC are identical.
The hardware configuration is very close to mine.
Mine is after getting fixing(?), rendering in software mode.

Code: Select all

steve@steve ~ $ inxi -Fxz
System:    Host: steve Kernel: 4.15.0-38-generic x86_64 bits: 64 gcc: 7.3.0
           Desktop: Cinnamon 3.8.9 (Gtk 3.22.30-1ubuntu1)
           Distro: Linux Mint 19 Tara
Machine:   Device: desktop System: ASUS product: All Series serial: N/A
           Mobo: ASUSTeK model: Z97-A-USB31 v: Rev 1.xx serial: N/A
           UEFI: American Megatrends v: 2501 date: 06/24/2015
Battery    hidpp__0: charge: N/A condition: NA/NA Wh
           model: Logitech Wireless Mouse M325 status: Discharging
CPU:       Quad core Intel Core i5-4690K (-MCP-) 
           arch: Haswell rev.3 cache: 6144 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 27999
           clock speeds: max: 4300 MHz 1: 1376 MHz 2: 1105 MHz 3: 1157 MHz
           4: 1152 MHz
Graphics:  Card: NVIDIA GM206 [GeForce GTX 950] bus-ID: 01:00.0
           Display Server: x11 (X.Org 1.19.6 )
           drivers: nouveau (unloaded: modesetting,fbdev,vesa)
           Resolution: 1920x1080@60.00hz
           OpenGL: renderer: NV126 version: 4.3 Mesa 18.0.5 Direct Render: Yes
Audio:     Card-1 NVIDIA Device 0fba driver: snd_hda_intel bus-ID: 01:00.1
           Card-2 Intel 9 Series Family HD Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0
           Sound: Advanced Linux Sound Architecture v: k4.15.0-38-generic
Network:   Card: Intel Ethernet Connection (2) I218-V
           driver: e1000e v: 3.2.6-k port: f040 bus-ID: 00:19.0
           IF: eno1 state: up speed: 100 Mbps duplex: full mac: <filter>
Drives:    HDD Total Size: 1256.3GB (35.0% used)
           ID-1: /dev/sda model: MKNSSDRE256GB size: 256.1GB
           ID-2: /dev/sdb model: WDC_WD10EZEX size: 1000.2GB
Partition: ID-1: / size: 219G used: 53G (26%) fs: ext4 dev: /dev/sda2
           ID-2: swap-1 size: 17.11GB used: 0.00GB (0%)
           fs: swap dev: /dev/sda3
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 29.8C mobo: 27.8C
           Fan Speeds (in rpm): cpu: 0
Info:      Processes: 186 Uptime: 25 min Memory: 4669.3/15977.1MB
           Init: systemd runlevel: 5 Gcc sys: 7.3.0
           Client: Shell (bash 4.4.191) inxi: 2.3.56 
steve@steve ~ $ 
Followed suggestions in the post, didn't help.
Ran Timeshift file dated 2018-09-29, which was good point, as far as I can recall.
Everything was back, no "Rendering in software mode"
Rebooted and ran Update Manager.
Rebooted, "Rendering in software mode" was back!
Reran Timeshift and Update Manager deselecting Nvidia updates.

Everything seems to be running OK without these updates.
There is a a problem on my desktop with one or all these updates, not going to mess around with them any more.
I hope someone can figure out if this a Nvidia or Mint problem.
Attachments
Screenshot from 2018-10-22 18-32-36.png
Last edited by stevep3129 on Thu Nov 08, 2018 9:45 pm, edited 1 time in total.

stevep3129
Level 2
Level 2
Posts: 88
Joined: Mon Sep 21, 2015 6:10 pm
Location: Oregon

Re: Mint 19 Nvidia update problem, rendering in software mode (Solved)

Post by stevep3129 » Thu Nov 08, 2018 9:41 pm

I had another problem to which the solution was to disable Secure Boot.
That worked and on hunch I ran the Nvidia update.
It also solved this problem.

jimsvarkey
Level 1
Level 1
Posts: 1
Joined: Tue Jun 06, 2017 1:59 am

Re: Mint 19 Nvidia update problem, rendering in software mode (Solved)

Post by jimsvarkey » Tue Nov 20, 2018 12:34 am

I have a very similar issue. Since this is a fresh install, I don't have timeshift. Right now my system boots into software rendering mode and the desktop looks as if it has a very low resolution. The drivers in the driver manger are often greyed out and you can't change the driver from it.

After booting, if I press ctrl+alt+backspace and logs in again the problem would be over but only till next boot. Hope this issue will resolve soon.

stevep3129
Level 2
Level 2
Posts: 88
Joined: Mon Sep 21, 2015 6:10 pm
Location: Oregon

Re: Mint 19 Nvidia update problem, rendering in software mode (Solved)

Post by stevep3129 » Tue Nov 20, 2018 9:19 pm

When rebooting your PC go into BIOS and make Secure Boot is Disabled!
By good fortune that was a simple solution to my problem.
If that doesn't help start a new post. That way you will get lot more views about your problem and more experienced users can help.
Also the post the output of the terminal command

Code: Select all

inxi -Fxz
.
It is a help to see what your machine is and makes it easier for other users to help you.

Post Reply

Return to “Graphics Cards & Monitors”