Page 1 of 1

Mint 18.3 Cinnamon not recognising monitor [SOLVED]

Posted: Mon Oct 29, 2018 2:55 pm
by fotoderek
Hello,
I have acquired a new PC and installed Mint 18 Cinnamon from the cover disk of Linux Format 214. The kernel is 4.4.0-138 generic. The graphics are handled by Intel Corporation Device 3e90 (prog-if 00 [VGA controller]) and the monitor is AOC E2270SWHN of 1920x1080 (16:9). The Display application only shows the monitor as a laptop with 1024x768 screen and with no options for adjustment or correction. While tolerable for everyday tasks, this is not acceptable for photo editing or other graphics tasks.

Elsewhere I saw a recommendation to change the VGA cable, which didn't produce any improvement. I next followed the advice in fourth post from bottom of viewtopic.php?f=59&t=250485, namely

Code: Select all

sudo apt-get remove xserver-xorg-video-intel
and

Code: Select all

inxi -G
. The latter now shows

Code: Select all

Card: Intel Device 3e90
           Display Server: X.Org 1.18.3 drivers: fbdev (unloaded: vesa)
           Resolution: 1024x768@76.00hz
           GLX Renderer: Gallium 0.4 on llvmpipe (LLVM 3.8, 128 bits)
           GLX Version: 3.0 Mesa 11.2.0
.
Note that fbdev has not been removed, unlike in the example quoted.
Unfortunately the Display app. continues to insist my PC is a laptop with a small screen, presumably due to the continued presence of fbdev. Where do I go from here?

Thanks in anticipation of some help,
Derek.

Re: Mint 18.3.06 Cinnamon not recognising monitor

Posted: Mon Oct 29, 2018 3:30 pm
by roblm
I see you have another topic in the Newbie section so I got some info from there.

First reinstall the intel driver and then logout and back in: sudo apt install xserver-xorg-video-intel

Then use these commands and post the output: inxi -Gx and xrandr --prop

Re: Mint 18.3 Cinnamon not recognising monitor [SOLVED]

Posted: Tue Oct 30, 2018 6:41 am
by fotoderek
Hello robim,
My other topic has produced results far beyond the basic remit. I have installed the most up-to-date kernel, via

Code: Select all

sudo apt-get install --install-recommends linux-generic-hwe-16.04 xserver-xorg-hwe-16.04 
to match my new PC. The PC now recognises the monitor and the printer has regained full functionality. Consequently this thread acquires [SOLVED] status.
Thank you for your interest,
Derek.