configuration gets messeed up when system is idle or monitor turned off

Screen resolution, 3D Acceleration, nVidia, ATI
Forum rules
Before you post please read this
Post Reply
kalimerox
Level 1
Level 1
Posts: 30
Joined: Wed Nov 16, 2011 2:00 am

configuration gets messeed up when system is idle or monitor turned off

Post by kalimerox » Wed Oct 31, 2018 9:19 am

Hi there, I have 2 monitors running on my system. Whenever the system goes idle or i switch off one of the monitors the configurations gets messed up and i need to re configure it in the display manager. Is there a way to fix these settings? I have a 4k dell monitor and a hd lg working with a amd graphics card. Thank you!!

EDIT:
I m not sure if i posted this to the right section, if not feel free to move the thread...

User avatar
roblm
Level 9
Level 9
Posts: 2799
Joined: Sun Feb 24, 2013 2:41 pm

Re: configuration gets messeed up when system is idle or monitor turned off

Post by roblm » Thu Nov 01, 2018 2:03 pm

Open the Terminal, use these commands and post the output: inxi -SMCGx and xrandr

kalimerox
Level 1
Level 1
Posts: 30
Joined: Wed Nov 16, 2011 2:00 am

Re: configuration gets messeed up when system is idle or monitor turned off

Post by kalimerox » Mon Nov 12, 2018 2:35 pm

Code: Select all

inxi -SMCGx 
System:    Host: kalimerox-H55M-UD2H Kernel: 4.15.0-38-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: Xfce 4.12.3 (Gtk 2.24.28) Distro: Linux Mint 18.3 Sylvia
Machine:   Mobo: Gigabyte model: H55M-UD2H v: x.x
           Bios: Award v: F9 date: 05/28/2010
CPU:       Quad core Intel Core i7 870 (-HT-MCP-) cache: 8192 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 23464
           clock speeds: max: 3223 MHz 1: 2440 MHz 2: 3005 MHz 3: 2875 MHz
           4: 2951 MHz 5: 2944 MHz 6: 3223 MHz 7: 3028 MHz 8: 3076 MHz
Graphics:  Card: Advanced Micro Devices [AMD/ATI] Device 67df bus-ID: 01:00.0
           Display Server: X.Org 1.18.4 drivers: ati,amdgpu (unloaded: fbdev,vesa,radeon)
           Resolution: 3840x2160@60.00hz, 1920x1080@60.00hz
           GLX Renderer: AMD Radeon RX 480 Graphics (POLARIS10 / DRM 3.23.0 / 4.15.0-38-generic, LLVM 6.0.0)
           GLX Version: 3.0 Mesa 18.0.5 Direct Rendering: Yes

Code: Select all

xrandr
Screen 0: minimum 320 x 200, current 5760 x 2160, maximum 16384 x 16384
DisplayPort-0 disconnected (normal left inverted right x axis y axis)
DisplayPort-1 connected primary 3840x2160+1920+0 (normal left inverted right x axis y axis) 597mm x 336mm
   3840x2160     60.00*+  29.98  
   2560x1440     59.95  
   1920x1200     59.88  
   1920x1080     60.00    50.00    59.94    24.00    23.98  
   1600x1200     60.00  
   1680x1050     59.95  
   1280x1024     75.02    60.02  
   1440x900      60.00  
   1280x800      59.81  
   1152x864      75.00  
   1280x720      60.00    50.00    59.94  
   1024x768      75.03    60.00  
   800x600       75.00    60.32  
   720x576       50.00  
   720x480       60.00    59.94  
   640x480       75.00    60.00    59.94  
   720x400       70.08  
HDMI-A-0 connected 1920x1080+0+0 (normal left inverted right x axis y axis) 480mm x 270mm
   1920x1080     60.00*+  50.00    59.94  
   1680x1050     59.88  
   1400x1050     59.95  
   1600x900      60.00  
   1280x1024     75.02    60.02  
   1440x900      59.90  
   1280x800      59.91  
   1152x864      75.00  
   1280x720      60.00    50.00    59.94  
   1024x768      75.03    60.00  
   800x600       75.00    60.32  
   720x576       50.00  
   720x480       60.00    59.94  
   640x480       75.00    60.00    59.94  
   720x400       70.08  
HDMI-A-1 disconnected (normal left inverted right x axis y axis)
DVI-D-0 disconnected (normal left inverted right x axis y axis)


User avatar
roblm
Level 9
Level 9
Posts: 2799
Joined: Sun Feb 24, 2013 2:41 pm

Re: configuration gets messeed up when system is idle or monitor turned off

Post by roblm » Tue Nov 13, 2018 9:15 am

Try using this command when the problem happens:

Code: Select all

xrandr --output DisplayPort-1 --mode 3840x2160 --primary --rate 60 --pos 1920x0 --output HDMI-A-0 --mode 1920x1080 --rate 60 --pos 0x0
If that works, then create a desktop launcher by right clicking on the desktop and selecting Create Launcher. Type a Name, such as xrandr. For the Command, add the xrandr line above. Right click on the launcher and select Properties > Permissions. Mark the checkbox next to Allow this file to run as a program.

Post Reply

Return to “Graphics Cards & Monitors”