Can't go back from Nvidia drivers to nouveau

Screen resolution, 3D Acceleration, nVidia, ATI
Forum rules
Before you post please read this
Post Reply
kmph
Level 3
Level 3
Posts: 118
Joined: Sun Oct 12, 2014 3:18 pm

Can't go back from Nvidia drivers to nouveau

Post by kmph » Wed Oct 31, 2018 2:38 pm

LM 19. A week ago or so I opened the Driver Manager, saw radio buttons: nvidia driver and xserver nouveau, the latter one checked. I checked nvidia, then clicked Apply changes, then waited until the process completed, then was prompted to reboot then clicked 'Reboot'.

Today I changed my mind. I went to the Driver Manager again, I checked nouveau, I clicked Apply changes, waited and accepted to Reboot.

However, once the computer opened again, I can still see nvidia's icon in my system tray! And the driver manager incorrectly states that (a) I have a manually installed driver (b) no proprietary drivers are in use (c) both nvidia and nouveau are grayed out.

Here is how the situation looks like:

Image

Code: Select all

m@m-X555LJ:~$ inxi -Fxz
System:    Host: m-X555LJ Kernel: 4.15.0-38-generic x86_64 bits: 64 gcc: 7.3.0
           Desktop: Cinnamon 3.8.9 (Gtk 3.22.30-1ubuntu1) Distro: Linux Mint 19 Tara
Machine:   Device: laptop System: ASUSTeK product: X555LJ v: 1.0 serial: N/A
           Mobo: ASUSTeK model: X555LJ v: 1.0 serial: N/A
           UEFI: American Megatrends v: X555LJ.504 date: 08/04/2015
Battery    BAT0: charge: 28.6 Wh 100.1% condition: 28.6/37.3 Wh (77%) model: ASUSTeK ASUS status: Discharging
CPU:       Dual core Intel Core i5-5200U (-MT-MCP-) arch: Broadwell rev.4 cache: 3072 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 8787
           clock speeds: max: 2700 MHz 1: 986 MHz 2: 904 MHz 3: 1117 MHz 4: 1106 MHz
Graphics:  Card-1: Intel HD Graphics 5500 bus-ID: 00:02.0
           Card-2: NVIDIA GK208M [GeForce 920M] bus-ID: 04:00.0
           Display Server: x11 (X.Org 1.19.6 ) drivers: modesetting,nvidia (unloaded: fbdev,vesa,nouveau)
           Resolution: 1366x768@60.00hz
           OpenGL: renderer: GeForce 920M/PCIe/SSE2 version: 4.6.0 NVIDIA 390.77 Direct Render: Yes
Audio:     Card-1 Intel Wildcat Point-LP High Definition Audio Controller driver: snd_hda_intel bus-ID: 00:1b.0
           Card-2 Intel Broadwell-U Audio Controller driver: snd_hda_intel bus-ID: 00:03.0
           Sound: Advanced Linux Sound Architecture v: k4.15.0-38-generic
Network:   Card-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           driver: r8169 v: 2.3LK-NAPI port: 4000 bus-ID: 02:00.0
           IF: enp2s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
           Card-2: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter driver: ath9k bus-ID: 03:00.0
           IF: wlp3s0 state: down mac: <filter>
Drives:    HDD Total Size: 500.1GB (14.6% used)
           ID-1: /dev/sda model: ST500LM030 size: 500.1GB
Partition: ID-1: / size: 229G used: 68G (32%) fs: ext4 dev: /dev/dm-0
           ID-2: /boot size: 462M used: 224M (51%) fs: ext2 dev: /dev/sda5
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 44.0C mobo: N/A gpu: 0.0:44C
           Fan Speeds (in rpm): cpu: 2800
Info:      Processes: 234 Uptime: 25 min Memory: 1408.8/3847.5MB Init: systemd runlevel: 5 Gcc sys: 7.3.0
           Client: Shell (bash 4.4.191) inxi: 2.3.56

User avatar
roblm
Level 9
Level 9
Posts: 2795
Joined: Sun Feb 24, 2013 2:41 pm

Re: Can't go back from Nvidia drivers to nouveau

Post by roblm » Wed Oct 31, 2018 2:52 pm

That’s a bug in the operation of Driver Manager. Prior to Mint 19, the only time that message was seen was when a Nvidia driver was downloaded and installed from Nvidia’s website. Now it happens every time the Nviidia driver is installed and later removed using Driver Manager.

Open the Terminal and use this command to remove remaining Nvidia files: apt autoremove

If there is no change and the inxi output still shows nvidia after drivers:, then use this command to check for a
nvidia-graphics-drivers.conf file: ls /etc/modprobe.d

If it exists, then use this command to remove it: sudo rm /etc/modprobe.d/nvidia-graphics-drivers.conf

Then update the initial ramdisk and reboot: sudo update initramfs -u; reboot

kmph
Level 3
Level 3
Posts: 118
Joined: Sun Oct 12, 2014 3:18 pm

Re: Can't go back from Nvidia drivers to nouveau

Post by kmph » Wed Oct 31, 2018 4:29 pm

roblm wrote:
Wed Oct 31, 2018 2:52 pm
Open the Terminal and use this command to remove remaining Nvidia files: apt autoremove
Done. State of affairs after this command (and rebooting):

Image

Code: Select all

m@m-X555LJ:~$ inxi -Fxz
System:    Host: m-X555LJ Kernel: 4.15.0-38-generic x86_64 bits: 64 gcc: 7.3.0
           Desktop: Cinnamon 3.8.9 (Gtk 3.22.30-1ubuntu1) Distro: Linux Mint 19 Tara
Machine:   Device: laptop System: ASUSTeK product: X555LJ v: 1.0 serial: N/A
           Mobo: ASUSTeK model: X555LJ v: 1.0 serial: N/A
           UEFI: American Megatrends v: X555LJ.504 date: 08/04/2015
Battery    BAT0: charge: 28.6 Wh 100.1% condition: 28.6/37.3 Wh (77%) model: ASUSTeK ASUS status: Discharging
CPU:       Dual core Intel Core i5-5200U (-MT-MCP-) arch: Broadwell rev.4 cache: 3072 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 8787
           clock speeds: max: 2700 MHz 1: 2388 MHz 2: 2370 MHz 3: 1790 MHz 4: 2283 MHz
Graphics:  Card-1: Intel HD Graphics 5500 bus-ID: 00:02.0
           Card-2: NVIDIA GK208M [GeForce 920M] bus-ID: 04:00.0
           Display Server: x11 (X.Org 1.19.6 ) drivers: modesetting,nouveau (unloaded: fbdev,vesa)
           Resolution: 1366x768@60.00hz
           OpenGL: renderer: Mesa DRI Intel HD Graphics 5500 (Broadwell GT2)
           version: 4.5 Mesa 18.0.5 Direct Render: Yes
Audio:     Card-1 Intel Wildcat Point-LP High Definition Audio Controller driver: snd_hda_intel bus-ID: 00:1b.0
           Card-2 Intel Broadwell-U Audio Controller driver: snd_hda_intel bus-ID: 00:03.0
           Sound: Advanced Linux Sound Architecture v: k4.15.0-38-generic
Network:   Card-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           driver: r8169 v: 2.3LK-NAPI port: 4000 bus-ID: 02:00.0
           IF: enp2s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
           Card-2: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter driver: ath9k bus-ID: 03:00.0
           IF: wlp3s0 state: down mac: <filter>
Drives:    HDD Total Size: 500.1GB (14.6% used)
           ID-1: /dev/sda model: ST500LM030 size: 500.1GB
Partition: ID-1: / size: 229G used: 68G (32%) fs: ext4 dev: /dev/dm-0
           ID-2: /boot size: 462M used: 225M (52%) fs: ext2 dev: /dev/sda5
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 43.0C mobo: N/A
           Fan Speeds (in rpm): cpu: 2600
Info:      Processes: 222 Uptime: 3 min Memory: 902.2/3847.5MB Init: systemd runlevel: 5 Gcc sys: 7.3.0
           Client: Shell (bash 4.4.191) inxi: 2.3.56 

Code: Select all

m@m-X555LJ:~$ ls /etc/modprobe.d
alsa-base.conf                  blacklist-modem.conf
amd64-microcode-blacklist.conf  blacklist-oss.conf
blacklist-ath_pci.conf          blacklist-rare-network.conf
blacklist.conf                  dkms.conf
blacklist-firewire.conf         intel-microcode-blacklist.conf
blacklist-framebuffer.conf      iwlwifi.conf
As you can see inxi stops displaying nvidia and there is no nvidia-graphics-drivers.conf in /etc/modprobe.d.

However, nvidia icon is still present in system tray and clicking it still makes nvidia x server settings pop up.

ajgringo619
Level 5
Level 5
Posts: 544
Joined: Thu Mar 01, 2018 8:36 pm
Location: San Diego, California

Re: Can't go back from Nvidia drivers to nouveau

Post by ajgringo619 » Wed Oct 31, 2018 4:57 pm

Go to Settings --> Session and Startup, then uncheck any Nvidia programs.
[Mint 19 XFCE, AMD FX-8350 Eight-Core w/16 GB RAM, 4.15.0-42-generic, GeForce GTX 960 w/Nvidia 415.18]
Image

User avatar
roblm
Level 9
Level 9
Posts: 2795
Joined: Sun Feb 24, 2013 2:41 pm

Re: Can't go back from Nvidia drivers to nouveau

Post by roblm » Wed Oct 31, 2018 5:19 pm

That’s normal for that icon to still be there. What’s not normal is that it shows Nvidia Mode when clicked. After removing the Nvidia driver, it should show Intel Mode. This is due to some more buggy operation of nvidia-prime. To get that back to normal, use this command in the Terminal and reboot: sudo prime-select intel

When you get back to the desktop, it should show Intel Mode when clicked.

Post Reply

Return to “Graphics Cards & Monitors”