AMD APU+AMD GPU Laptop - Can't turn on dedicated graphics

Screen resolution, 3D Acceleration, nVidia, ATI
Forum rules
Before you post please read this
rdlf4
Level 1
Level 1
Posts: 20
Joined: Sun Jul 02, 2017 9:53 pm

Re: AMD APU+AMD GPU Laptop - Can't turn on dedicated graphics

Post by rdlf4 » Mon Nov 12, 2018 10:57 am

My laptop is running on battery right now. Launchers have been created. I double-clicked Userspace, typed in my password but so far it's still on 1.8Ghz.
Not looking good, I guess it was supposed to be at max frequency all the time.
cpufreq-info still says:

Code: Select all

current policy: frequency should be within 1.40 GHz and 1.80 GHz.
Trying Tomb Raider in order to check the CPU speed. It's confirmed, it just won't go any higher than 1.8Ghz.
https://imgur.com/a/AQDsQOv

I guess the only way to go about it is to set the cpu frequency using cpupower.
Problem is, cpupower messes up my governors. For instance, supposing that I have ignore_ppc1 set to 1 and then I choose governor performance, doing

Code: Select all

cpupower frequency-set --max 2700000 --min 1800000
will set the minimum and maximum frequency to all the governors, instead of just the one I choose.

I'm running out of ideas.

User avatar
roblm
Level 9
Level 9
Posts: 2792
Joined: Sun Feb 24, 2013 2:41 pm

Re: AMD APU+AMD GPU Laptop - Can't turn on dedicated graphics

Post by roblm » Tue Nov 13, 2018 10:24 am

I made a mistake in my previous post. The value of 3500000 in this line is for my system. I assume you changed it to 2700000?

Code: Select all

echo "3500000" | sudo tee /sys/devices/system/cpu/cpu*/cpufreq/scaling_setspeed

If I use the command cpupower help frequency-set, I see these options:
-d --min <FREQ>
new minimum CPU frequency the governor may select.

-u --max <FREQ>
new maximum CPU frequency the governor may select.

-g --governor <GOV>
new cpufreq governor.

-f --freq <FREQ>
specific frequency to be set. Requires userspace governor to be available and loaded.

-r --related
modify all hardware-related CPUs at the same time

Try using these commands after using ignore_ppc=1:

Code: Select all

echo "userspace" | sudo tee /sys/devices/system/cpu/cpu*/cpufreq/scaling_governor
sudo cpupower frequency-set --freq 2700000

Post Reply

Return to “Graphics Cards & Monitors”