Linux Mint 19 Intel graphics

Screen resolution, 3D Acceleration, nVidia, ATI
Forum rules
Before you post please read this
Post Reply
rr92
Level 1
Level 1
Posts: 4
Joined: Tue Dec 03, 2013 4:42 am

Linux Mint 19 Intel graphics

Post by rr92 » Tue Nov 13, 2018 8:27 pm

Hi all, recently I installed Linux Mint 19. I purge nvidia drivers, reinstall and prove all to trying to switch to Intel graphic card. Last thing I change in nvidia prime but it doesnt work. Please I need to change it. Here is my Inxi -Fxz output:

Code: Select all

roberto@roberto-GL62M-7RDX:~$ inxi -Fxz
System:    Host: roberto-GL62M-7RDX Kernel: 4.15.0-39-generic x86_64
           bits: 64 gcc: 7.3.0
           Desktop: Cinnamon 3.8.9 (Gtk 3.22.30-1ubuntu1)
           Distro: Linux Mint 19 Tara
Machine:   Device: laptop System: Micro-Star product: GL62M 7RDX v: REV:1.0 serial: N/A
           Mobo: Micro-Star model: MS-16J9 v: REV:1.0 serial: N/A
           UEFI: American Megatrends v: E16J9IMS.31C date: 10/24/2017
Battery    BAT1: charge: 35.2 Wh 88.3% condition: 39.8/42.4 Wh (94%)
           model: MSI BIF0_9 status: Charging
CPU:       Quad core Intel Core i7-7700HQ (-MT-MCP-) 
           arch: Skylake rev.9 cache: 6144 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 22464
           clock speeds: max: 3800 MHz 1: 3437 MHz 2: 3427 MHz 3: 3427 MHz
           4: 3403 MHz 5: 3421 MHz 6: 3421 MHz 7: 3421 MHz 8: 3400 MHz
Graphics:  Card-1: Intel Device 591b bus-ID: 00:02.0
           Card-2: NVIDIA GP107M [GeForce GTX 1050 Mobile] bus-ID: 01:00.0
           Display Server: x11 (X.Org 1.19.6 )
           drivers: modesetting (unloaded: fbdev,vesa)
           Resolution: 1920x1080@60.01hz
           OpenGL: renderer: Mesa DRI Intel HD Graphics 630 (Kaby Lake GT2)
           version: 4.5 Mesa 18.0.5 Direct Render: Yes
Audio:     Card Intel CM238 HD Audio Controller
           driver: snd_hda_intel bus-ID: 00:1f.3
           Sound: Advanced Linux Sound Architecture v: k4.15.0-39-generic
Network:   Card-1: Intel Device 24fb driver: iwlwifi bus-ID: 02:00.0
           IF: wlp2s0 state: down mac: <filter>
           Card-2: Qualcomm Atheros QCA8171 Gigabit Ethernet
           driver: alx port: d000 bus-ID: 03:00.0
           IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives:    HDD Total Size: 1256.3GB (0.9% used)
           ID-1: /dev/sda model: TOSHIBA_THNSNJ25 size: 256.1GB
           ID-2: /dev/sdb model: HGST_HTS541010B7 size: 1000.2GB
Partition: ID-1: / size: 106G used: 7.3G (8%) fs: ext4 dev: /dev/sda5
           ID-2: /home size: 445G used: 137M (1%) fs: ext4 dev: /dev/sdb3
           ID-3: swap-1 size: 4.10GB used: 0.00GB (0%)
           fs: swap dev: /dev/sda6
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 55.0C mobo: 27.8C
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 236 Uptime: 0 min Memory: 595.6/7896.5MB
           Init: systemd runlevel: 5 Gcc sys: 7.3.0
           Client: Shell (bash 4.4.191) inxi: 2.3.56 
The led from MSI is still orange (Nvidia card) when I changed to intel. Thanks for all.

firepower
Level 1
Level 1
Posts: 38
Joined: Fri Sep 01, 2017 7:39 pm

Re: Linux Mint 19 Intel graphics

Post by firepower » Sun Nov 18, 2018 3:14 am

To change prime mode use terminal command 'prime-select nvidia | intel | query'
you need to log out and back in for mode change to take affect. (restart maybe more reliable if logout not work)

to find out what mode your using:
sudo prime-select query

to change mode Intel to nvidia
sudo prime-select nvidia

to change mode nvidia to intel
sudo prime-select intel

you can also change prime modes in nvidia control panel and then reboot.
prime.png

Post Reply

Return to “Graphics Cards & Monitors”