(SOLVED) Occasional screen flicker and black square around windows

Screen resolution, 3D Acceleration, nVidia, ATI
Forum rules
Before you post please read this
User avatar
roblm
Level 11
Level 11
Posts: 3520
Joined: Sun Feb 24, 2013 2:41 pm

Re: Occasional screen flicker and black square around windows

Post by roblm » Mon Dec 31, 2018 8:02 pm

You can test using a mode with a lower refresh rate, which will then be below the pixel clock limit of 165 MHz. This mode is using 54 Hz and was generated by umc (universal modeline calculator).

Change the Modeline in the xorg.conf file to this:

Code: Select all

Modeline "2560x1080_53.92"  162.50  2560 2608 2640 2720  1080 1083 1087 1108  +HSync -VSync
Change the MetaModes line to this:

Code: Select all

Option "MetaModes" "DP-0: 2560x1080_53.92 +1920+0, DP-1: nvidia-auto-select +0+0"

Also, test a mode with a 50 Hz refresh rate:

Code: Select all

Modeline "2560x1080_49.94"  150.25  2560 2608 2640 2720  1080 1083 1087 1106  +HSync -VSync
Option "MetaModes" "DP-0: 2560x1080_49.94 +1920+0, DP-1: nvidia-auto-select +0+0"

redpinkoZ1917
Level 1
Level 1
Posts: 46
Joined: Sun Dec 09, 2018 11:22 pm

Re: Occasional screen flicker and black square around windows

Post by redpinkoZ1917 » Mon Dec 31, 2018 8:20 pm

roblm wrote:
Mon Dec 31, 2018 8:02 pm
You can test using a mode with a lower refresh rate, which will then be below the pixel clock limit of 165 MHz. This mode is using 54 Hz and was generated by umc (universal modeline calculator).

Change the Modeline in the xorg.conf file to this:

Code: Select all

Modeline "2560x1080_53.92"  162.50  2560 2608 2640 2720  1080 1083 1087 1108  +HSync -VSync
Change the MetaModes line to this:

Code: Select all

Option "MetaModes" "DP-0: 2560x1080_53.92 +1920+0, DP-1: nvidia-auto-select +0+0"

Also, test a mode with a 50 Hz refresh rate:

Code: Select all

Modeline "2560x1080_49.94"  150.25  2560 2608 2640 2720  1080 1083 1087 1106  +HSync -VSync
Option "MetaModes" "DP-0: 2560x1080_49.94 +1920+0, DP-1: nvidia-auto-select +0+0"

Code: Select all

[ 20698.207] (WW) NVIDIA(GPU-0):     Mode is rejected: VertRefresh (53.9 Hz) out of range
[ 20698.207] (WW) NVIDIA(GPU-0):     (56.000-75.000 Hz).
How do I circumvent this? I haven't been able to find a refresh rate that falls within both parameters.

User avatar
roblm
Level 11
Level 11
Posts: 3520
Joined: Sun Feb 24, 2013 2:41 pm

Re: Occasional screen flicker and black square around windows

Post by roblm » Mon Dec 31, 2018 8:32 pm

Oops! I forgot about checking that supported 56.00-75.00 Hz range. You would have to change the line in the xorg.conf file to VertRefresh 54.0 - 75.0, but that is probably not a good idea.

redpinkoZ1917
Level 1
Level 1
Posts: 46
Joined: Sun Dec 09, 2018 11:22 pm

Re: Occasional screen flicker and black square around windows

Post by redpinkoZ1917 » Mon Dec 31, 2018 8:40 pm

roblm wrote:
Mon Dec 31, 2018 8:32 pm
Oops! I forgot about checking that supported 56.00-75.00 Hz range. You would have to change the line in the xorg.conf file to VertRefresh 54.0 - 75.0, but that is probably not a good idea.
No problem. I'll just wait for the new hardware. Thanks again, and happy new year! As it turns out, my switch does support 4k but only a 30hz refresh rate for it, so hopefully this new switch will solve the problem.

redpinkoZ1917
Level 1
Level 1
Posts: 46
Joined: Sun Dec 09, 2018 11:22 pm

Re: Occasional screen flicker and black square around windows

Post by redpinkoZ1917 » Thu Jan 03, 2019 9:03 pm

So the new switch solved my problem. I switched from this to this.

I am thinking it has to do with the EDID emulator, the 60hz refresh rate compatibility, or both in the new KVM switch. Hopefully this thread might help someone in the future.

Cheers!

Post Reply

Return to “Graphics Cards & Monitors”