AMD hybrid graphics still don't switch for the fourth year in a row

Screen resolution, 3D Acceleration, nVidia, ATI
Forum rules
Before you post please read this
Post Reply
a.bowers
Level 2
Level 2
Posts: 54
Joined: Mon Nov 24, 2014 3:50 pm

AMD hybrid graphics still don't switch for the fourth year in a row

Post by a.bowers »

Linux Mint 19.1. Kernel 4.15.0.43.

My hybrid graphics still won't behave themselves. I can't get my Radeon card to turn on. I'll try to give the output of some vaguely useful shell commands.

Code: Select all

lspci -k | grep -EA3 'VGA|Display'
00:02.0 VGA compatible controller: Intel Corporation Haswell-ULT Integrated Graphics Controller (rev 0b)
	Subsystem: Dell Haswell-ULT Integrated Graphics Controller
	Kernel driver in use: i915
	Kernel modules: i915
--
08:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Opal XT [Radeon R7 M265]
	Subsystem: Dell Opal XT [Radeon R7 M265]
	Kernel driver in use: radeon
	Kernel modules: radeon, amdgpu

Code: Select all

sudo cat /sys/kernel/debug/vgaswitcheroo/switch
0:DIS: :DynOff:0000:08:00.0
1:IGD:+:Pwr:0000:00:02.0

Code: Select all

sudo cat /etc/default/grub
# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_TIMEOUT_STYLE=hidden
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash radeon.modeset=1 radeon.runpm=1"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"
Even if I weren't already struggling to understand how any of this crap fits together and works, this one completely melts my brain: If I attempt to echo OFF or DIS into VGAswitcheroo, I get "permission denied" even with sudo. Commands prefaced with DRI_Prime=1 either have no effect and are run on the Intel graphics, or it fails after a few seconds with a long-winded error message.

How do I get it working and KEEP it working?

Post Reply

Return to “Graphics Cards & Monitors”