Mint 19.1 Screen Flicker in Cinnnamon with Intel HD3000

Screen resolution, 3D Acceleration, nVidia, ATI
Forum rules
Before you post please read this
Post Reply
hogfan
Level 2
Level 2
Posts: 80
Joined: Fri Apr 20, 2012 10:08 pm

Mint 19.1 Screen Flicker in Cinnnamon with Intel HD3000

Post by hogfan » Wed Jan 02, 2019 9:19 pm

Hello, hoping somebody can help me out in regards to solving some flickering issues I'm seeing in Cinnamon after upgrading to Mint 19 from 18.3. I've been running Mint 18 on this machine in the past with no issues. The issue seems to be more prevalent in the panel and Cinnamon menus. Below is the info from my notebook. Any suggestions appreciated.

Code: Select all

jeremy@MINTBOOK19 ~ $ inxi -Fxz
System:
  Host: MINTBOOK19 Kernel: 4.18.0-13-generic x86_64 bits: 64 compiler: gcc 
  v: 7.3.0 Desktop: Cinnamon 4.0.8 Distro: Linux Mint 19.1 Tessa 
  base: Ubuntu 18.04 bionic 
Machine:
  Type: Portable System: Dell product: XPS L412Z v: A06 serial: <filter> 
  Mobo: Dell model: 008DD8 v: A00 serial: <filter> UEFI: Dell v: A06 
  date: 07/19/2012 
Battery:
  ID-1: BAT1 charge: 9.0 Wh condition: 24.9/58.0 Wh (43%) 
  model: SANYO DELL RMTVY239 status: Discharging 
CPU:
  Topology: Dual Core model: Intel Core i5-2450M bits: 64 type: MT MCP 
  arch: Sandy Bridge rev: 7 L2 cache: 3072 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 19956 
  Speed: 798 MHz min/max: 800/3100 MHz Core speeds (MHz): 1: 798 2: 798 
  3: 798 4: 797 
Graphics:
  Device-1: Intel 2nd Generation Core Processor Family Integrated Graphics 
  vendor: Dell driver: i915 v: kernel bus ID: 00:02.0 
  Display: x11 server: X.Org 1.19.6 driver: modesetting unloaded: fbdev,vesa 
  resolution: 1366x768~60Hz 
  OpenGL: renderer: Mesa DRI Intel Sandybridge Mobile v: 3.3 Mesa 18.0.5 
  direct render: Yes 
Audio:
  Device-1: Intel 6 Series/C200 Series Family High Definition Audio 
  vendor: Dell driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
  Sound Server: ALSA v: k4.18.0-13-generic 
Network:
  Device-1: Qualcomm Atheros AR8151 v2.0 Gigabit Ethernet vendor: Dell 
  driver: atl1c v: 1.0.1.1-NAPI port: 3000 bus ID: 01:00.0 
  IF: enp1s0 state: down mac: <filter> 
  Device-2: Broadcom Limited BCM4352 802.11ac Wireless Network Adapter 
  vendor: AzureWave driver: wl v: kernel port: 3000 bus ID: 02:00.0 
  IF: wlp2s0 state: up mac: <filter> 
Drives:
  Local Storage: total: 465.76 GiB used: 42.86 GiB (9.2%) 
  ID-1: /dev/sda vendor: Crucial model: CT500MX200SSD1 size: 465.76 GiB 
Partition:
  ID-1: / size: 24.60 GiB used: 15.24 GiB (61.9%) fs: ext4 dev: /dev/sda10 
  ID-2: /home size: 90.95 GiB used: 27.63 GiB (30.4%) fs: ext4 
  dev: /dev/sda11 
  ID-3: swap-1 size: 2.15 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda13 
Sensors:
  System Temperatures: cpu: 48.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 230 Uptime: 22m Memory: 7.74 GiB used: 2.85 GiB (36.8%) 
  Init: systemd runlevel: 5 Compilers: gcc: 7.3.0 Shell: bash v: 4.4.19 
  inxi: 3.0.27 


User avatar
smurphos
Level 12
Level 12
Posts: 4097
Joined: Fri Sep 05, 2014 12:18 am
Location: Britisher
Contact:

Re: Min 19.1 Screen Flicker in Cinnnamon with Intel HD3000

Post by smurphos » Thu Jan 03, 2019 3:20 am

I've got very similar hardware - (i5-2430M) but I'm still using the 4.15 kernel series and I'm not seeing any issues.

See if disabling vblank in compositor options (Settings - General) makes any difference and/or switching back to the latest 4.15 kernel.
For custom Nemo actions, useful scripts for the Cinnamon desktop, and Cinnamox themes visit my Github pages.

hogfan
Level 2
Level 2
Posts: 80
Joined: Fri Apr 20, 2012 10:08 pm

Re: Min 19.1 Screen Flicker in Cinnnamon with Intel HD3000

Post by hogfan » Thu Jan 03, 2019 8:44 pm

Thanks for the suggestions! Disabling VBlank in the compositor settings and restarting Cinnamon appears to have fixed the issue for me. The odd thing is that I didn't see this issue when booted from the Mint 19.1 Tessa Live DVD.

hogfan
Level 2
Level 2
Posts: 80
Joined: Fri Apr 20, 2012 10:08 pm

Re: Min 19.1 Screen Flicker in Cinnnamon with Intel HD3000

Post by hogfan » Fri Jan 04, 2019 10:15 pm

Ok, things have gotten even weirder now. It appears the VBlank Compositor setting may not matter in my case. I just booted the machine up and the Cinnamon menu and panel was flickering like crazy. I went into the General settings and VBlank was still turned off. I turned it back, hit ALT+F2, typed in "r" and hit enter to restart Cinnamon. After the restarting Cinnamon, the flicker is gone again. So it appears that something is happening when the system first loads the Cinnamon desktop that is remedied after a Cinnamon restart.

I have the following items in my startup applications:

Cairo Dock
Conky
f.Lux
Cinnamon Settings Daemon - xrandr (Points to: /usr/lib/x86_64-linux-gnu/cinnamon-settings-daemon/csd-xrandr)

I disabled these one at a time and rebooted the machine but the flicker still exists. Once again, restarting Cinnamon resolves the issue for the remainder of my session.

User avatar
smurphos
Level 12
Level 12
Posts: 4097
Joined: Fri Sep 05, 2014 12:18 am
Location: Britisher
Contact:

Re: Min 19.1 Screen Flicker in Cinnnamon with Intel HD3000

Post by smurphos » Sat Jan 05, 2019 1:25 am

Did you try with kernel 4.15? I use conky, but no dock or f.Lux. xrandr is a standard startup item.
For custom Nemo actions, useful scripts for the Cinnamon desktop, and Cinnamox themes visit my Github pages.

hogfan
Level 2
Level 2
Posts: 80
Joined: Fri Apr 20, 2012 10:08 pm

Re: Mint 19.1 Screen Flicker in Cinnnamon with Intel HD3000

Post by hogfan » Sat Jan 05, 2019 2:41 pm

I did, tested going all the way back to a 4.4 kernel.

nkoropoff
Level 1
Level 1
Posts: 47
Joined: Fri Mar 21, 2014 12:32 pm

Re: Mint 19.1 Screen Flicker in Cinnnamon with Intel HD3000

Post by nkoropoff » Sat Jan 05, 2019 3:06 pm

I have encountered screen flashing (very random and infrequent) and also where the screen goes completely black for a couple of seconds going back to 18.3 Cinnamon. I have Intel HD 630 graphics. I think it is likely a result of using a 4K monitor at 3820 x 2160 @ 60 Hz. My wife's system is identical in every way except her display is running at 1920 x 1200 @ 60Hz and never encounters what I have. My motherboard was exchanged at 6 months age for a memory issue the the screen behavior never changes.

Update: forgot to mention this was on the 4.15 and 4.18 kernels.
Last edited by nkoropoff on Sun Jan 06, 2019 2:15 pm, edited 1 time in total.

User avatar
smurphos
Level 12
Level 12
Posts: 4097
Joined: Fri Sep 05, 2014 12:18 am
Location: Britisher
Contact:

Re: Mint 19.1 Screen Flicker in Cinnnamon with Intel HD3000

Post by smurphos » Sun Jan 06, 2019 4:30 am

No other bright ideas sorry - I did read about some LED displays with Intel graphics flickering at low brightness levels - is that relevant to you? I do get flickering as I adjust brightness - but not at any particular level.

If it is relevant here's the link https://wiki.archlinux.org/index.php/ba ... i915_only)
For custom Nemo actions, useful scripts for the Cinnamon desktop, and Cinnamox themes visit my Github pages.

Post Reply

Return to “Graphics Cards & Monitors”